none
Inicio de sesion Exchange 2010 imposible RRS feed

  • Pregunta

  • Buenas,

    Tengo un servidor Exchange 2010 al que se conectan versiones 2007 y 2010 de Outlook a traves de RPC y en general funciona bien, pero tengo unos cuantos usuarios que están experimentando problemas.

    Inicialmente les instalé los certificados, configuré la cuenta de Exchange en Outlook y conecté sin problemas. Estos usuarios tienen version es de Outlook 2007 y 2010 indistintamente y Windows XP SP3 como sistema operativo.

    El problema llega tras reiniciar el equipo y abrir Outlook, vuelve a pedir credenciales pero nunca las acepta, a pesar de que son correctas porque a traves de OWA si que entramos.

    He visto algunos hilos antiguos en el foro pero no tienen respuesta marcada.

    Alguna idea?

     

    Muchas gracias y feliz año a todos!


    miércoles, 4 de enero de 2012 11:22

Respuestas

Todas las respuestas

  • Algún error en el Visor de sucesos de los clientes? Y en Exchange?

    Si inicias el Outlook con la línea de comandos "outlook.exe /rpcdiag" puedes poner por aquí el resultado?


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCITP: Lync Server Administrator 2010
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card
    miércoles, 4 de enero de 2012 13:18
    Moderador
  • Hola Marc,

    En el visor de los clientes no veo nada, en el de "Microsoft Exchange with Database Availability Group Events" hay una advertencia y un error que se repiten a menudo, no he conseguido verificar si se producen en el momento en el que estos clientes intentan logarse pero te los pongo igualmente, tambien añado la ventana del rpcdiag.

    Tengo que decir que cuando sucede esto Outlook no hace ni siquiera intento de conexión, pide inmediatamente las credenciales de nuevo.

     

    Nombre de registro:Application
    Origen:        MSExchangeTransport
    Fecha:         05/01/2012 9:56:02
    Id. del evento:12024
    Categoría de la tarea:(12)
    Nivel:         Advertencia
    Palabras clave:Clásico
    Usuario:       No disponible
    Equipo:        *******.******.com
    Descripción:
    Microsoft Exchange no pudo cargar el certificado con huella digital de 2E341AFB2944C04916283F083AF51EBB5B5CA769 del almacén personal del equipo local. Este certificado estaba configurado para la autenticación con otros servidores de Exchange. El flujo de correo a otros servidores de Exchange puede verse afectado por este error. Si el certificado con esta huella digital aún existe en el almacén personal, ejecute Enable-ExchangeCertificate 2E341AFB2944C04916283F083AF51EBB5B5CA769 -Services SMTP para solucionar el problema. Si el certificado no existe en el almacén personal, recupérelo desde la copia de seguridad utilizando el cmdlet Import-ExchangeCertificate, o cree un certificado nuevo para el FQDN o el servidor habilitado para SMTP ejecutando el siguiente comando: New- ExchangeCertificate -DomainName serverfqdn -Services SMTP. Mientras tanto, se usa un certificado efímero autofirmado con huella digital 22B08CCAB04D2784D6E7358EFC8EF2D13E919D66.
    XML de evento:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchangeTransport" />
        <EventID Qualifiers="32772">12024</EventID>
        <Level>3</Level>
        <Task>12</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-01-05T08:56:02.000000000Z" />
        <EventRecordID>178731</EventRecordID>
        <Channel>Application</Channel>
        <Computer>*******.******.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data>2E341AFB2944C04916283F083AF51EBB5B5CA769</Data>
        <Data>22B08CCAB04D2784D6E7358EFC8EF2D13E919D66</Data>
      </EventData>
    </Event>

    -----------------------------------------------------------------------------------------------------------------------------------

    Nombre de registro:Application
    Origen:        MSExchangeTransport
    Fecha:         05/01/2012 9:56:02
    Id. del evento:12014
    Categoría de la tarea:(12)
    Nivel:         Error
    Palabras clave:Clásico
    Usuario:       No disponible
    Equipo:        ********.******.com
    Descripción:
    Microsoft Exchange no encontró un certificado que contenga el nombre de dominio *******.******.comen el almacén personal del equipo local. Por este motivo, no se puede ofrecer el verbo STARTTLS SMTP para el conector Default *****con un parámetro de FQDN de *******.******.com. Si el FQDN de conector no está especificado, se usará el FQDN del equipo. Compruebe la configuración del conector y los certificados instalados para asegurarse de que exista un certificado con un nombre de dominio para este FQDN. Si este certificado existe, ejecute Enable-ExchangeCertificate -Services SMTP para asegurarse de que el servicio de transporte de Microsoft Exchange tenga acceso a la clave de certificado.
    XML de evento:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchangeTransport" />
        <EventID Qualifiers="49156">12014</EventID>
        <Level>2</Level>
        <Task>12</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-01-05T08:56:02.000000000Z" />
        <EventRecordID>178732</EventRecordID>
        <Channel>Application</Channel>
        <Computer>*******.******.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data>arxinter2.arxinter.com</Data>
        <Data>Default ARXINTER2</Data>
      </EventData>
    </Event>

    -----------------------------------------------------------------------------------------------------------------------------------

    -----------------------------------------------------------------------------------------------------------------------------------

    Voy a ver si consigo capturar algun evento cuando se intentan conectar estos clientes.

    Saludos.

    jueves, 5 de enero de 2012 9:43
  • Olvide hacer un apunte.

    Me he fijado en que en los equipos que sucede esto, al entrar en la configuracion del proxy de Exchange, se ha marcado la opción de Conectar unicamente a servidores proxy en cuyo certificado figure este nombre principal: msstd:nombre_servidor_proxy

    Esta opción se rellena sola, si la desmarco y reinicio Outlook si que conecta una primera vez, pero al volver a reiniciarlo esta opción vuelve a activarse sola y ya no puede conectarse.

     

    Saludos,

    jueves, 5 de enero de 2012 10:21
  • Como me confirmas, los clientes Outlook con problemas no son capaces de conectarse por RPC al servidor. Aunque no es aconsejable, se puede configurar Exchange para que no guarde ningún valor sobre "MSSTD" o, mejor, darle el nombre que tiene el certificado con el que publicas el servicio, bien el nombre interno bien el externo.

    El cmdlet es Set-OutlookProvider. Recuerda que antes de tocar nada, debes apuntar los valores que tenga actualmenge (Get-OutlookProvider)

    Y tienes algo de información en http://www.agileit.com/Blog/Lists/Posts/Post.aspx?Id=278


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCITP: Lync Server Administrator 2010
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card
    jueves, 5 de enero de 2012 11:43
    Moderador
  • Hola Marc,

     

    Por fín he podido retomar el asunto.

    He leido el artículo y tiene todo el sentido del mundo, le he dado el nombre externo y estoy a la espera de que los usuarios que presentaban el problema me reporten resultados.

    En cuanto los tenga lo repoto y marco la respuesta.

    Saludos,

    Álvaro.

    martes, 17 de enero de 2012 9:02
  • Hola de nuevo,

    Esto sigue igual asi que al final estoy migrando a los usuarios a W7 y ya no tengo ese problema, curioso no?

    Saludos.

    • Marcado como respuesta Álvaro Martín miércoles, 15 de febrero de 2012 11:35
    miércoles, 15 de febrero de 2012 11:35
  • Sí, curioso ciertamente


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCITP: Lync Server Administrator 2010
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card

    miércoles, 15 de febrero de 2012 12:32
    Moderador