none
Migración de sbs2003 a una nueva máquina RRS feed

  • Pregunta

  • Hola a todos.

    Estoy intentando migrar mi SBS2003 a un nuevo servidor, ya que el que tenía se ha quedado obsoleto. Encontré el documento de Microsoft en el que se explican los pasos a seguir para poder llevar a cabo la migración en cuestión (Migrating windows small business server 2003 to new hardware).

    He ido siguiendo los pasos hasta que me indica que tengo que proseguir con la instalación de sbs 2003 (he añadido el nuevo servidor al dominio, lo he hecho controlador de dominio, he instalado y replicado el active directory, el dns, lo he hecho catálogo global y he transferido los roles del operation master, tal como se indica).

    La cuestión es que al intentar continuar con la instalación, en la ventana de requisitos del programa de instalación me dice que no se puede contactar con todos los controladores de dominio (en principio hay 2, el nuevo y el antiguo), pero en active directory me aparecen los dos... Y no puedo proseguir con la instalación.

    Tengo que borrar el controlador de dominio antiguo? Si alguien ha tenido que realizar la migración de sbs 2003 y se le ocurre algo sería genial, la verdad es que estoy atascado...

    Gracias,

    un saludo


    Raúl
    miércoles, 13 de agosto de 2008 11:26

Respuestas

  • Hola a todos,

     

    os escribo porque al final ya llevé a cabo la famosa migración de servidor. La implementé a lo largo del puente del Pilar para no causar molestias a los usuarios y por suerte salió todo bien.

     

    Lo que hice fue seguir al pie de la letra el manual de Microsoft "Migrating Windows Small Business Server 2003 to new hardware":

     

    http://technet.microsoft.com/en-us/library/cc747454.aspx

     

    la única pega la tuve en el comienzo del proceso. Una vez que había realizado los primeros pasos de la instalación, cuando iba a pasar a la parte "Continue Windows Small Business Server 2003 setup" (en dicho manual) no conseguía validar con éxito todos los puntos necesarios. De hecho, me pasaba igual que en la ocasión anterior, me decía "No se puede contactar  con todos los controladores de dominio". Como era un error y no una advertencia, no podía continuar con la instalación, así que llamé a Microsoft para que me dieran soporte técnico y me lo consiguieron solucionar.

     

    La solución que me propusieron en primera instancia no me pareció demasiado ortodoxa, pero otros casos que tenían con el mismo error los habían solucionado así, y a mi al final también me ha ido bien. Tuve que copiar todo el contenido del primer CD de instalación del sbs2003 al disco duro del servidor. Una vez copiado, tenemos que localizar el archivo "Setup.sdb" (en la carpeta "\setup\i386"). Lo abrimos con el Notepad y buscamos una línea en la que aparece una ristra de caracteres y a continuación: "AddtlDCCheck". En esa línea se hace la comprobación de los controladores de dominio, pero por algún motivo da problemas, así que lo que hay que hacer es poner un ";" al comienzo de esa línea para que no se ejecute (como si fuera un comentario). Guardamos el archivo y procedemos a ejecutar el Setup de la instalación. Veremos que en la ventana de requisitos del programa de instalación ya no aparece el error de verificación de los controladores de dominio y ¡por fin! podemos continuar con la instalación.

     

    A partir de ese punto seguí los pasos del manual y no tuve ningún problema hasta el final. Cuando ya tenía todo instalado, los clientes se conectaban correctamente a la red (se servía correctamente el dhcp, podían acceder a las carpetas compartidas, tenían internet, etc), resulta que no se podía acceder desde los clientes ni al correo ni a la página de company web. Después de buscar y rebuscar y no saber qué podía pasar, recibí ayuda de un amigo que es un crack (siempre que no se qué más hacer a él se le ocurre la solución, gracias Edgar), resulta que instalando un parche de Microsoft que salió después del sp2 de exchange se solucionaba. El parche es: kb948496. Lo instalé, reinicié el servidor y ya funcionaba todo.

     

    Os cuento todo por si alguno estáis en la misma situación que yo, ya que no he encontrado por internet ningún sitio en el que dieran solución al problema. Si tenéis alguna duda y os puedo ayudar no dudéis en preguntar.

     

     

    un saludo

    jueves, 23 de octubre de 2008 7:34

Todas las respuestas

  • Hola Raúl,

    estoy teniendo el mismo problema que tú ahora mismo, me gustaría saber si lo has solucionado y si es así, como?

    En mi caso estoy instalando un nuevo servidor con Windows 2003 SBS R2 para sustituir el antiguo Windows 2003 SBS.

     

    Ya lo he promocionado como DC, DNS, ya es catálogo global y he transferido todos los roles al nuevo server, se replica perfectamente pero igual que has comentado tú al proseguir con la instalación del SBS en la ventana de requisitos del programa de instalación me marca como bloqueo "No se puede contactar  con todos los controladores de dominio"

    He probado y resuelve correctamente por DNS los otros DC's la replicación es correcta.

     

    Si lo has solucionado agradecería enormemente que lo compartieras, ya que es algo que no está documentado y seguro que a muchos nos será de gran utilidad.

     

    Gracias de antemano, un saludo.

    miércoles, 3 de septiembre de 2008 15:14
  • Creo que no es el camino adecuado.

    Basicamente es necesario tener 2 dominios SBS, el antiguo y el nuevo, una vez que el nuevo esté preparado, hay que migrar mediante ADMT, los usuarios, grupos, pcs, etc. Mediante exmerge hay que migrar los buzones de exchange, y las bbdd de SQL Server haciendo un backup de las mismas a fichero y luego recuperandolas en el nuevo. Los ficheros mediante ROBOCOPY. Una vez migrado todo, hay que apagar el servidor antiguo.

    Mediante ADMT, se puede migrar todo, hasta los SID de los usuarios para conservar los permisos, la pertenencia a grupos, perfiles de los usuarios, recursos compartidos y permisos de las máquinas... etc... el documento correcto que hay que seguir: http://www.microsoft.com/downloads/details.aspx?FamilyID=fa187d1e-8218-4501-9729-222bd8ebb64c&DisplayLang=en (en inglés por supuesto).

    Es bueno echarle una lectura y hacerse un planning, ya que requiere un corte prolongado, también es bueno antes de hacer la migración definitiva hacer las pruebas pertinentes para migrar usuarios, máquinas etc..
    miércoles, 3 de septiembre de 2008 23:33
  • Hola,

    de momento no he conseguido solucionar el problema, ya que la idea era preparar el servidor aprovechando que la gente de la empresa estaba de vacaciones y ya han vuelto...

    De momento he pospuesto el tema hasta el puente de octubre, en el que lo volveré a intentar. Si llego al mismo punto intentaré que me den soporte en Microsoft sobre la migración, y a ver si hay suerte...

    Yo creo que debe de poderse hacer, ya que si Microsoft ha publicado un documento específico para migrar un sbs2003 de una máquina a otra (que es exactamente mi caso) será que ellos lo consiguen hacer así... otra cosa es que igual hacemos algo mal o bien hay algún problema en el servidor de origen que no permite hacer la migración...

    Si conseguís hacerlo ya nos diréis cómo lo habéis conseguido, ok? si me entero de algo lo pondré por aquí.


    un saludo
    jueves, 4 de septiembre de 2008 6:39
  • Te puedo asegurar que siguiendo ese documento he hecho un número considerable de migraciones, pero hay que seguir los pasos correctamente. De hecho he variado en varias veces el procedimiento del documento, para que las paradas fueran mínimas, pero es complicarlo mucho más.

     

    Como te digo, montate un entorno de pruebas y revisa que los pasos que vas dando son buenos.

     

    Saludos.

    jueves, 4 de septiembre de 2008 6:47
  • Hola Ignacio,

    entonces tu método es, por decirlo así, una red a parte independiente de la ya existente, e ir copiando todo digamos manualmente? (active directory, archivos compartidos, exchange server, ...). Porque en la misma red no pueden coexistir 'pacificamente' los dos sbs2003...

    En el documento que recomendabas en tu post anterior se especifica que está indicado para la migración desde un sbs2003 hacia un w essential business server 2008, y lo que yo voy a hacer es pasar de un sbs2003 premium a otro, no habrá ningún problema con esa documentación?

    Es un tema que me está llevando de cráneo, porque es bastante delicado (si lo hago mal tiro toda la empresa, y por eso quiero tenerlo todo bastante claro antes de pasar a llevarlo a cabo...).

    Gracias por tus comentarios.


    un saludo!
    jueves, 4 de septiembre de 2008 7:47
  • Pido disculpas, el link que puse no era correcto.

     

    En este está la documentación:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=fa187d1e-8218-4501-9729-222bd8ebb64c&DisplayLang=en

     

    De todas formas, he editado el otro link para evitar confusiones.

     

    El procedimiento digamos que no es automático 100%, es decir, puedes migrar AD con ADMT, digamos que en el documento cuenta como ir migrando cada una de las partes, aunque puedes automatizar gran parte.

     

    Realmente el tiempo de migración depende del hardware y del número de máquinas, pero vamos con ADMT unas 25 máquinas puedes tardar unas 2h, añade también el tiempo que tardas en migrar datos y los nuevos perfiles de los usuarios de Outlook, etc... etc... aunque para esto puedes hacer un despliegue de Outlook con un MST que modifque el perfil de Outlook apuntando al nuevo servidor, etc.

     

    Digamos que si lo tienes todo bien organizado puede llevarte 1 día la parte de traspaso de todo.

     

    Saludos.

    jueves, 4 de septiembre de 2008 7:53
  • Hola a todos,

     

    os escribo porque al final ya llevé a cabo la famosa migración de servidor. La implementé a lo largo del puente del Pilar para no causar molestias a los usuarios y por suerte salió todo bien.

     

    Lo que hice fue seguir al pie de la letra el manual de Microsoft "Migrating Windows Small Business Server 2003 to new hardware":

     

    http://technet.microsoft.com/en-us/library/cc747454.aspx

     

    la única pega la tuve en el comienzo del proceso. Una vez que había realizado los primeros pasos de la instalación, cuando iba a pasar a la parte "Continue Windows Small Business Server 2003 setup" (en dicho manual) no conseguía validar con éxito todos los puntos necesarios. De hecho, me pasaba igual que en la ocasión anterior, me decía "No se puede contactar  con todos los controladores de dominio". Como era un error y no una advertencia, no podía continuar con la instalación, así que llamé a Microsoft para que me dieran soporte técnico y me lo consiguieron solucionar.

     

    La solución que me propusieron en primera instancia no me pareció demasiado ortodoxa, pero otros casos que tenían con el mismo error los habían solucionado así, y a mi al final también me ha ido bien. Tuve que copiar todo el contenido del primer CD de instalación del sbs2003 al disco duro del servidor. Una vez copiado, tenemos que localizar el archivo "Setup.sdb" (en la carpeta "\setup\i386"). Lo abrimos con el Notepad y buscamos una línea en la que aparece una ristra de caracteres y a continuación: "AddtlDCCheck". En esa línea se hace la comprobación de los controladores de dominio, pero por algún motivo da problemas, así que lo que hay que hacer es poner un ";" al comienzo de esa línea para que no se ejecute (como si fuera un comentario). Guardamos el archivo y procedemos a ejecutar el Setup de la instalación. Veremos que en la ventana de requisitos del programa de instalación ya no aparece el error de verificación de los controladores de dominio y ¡por fin! podemos continuar con la instalación.

     

    A partir de ese punto seguí los pasos del manual y no tuve ningún problema hasta el final. Cuando ya tenía todo instalado, los clientes se conectaban correctamente a la red (se servía correctamente el dhcp, podían acceder a las carpetas compartidas, tenían internet, etc), resulta que no se podía acceder desde los clientes ni al correo ni a la página de company web. Después de buscar y rebuscar y no saber qué podía pasar, recibí ayuda de un amigo que es un crack (siempre que no se qué más hacer a él se le ocurre la solución, gracias Edgar), resulta que instalando un parche de Microsoft que salió después del sp2 de exchange se solucionaba. El parche es: kb948496. Lo instalé, reinicié el servidor y ya funcionaba todo.

     

    Os cuento todo por si alguno estáis en la misma situación que yo, ya que no he encontrado por internet ningún sitio en el que dieran solución al problema. Si tenéis alguna duda y os puedo ayudar no dudéis en preguntar.

     

     

    un saludo

    jueves, 23 de octubre de 2008 7:34