none
Problema tunel VPN+SBS2003 RRS feed

  • Pregunta

  • Hola, hasta esta mañana tenia funcionando un Tunel VPN entre dos oficinas con dos Zywall 2 PLus.
    Por un lado la oficina A (192.168.1.0/24) en la que teniamos conectado SOLO el servidor (SBS2003) con ip 192.168.1.66.
    Por otro la oficina B (192.168.2.0/24) en la que teniamos varios equipos y alguna copiadora, con carpetas compartidas y escritorio remoto.
    La comunicación era buena, sin problemas.
    Ésta mañana hemos tenido que reiniciar el servidor para actualizar uno de los programas.
    Al arrancar el servidor, el túnel funciona.
    Desde la oficina B, tengo ping con el Zywall2 remoto (192.168.1.3) pero no tengo ping con el servidor. Desde esta oficina incluso puedo administrar el Firewall remoto a través 192.168.1.3.

    Desde la oficina A, NO tengo ping con el Zywall2 remoto (192.168.2.2) ni por supuesto con ninguna de las máquinas de la red. Desde aquí no puedo administrar el Firewall 192.168.2.2.

    Entiendo que el problema tiene que estar en el servidor. ¿Pero dónde?
    Tengo firewall de los Zywall desactivados para simplificar. No se ha hecho ningun cambio de configuracion ni de IP ni nada.
    ¿alguna pista de por donde mirar?

    Muchas gracias
    Saludos
    lunes, 28 de febrero de 2011 18:09

Respuestas

  • Hola Jairo,

    Segun comentas entonces los routers de telefonica son las puertas de enlace en casa una de las oficinas. Entonces, si el tunel esta OK el problema esta en los routers.

    Es decir, necesitaras una ruta estatica en cada uno de ellos:

     1.- En el router de la oficina A una ruta estatica a 192.168.2.0/24 con gateway 192.168.1.3

     2.- En el router de la oficina B una ruta estatica a 192.168.1.0/24 con gateway 192.168.2.2

    Suerte

    Un saludo

     

     

     

     


    "Saber que se sabe lo que se sabe y que no se sabe lo que no se sabe; he aquí el verdadero saber." Confucio
    • Marcado como respuesta Ismael Borche miércoles, 27 de abril de 2011 0:45
    miércoles, 30 de marzo de 2011 14:22

Todas las respuestas

  • Hola Jairo,

    Primero probaría que desde el Zywall de la oficina A (192.168.1.3) tengas ping con el Zywall de la oficina B (192.168.2.2) y con los equipos de la oficna B (192.168.2.0/24) para descartar que el problema este en el tunel.

    Si estas pruebas van bien, el problema es del servidor, revisa las rutas. ¿Es el Zywall el gateway por defecto?. Yo pienso que el problema ha de ser de enrutamiento.

    Suerte

    Un saludo

     


    "Saber que se sabe lo que se sabe y que no se sabe lo que no se sabe; he aquí el verdadero saber." Confucio
    martes, 1 de marzo de 2011 10:27
  • Hola GregoJ. Gracias por responder.

    Desde la oficina A no tengo ping con nada de nada. Ni con el otro Zywall, ni con ningun equipo de esa red.

    Sin embargo desde la oficina B tengo ping con el Zywall A y con un DVR (192.168.1.64) que ni siquiera está conectado al Zywall (está a un switch anterior).

    He instalado Wireshark en el servidor y en otro equipo de la red B (192.168.2.67). Cuando hago ping desde éste equipo (192.168.2.67) al servidor (192.168.1.66), éste recibe la peticion, y además envía la respuesta, sin embargo, al equipo 192.168.2.67 no le llegan los paquetes de reply.

    ¿El fallo debe estar en el Tunel? Si es asi, ¿cómo esposible que haya ping con 192.168.1.64?

    Los dos Zywall estan funcionando como Bridge, no como router, porque en ambas oficinas necesitaban Wifi, asi que para evitar mas gasto estan los router zyxel de telefonica, y despues los firewall zyxel como bridge, y con el firewall desactivado.

    Segun el administrador de los zyxel, el tunel esta funcionando bien.

    Gracias

     

    EDITO:

    Desde la consola de ambos Zywall TENGO PING entre ellos.

    He instalado wireshark en el servidor y en un equipo de la red B para monitorizar el tráfico.

    Si desde 192.168.2.67 hago ping a 192.168.1.66 (servidor). Éste último recibe la petición y envía la respuesta. 192.168.2.67 NO RECIBE la respuesta.

    Si desde 192.168.2.67 hago ping a otras máquinas, no obtengo respuesta, ni desde la consola de zywall ni desde el propio pc, salvo el DVR (192.168.1.64).

     

    Si desde 192.168.1.66 hago ping a 192.168.2.67 no obtengo respuesta.

    Sin embargo si hago el ping a traves del zywal A (192.168.1.3) a 192.168.2.67 sí tengo respuesta.

    • Editado Jairo López martes, 1 de marzo de 2011 14:17 Añadir informacion
    martes, 1 de marzo de 2011 11:39
  • Hola Jairo,

    Segun comentas entonces los routers de telefonica son las puertas de enlace en casa una de las oficinas. Entonces, si el tunel esta OK el problema esta en los routers.

    Es decir, necesitaras una ruta estatica en cada uno de ellos:

     1.- En el router de la oficina A una ruta estatica a 192.168.2.0/24 con gateway 192.168.1.3

     2.- En el router de la oficina B una ruta estatica a 192.168.1.0/24 con gateway 192.168.2.2

    Suerte

    Un saludo

     

     

     

     


    "Saber que se sabe lo que se sabe y que no se sabe lo que no se sabe; he aquí el verdadero saber." Confucio
    • Marcado como respuesta Ismael Borche miércoles, 27 de abril de 2011 0:45
    miércoles, 30 de marzo de 2011 14:22