none
AMD, vmware y windows seven. Problemas en USB

    Pregunta

  • Buenas.

    Tengo un comercio de montaje de PCs y tambien doy soporte a software, problemas en instalaciones etc, que esto último es lo único que da dinero hoy día. Uno de los problemas mas comunes es que al usar herramientas de virtualización como vmware o virtualbox los USB no son reconocidos y en el caso de vmware el servicio "USB Arbitration Service" no arranca y da un error 31.

    Lo he probado con sistemas operativos windows seven recién instalados y unicamente con los drivers correspondientes a los dispositivos no reconocidos, resultando que siempre que reproduzco un error así es con tarjetas que tienen AMD, no sucediendome nunca con Intel. Es la unica diferencia que he encontrado ya que no veo otra lógica. ¿puede existir incompatibilidad entre AMD, vmware y seven? ¿hay algo que esté en mi mano hacer?

    Saludines.
    jueves, 11 de marzo de 2010 9:15

Respuestas

  • Buenas.

    Tengo un comercio de montaje de PCs y tambien doy soporte a software, problemas en instalaciones etc, que esto último es lo único que da dinero hoy día. Uno de los problemas mas comunes es que al usar herramientas de virtualización como vmware o virtualbox los USB no son reconocidos y en el caso de vmware el servicio "USB Arbitration Service" no arranca y da un error 31.

    Lo he probado con sistemas operativos windows seven recién instalados y unicamente con los drivers correspondientes a los dispositivos no reconocidos, resultando que siempre que reproduzco un error así es con tarjetas que tienen AMD, no sucediendome nunca con Intel. Es la unica diferencia que he encontrado ya que no veo otra lógica. ¿puede existir incompatibilidad entre AMD, vmware y seven? ¿hay algo que esté en mi mano hacer?

    Saludines.

    No tiene que ver Windows 7. Es un problema que sucede con vmware cuando algun software sustituye los drivers originales de Windows usbd.sys y usbhub.sys o bien mete filtros no compatibles sobre ellos.

    En particular, y al menos en el caso que expones, el culpable son los filtros AMD que hay que instalar en ciertas placas madre para dispositivos reconocidos como "AMD USB Filter Driver" o bien "AMD usb audio filter" por ejemplo.

    Lo tienes ampliamente documentado en los foros de vmware, por ejemplo:

    http://communities.vmware.com/message/1234623#1234623
    http://communities.vmware.com/message/1489822#1489822

    Tambien es verdad que si esto sucede posterior a la instalacion, y en ese caso puede suceder com AMD, Intel o lo que sea, es porque algun software montado hace la misma funcion: instalar filtros no compatibles. En esto se ha hecho famoso con software de telefonos moviles (Sony Ericson, por ejemplo), e incluso viejas versiones del iTunes que sustituyen medio stack USB, aunque no es tu caso, ya que te sucede justo nada mas instalar y sin nada mas que los drivers de placa madre, por lo que al ser AMD el problema es lo anterior que he citado.

    Puedes reparchear en el registro segun este documento del gurú de vmware:

    http://www.sanbarrow.com/workstation-faq.html#p8

    Ahora bien, mi consejo es no instalar los drivers de AMD, al menos el "AMD USB Filter Driver" ya que realmente no se nota para nada el usarlo o no (es decir no se notan mejorias y si se notan problemas).

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    • Marcado como respuesta raul.mh jueves, 11 de marzo de 2010 11:38
    jueves, 11 de marzo de 2010 9:32

Todas las respuestas

  • Buenas.

    Tengo un comercio de montaje de PCs y tambien doy soporte a software, problemas en instalaciones etc, que esto último es lo único que da dinero hoy día. Uno de los problemas mas comunes es que al usar herramientas de virtualización como vmware o virtualbox los USB no son reconocidos y en el caso de vmware el servicio "USB Arbitration Service" no arranca y da un error 31.

    Lo he probado con sistemas operativos windows seven recién instalados y unicamente con los drivers correspondientes a los dispositivos no reconocidos, resultando que siempre que reproduzco un error así es con tarjetas que tienen AMD, no sucediendome nunca con Intel. Es la unica diferencia que he encontrado ya que no veo otra lógica. ¿puede existir incompatibilidad entre AMD, vmware y seven? ¿hay algo que esté en mi mano hacer?

    Saludines.

    No tiene que ver Windows 7. Es un problema que sucede con vmware cuando algun software sustituye los drivers originales de Windows usbd.sys y usbhub.sys o bien mete filtros no compatibles sobre ellos.

    En particular, y al menos en el caso que expones, el culpable son los filtros AMD que hay que instalar en ciertas placas madre para dispositivos reconocidos como "AMD USB Filter Driver" o bien "AMD usb audio filter" por ejemplo.

    Lo tienes ampliamente documentado en los foros de vmware, por ejemplo:

    http://communities.vmware.com/message/1234623#1234623
    http://communities.vmware.com/message/1489822#1489822

    Tambien es verdad que si esto sucede posterior a la instalacion, y en ese caso puede suceder com AMD, Intel o lo que sea, es porque algun software montado hace la misma funcion: instalar filtros no compatibles. En esto se ha hecho famoso con software de telefonos moviles (Sony Ericson, por ejemplo), e incluso viejas versiones del iTunes que sustituyen medio stack USB, aunque no es tu caso, ya que te sucede justo nada mas instalar y sin nada mas que los drivers de placa madre, por lo que al ser AMD el problema es lo anterior que he citado.

    Puedes reparchear en el registro segun este documento del gurú de vmware:

    http://www.sanbarrow.com/workstation-faq.html#p8

    Ahora bien, mi consejo es no instalar los drivers de AMD, al menos el "AMD USB Filter Driver" ya que realmente no se nota para nada el usarlo o no (es decir no se notan mejorias y si se notan problemas).

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    • Marcado como respuesta raul.mh jueves, 11 de marzo de 2010 11:38
    jueves, 11 de marzo de 2010 9:32
  • Tenías razón José Manuel. En un PC que no me funcionaba el USB en virtual, he instalado de nuevo seven, no he montado los drivers de AMD y funciona vmware correctamente. Instalo los drivers de AMD para el USB y deja de funcionar.

    Muchas gracias.
    jueves, 11 de marzo de 2010 11:37
  • Tenías razón José Manuel. En un PC que no me funcionaba el USB en virtual, he instalado de nuevo seven, no he montado los drivers de AMD y funciona vmware correctamente. Instalo los drivers de AMD para el USB y deja de funcionar.

    Muchas gracias.

    ;-)

    Un saludo,

    Jose Manuel Tella Llop news://jmtella.com

    jueves, 11 de marzo de 2010 11:47
  • gracias JM. tenia el mismo problema.

    creo que este es el ultimo amd que monto.
    Mira si con linux se hace sin problemas, con windows tambien.

    http://img690.imageshack.us/img690/8705/snapshot9s.png

    jueves, 11 de marzo de 2010 22:38
  • muchas gracias JMT, me pasó lo mismo y lo he solucionado gracias a este mensaje.

    :)

    sábado, 13 de marzo de 2010 19:53
  • ESTIMADO JOSE MANUEL:

    LA TEORIA EXPLICADA ME SIRVIO DE MUCHO, Y EFECTIVAMENTE LOS FOROS RESPECTO A ELIMINAR EL ARCHIVO DE AMD USB AUDIO DRIVER FILTER , FUNCIONO SATISFACTORIAMENTE Y AHORA PUEDO UTILIZZAR EL VMWARE AL 100%.

    GRACIAS...

    ATTE.

    DANTE DIAZ G-(PERU).

    domingo, 11 de julio de 2010 5:37
  • ESTIMADO JOSE MANUEL:

    LA TEORIA EXPLICADA ME SIRVIO DE MUCHO, Y EFECTIVAMENTE LOS FOROS RESPECTO A ELIMINAR EL ARCHIVO DE AMD USB AUDIO DRIVER FILTER , FUNCIONO SATISFACTORIAMENTE Y AHORA PUEDO UTILIZZAR EL VMWARE AL 100%.

    GRACIAS...

    ATTE.

    DANTE DIAZ G-(PERU).

    ;-)

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    domingo, 11 de julio de 2010 7:16
  • Yo tenia el mismo problema y lo pude resolver.

    En el foro de VMware está explicado que es lo que hay que hacer para VMware Workstation 7.1.1 y VMware Player 3.1.1.

    Los pasos son los siguientes:

    1. Abrir el registro de windows en Menu Inicio > Ejecutar > regedit
    2. En el editor de registro ir a HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}.
    3. En el panel de la derecha, si existe la entrada UpperFilters hay que borrarla.
    4. Luego ir a HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\.
    5. Borrar la carpeta (string) usbfilter.
    6. Delete this file: %system32%\drivers\usbfilter.sys.
    7. Reiniciar.

    Al iniciar nuevamente la PC, si abren el VMware ya no tendrán mas el problema del USB y podran usar sus unidades USB perfectamente.

    Fuente: http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1016809

    Nota: Yo lo realice con un Windows 7 Ultimate x64 y con VMware 7.1.2 build-301548 y me funciono perfectamente
    martes, 02 de noviembre de 2010 17:12
  • hola! les comento que realice todo eso paso porque poseo el mismo problema pero no me funciono y ahora el problema es mayor porque tampoco me reconoe los usb bajo windows.

    tengo una hp dv4-2041nr con windows home premiun seven 64bits 

    por fa les agradezco sus ayuda!

     

    lunes, 15 de noviembre de 2010 14:24
  • hola! les comento que realice todo eso paso porque poseo el mismo problema pero no me funciono y ahora el problema es mayor porque tampoco me reconoe los usb bajo windows.

    tengo una hp dv4-2041nr con windows home premiun seven 64bits 

    por fa les agradezco sus ayuda!

     

    Pero... comenta un poco más tu problema. ¿donde no te funcionan en maquina real o virtual?.. el compañero que preguntó se referia a maquina virtual. Y ¿te pasa desde el principio?... Supongo que no, entonces dime todo el software que has instalado.

    Jose Manuel Tella Llop news://jmtella.com

    lunes, 15 de noviembre de 2010 16:40
  • Buenas.

    Tengo un comercio de montaje de PCs y tambien doy soporte a software, problemas en instalaciones etc, que esto último es lo único que da dinero hoy día. Uno de los problemas mas comunes es que al usar herramientas de virtualización como vmware o virtualbox los USB no son reconocidos y en el caso de vmware el servicio "USB Arbitration Service" no arranca y da un error 31.

    Lo he probado con sistemas operativos windows seven recién instalados y unicamente con los drivers correspondientes a los dispositivos no reconocidos, resultando que siempre que reproduzco un error así es con tarjetas que tienen AMD, no sucediendome nunca con Intel. Es la unica diferencia que he encontrado ya que no veo otra lógica. ¿puede existir incompatibilidad entre AMD, vmware y seven? ¿hay algo que esté en mi mano hacer?

    Saludines.

     

    Mi estimado, empiezo en esto, a ver si me explico.

    Comence a revisar las entradas del Regedit, no me aparece ninguna de las dos (UpperFilter , UsbFilter).

    En el Comentario que en envias, comentan que los controladores que hacen que no funcione bien, son los de Sony Ericsson, por ejemplo Conecto comunmente mi celular al equipo.

    Mi duda es como los quito, ya que desinstalo uno de nombre SonyEricsson seehcri Control Device.

    Ademas de otros 2 USB ROOT HUB (de los 5 que me aparecen), pero despues ya no me reconoce el teclado y el raton.

    En Mi caso que debo de hacer para poder desinstalar todos sin que me Afecte...??

    Y si mas Adelante, podre conectar mi Celular, o No...???

    En espera de sus comentarios, Saludos...

    martes, 14 de diciembre de 2010 0:54

  • No tiene que ver Windows 7. Es un problema que sucede con vmware cuando algun software sustituye los drivers originales de Windows usbd.sys y usbhub.sys o bien mete filtros no compatibles sobre ellos.

    En particular, y al menos en el caso que expones, el culpable son los filtros AMD que hay que instalar en ciertas placas madre para dispositivos reconocidos como "AMD USB Filter Driver" o bien "AMD usb audio filter" por ejemplo.

    Lo tienes ampliamente documentado en los foros de vmware, por ejemplo:

    http://communities.vmware.com/message/1234623#1234623
    http://communities.vmware.com/message/1489822#1489822

    Tambien es verdad que si esto sucede posterior a la instalacion, y en ese caso puede suceder com AMD, Intel o lo que sea, es porque algun software montado hace la misma funcion: instalar filtros no compatibles. En esto se ha hecho famoso con software de telefonos moviles (Sony Ericson, por ejemplo), e incluso viejas versiones del iTunes que sustituyen medio stack USB, aunque no es tu caso, ya que te sucede justo nada mas instalar y sin nada mas que los drivers de placa madre, por lo que al ser AMD el problema es lo anterior que he citado.

    Puedes reparchear en el registro segun este documento del gurú de vmware:

    http://www.sanbarrow.com/workstation-faq.html#p8

    Ahora bien, mi consejo es no instalar los drivers de AMD, al menos el "AMD USB Filter Driver" ya que realmente no se nota para nada el usarlo o no (es decir no se notan mejorias y si se notan problemas).

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    Mi estimado, empiezo en esto, a ver si me explico.

    Comence a revisar las entradas del Regedit, no me aparece ninguna de las dos (UpperFilter , UsbFilter).

    En el Comentario que en envias, comentan que los controladores que hacen que no funcione bien, son los de Sony Ericsson, por ejemplo Conecto comunmente mi celular al equipo.

    Mi duda es como los quito, ya que desinstalo uno de nombre SonyEricsson seehcri Control Device.

    Ademas de otros 2 USB ROOT HUB (de los 5 que me aparecen), pero despues ya no me reconoce el teclado y el raton.

    En Mi caso que debo de hacer para poder desinstalar todos sin que me Afecte...??

    Y si mas Adelante, podre conectar mi Celular, o No...???

    En espera de sus comentarios, Saludos...


    martes, 14 de diciembre de 2010 1:38