none
Evento de Error 1102 en Terminal Server 2008 al actualizar el cliente Windows XP RRS feed

  • Pregunta

  • Hola,

    Tengo un servidor Windows Server 2008 con Terminal Services, todos los clientes son Windows XP. 2 de estos clientes tienen una impresora de tickets con el driver "Generic / Text Only".

    Uno de estos clientes al actualizarse a traves del Windows Update, provoca un error en su conexión de Terminal Server con el evento 1102 (Driver not foud).
    He formateado el cliente y vuelto a instalar, con el sp3 y el escritorio remoto en su versión 6, funciona perfectamente, al realizar el resto de las actualizaciones pendientes es cuando falla.

    ¿Que es lo que puede estar fallando? o ¿Cual es la actualización que falla?
    miércoles, 26 de agosto de 2009 10:06

Respuestas

  • Victor,
    Me imagino que debe ser algo de .Net Framework  que hace que deje de funcionar el Terminal Services Easy Print driver en el cliente y al dejar de funcionar esta funcionalidad requiere el driver en el servidor, al no tener el driver en el servidor falla con ese evento
    en el siguien KB tienes algunas opciones para solucionar esto

    http://technet.microsoft.com/en-us/library/cc775290(WS.10).aspx

    Info de como funciona TS Easy Print
     http://technet.microsoft.com/en-us/library/cc753853(WS.10).aspx

    RDP 6.1
    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=6e1ec93d-bdbd-4983-92f7-479e088570ad

    En el cliente tienes algun tipo de eventos? tienes aplicada la GPO de habilita TS Easy Print?
    Gustavo Gurmandi - http://www.grupoitpro.com.ar/blogs/gustavog
    miércoles, 26 de agosto de 2009 13:10
  • Hola Gustavo,

    Gracias por responder, pero no me expliqué bien, el driver que quiero que use es el "Generic / Text Only", no el Terminal Services Easy Print, este driver mapea correctamente la impresora en el servidor pero no imprime nada en ella. 

    Realmente no es un problema del driver, he probado con varios drivers de impresoras que estan en el servidor y en varios equipos y el Id 1102, sólo me lo dá este equipo. En el resto de los equipos clientes todas las impresoras funcionan.

    Además he probado a conectar este equipo cliente a un servidor TS con Windows 2003 y el mapeo de la impresora funciona correctamente.

    Le he cambiado el nombre al equipo cliente (ya por desesperacion) y sigue sin funcionar.

    Mientras iba escribiendo este mensaje estaba haciendo pruebas con los equipos, he conseguido que mapease correctamente la impresora y lo que hice fue desinstalar el Framework 2 y un driver para framework.

    Mañana actualizaré el sistema otra vez, para comprobar exactamente que es lo que falla. Ya te comentaré.

    Saludos,

    Victor
    jueves, 27 de agosto de 2009 12:56

Todas las respuestas

  • Victor,
    Me imagino que debe ser algo de .Net Framework  que hace que deje de funcionar el Terminal Services Easy Print driver en el cliente y al dejar de funcionar esta funcionalidad requiere el driver en el servidor, al no tener el driver en el servidor falla con ese evento
    en el siguien KB tienes algunas opciones para solucionar esto

    http://technet.microsoft.com/en-us/library/cc775290(WS.10).aspx

    Info de como funciona TS Easy Print
     http://technet.microsoft.com/en-us/library/cc753853(WS.10).aspx

    RDP 6.1
    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=6e1ec93d-bdbd-4983-92f7-479e088570ad

    En el cliente tienes algun tipo de eventos? tienes aplicada la GPO de habilita TS Easy Print?
    Gustavo Gurmandi - http://www.grupoitpro.com.ar/blogs/gustavog
    miércoles, 26 de agosto de 2009 13:10
  • Hola Gustavo,

    Gracias por responder, pero no me expliqué bien, el driver que quiero que use es el "Generic / Text Only", no el Terminal Services Easy Print, este driver mapea correctamente la impresora en el servidor pero no imprime nada en ella. 

    Realmente no es un problema del driver, he probado con varios drivers de impresoras que estan en el servidor y en varios equipos y el Id 1102, sólo me lo dá este equipo. En el resto de los equipos clientes todas las impresoras funcionan.

    Además he probado a conectar este equipo cliente a un servidor TS con Windows 2003 y el mapeo de la impresora funciona correctamente.

    Le he cambiado el nombre al equipo cliente (ya por desesperacion) y sigue sin funcionar.

    Mientras iba escribiendo este mensaje estaba haciendo pruebas con los equipos, he conseguido que mapease correctamente la impresora y lo que hice fue desinstalar el Framework 2 y un driver para framework.

    Mañana actualizaré el sistema otra vez, para comprobar exactamente que es lo que falla. Ya te comentaré.

    Saludos,

    Victor
    jueves, 27 de agosto de 2009 12:56