none
No puedo mover un buzon de una base de datos a otra. Exchange 2010 SP3 RU5 RRS feed

  • Pregunta

  • Estimados,

    Intento mover un buzon de una base de datos a otra base y no puedo.

    Informo que no solo es con ese buzon el problema. Son todos los buzones. Ninguno se puede cambiar.

    Informo que se hizo una nueva base de datos para ver si eran las bases e igual el problema sigue.

    Verifique la bases y una tiene diferencia con la otra en limites de los buzones. Y aun asi no se puede.

    Verifique las bases y son identicamente iguales en su configuracion y aun asi no puedo pasar cualquier buzon.

    Hice buzones nuevo para ver si era problema de los buzones antiguos y tampoco.

    Los buzones nuevos no tenia ni un correo e igual no pasa. Ingrese con el buzon y envie correo y me respondieron, e igual no puedo pasar el buzon de base de datos.

    Lo hice tanto por GUI como por CLI y aun asi no funciona, siempre se qued asi:

    En cola y puede durar dias, y no pasa nada, aun asi teniendo un solo correo la cuenta o ningun correo.

    Ya ejecute los comando:

    Test-AssistantHealth, Test-ServiceHealth, Test-Mailflow, Test-MRSHealth, Test-ReplicationHealth  y se ejecutan sin reportar ningun error.

    Ejecute el Script movemailbox.p1 el cua lesta en los scripts de Exchange con lo siguiente:

    .\MoveMailbox.ps1 -identity test6789 -TargetDatabase "tu base"

    Y se queda asi:

    Alguna ayuda, opinio o resolucion.

    Gracias,


    Edwin Duran Ospina Si la respuesta ha Colaborado con tu solución, favor marcarla como correcta.

    miércoles, 7 de octubre de 2015 18:55

Todas las respuestas

  • Que tal Edwin,

    Que te muestra el comando: Get-MoveRequest | Get-MoveRequestStatistics ?

    Te recomiendo que intentes ejecutar el move request en modo offline y de igual manera que le incrementes el valor de -Baditemlimit. Podria ser un tema de corrupcion de elementos en los buzones que se moveran

    Navega a la ruta de tus binarios, comunmente: unidad>\Program Files\Microsoft\Exchange Server\V14\Bin

    Y abre el archivo de configuracion: msexchangemailboxreplication.exe.config

    Aqui te dejo un articulo de Technet donde explican los parametros. Valida que todo este en orden

    No esta demas que suependas y quites los move requests activos reinicies el servicio de Mailbox Replication e intentes de nuevo

    Si tu ambiente cuenta con alta disponibilidad, debes considerar eso como variable, ya que hay otro valores dentro del archivo de configuración que debes validar como lo son:

    DataGuaranteeCheckPeriod 
    EnableDataGuaranteeCheck

    mas el valor de: DataMoveReplicationConstrain en las bases de datos

    Saludos y espero esta información te sea de utilidad


    Saludos | Senior Consultant Messaging & Communications | MCITP-MCSA-MCSE-MCT-MVP


    miércoles, 7 de octubre de 2015 22:25
  • estimado, Al ejecutar el comando, el cual ya he ejecutado varias veces: ================================================================= [PS] E:\Program Files\Microsoft\Exchange Server\V14\Scripts>Get-MoveRequest | Get-MoveRequestStatistics | fl RunspaceId : c164c045-08dc-4cc2-900a-ea4798c12d69 MailboxIdentity : dominio.com/Users/test514 aqui DistinguishedName : CN=test514 aqui,CN=Users,DC=dominio,DC=com DisplayName : test514 aqui Alias : test514 ExchangeGuid : 0fe32926-9428-4ffa-bc55-53b2292ecfd2 ArchiveGuid : Status : Queued StatusDetail : Queued SyncStage : None Flags : IntraOrg, Pull RequestStyle : IntraOrg Direction : Pull IsOffline : False Protect : False Priority : Normal Suspend : False SuspendWhenReadyToComplete : False IgnoreRuleLimitErrors : False SourceVersion : Version 14.3 (Build 181.0) SourceDatabase : datos1 TargetVersion : Version 14.3 (Build 123.0) TargetDatabase : datos2 SourceArchiveDatabase : SourceArchiveVersion : TargetArchiveDatabase : TargetArchiveVersion : RemoteHostName : RemoteGlobalCatalog : BatchName : RemoteCredentialUsername : RemoteDatabaseName : RemoteDatabaseGuid : RemoteArchiveDatabaseName : RemoteArchiveDatabaseGuid : TargetDeliveryDomain : ArchiveDomain : BadItemLimit : 0 BadItemsEncountered : AllowLargeItems : False QueuedTimestamp : 07-10-2015 20:16:16 StartTimestamp : LastUpdateTimestamp : 07-10-2015 20:16:16 InitialSeedingCompletedTimestamp : FinalSyncTimestamp : CompletionTimestamp : SuspendedTimestamp : OverallDuration : 00:00:08 TotalFinalizationDuration : TotalDataReplicationWaitDuration : TotalSuspendedDuration : TotalFailedDuration : TotalQueuedDuration : 00:00:08 TotalInProgressDuration : TotalStalledDueToHADuration : TotalTransientFailureDuration : MRSServerName : TotalMailboxSize : 724 B (724 bytes) TotalMailboxItemCount : 1 TotalArchiveSize : TotalArchiveItemCount : BytesTransferred : BytesTransferredPerMinute : ItemsTransferred : PercentComplete : 0 PositionInQueue : 3/3 (Position/Queue Length) FailureCode : FailureType : FailureSide : Message : FailureTimestamp : FailureContext : IsValid : True ValidationMessage : RequestGuid : 2f41373d-c30e-42e9-912d-07499024693c RequestQueue : datos2 Identity : RequestGuid (0fe32926-9428-4ffa-bc55-53b2292ecfd2), RequestQueue: (cf5fae4a-7453-4f3 3-85bb-9ee6974dde4e) Report : ====================================================================== Tambien Informo que lo he intentando con el Valor -Baditemlimit: ======================================================================== New-MoveRequest -Identity 'test23' -PrimaryOnly -TargetDatabase "datos2" -BadItemLimit 200 -AcceptLargeDataLoss - whatif ======================================================================== Ademas de los siguientes comandos: New-MoveRequest –Identity test23 –TargetDatabase ‘datos2’ New-MoveRequest –Identity test23 –TargetDatabase ‘datos2’ | ft –AutoSize -Wrap De igual manera verifique que el valor de la base de datos IsExcludedFromProvisioning $False. Y lo configure a $True. ================================================================= Set-MailboxDatabase ‘datos2’ –IsExcludedFromProvisioning $True ================================================================= Tambien ejecute los siguientes: ================================================================= *- Get-moverequest *- Get-MoveRequest -MoveStatus inprogress ================================================================= Lo intente mover por medio de ps1 MoveMailbox.ps1 ================================================================= .\MoveMailbox.ps1 -identity test23 -TargetDatabase "datos2" ================================================================= Por otro lado tambien ya revise el archivo que tu indicaste: ================================================================= Setting Name - Default, MinValue, MaxValue MaxRetries - 60, 0, 1000 MaxCleanupRetries - 5, 0, 100 RetryDelay - 00:00:30, 00:00:10, 00:30:00 MaxMoveHistoryLength - 2, 0, 100 MaxActiveMovesPerSourceMDB - 5, 0, 100 MaxActiveMovesPerTargetMDB - 2, 0, 100 MaxActiveMovesPerSourceServer - 50, 0, 1000 MaxActiveMovesPerTargetServer - 5, 0, 1000 MaxTotalMovesPerMRS - 100, 0, 1024 FullScanMoveJobsPollingPeriod - 00:10:00, 00:03:00, 1.00:00:00 MinimumTimeBeforePickingJobsFromSameDatabase - 00:00:04, 00:00:00, 01:00:00 ServerCountsNotOlderThan - 00:10:00, 00:00:00, 01:00:00 MRSAbandonedMoveJobDetectionTime - 01:00:00, 01:00:00, 12:00:00 BackoffIntervalForProxyConnectionLimitReached - 00:30:00, 00:00:30, 1.00:00:00 DataGuaranteeCheckPeriod - 00:00:10, 00:00:01, 02:00:00 DataGuaranteeTimeout = 00:30:00, 00:00:00, 12:00:00 DataGuaranteeLogRollDelay = 00:01:00, 00:00:00, 12:00:00 EnableDataGuaranteeCheck = false, false, true DisableMrsProxyCompression = false, false, true DisableMrsProxyBuffering = false, false, true ============================================================================= Esto esta tal como se indica la norma de microsoft. Dado que se revisa. lo unoco que me hace falta por hacer es DataMoveReplicationConstrain, que por defecto viene en secondcopy y quiero ponerla en none, luego regresarla, pero no creo que solucione el problema. Yo ya revise con el Test-MSRHealth y todo esta bien, osea que el servicio de la replicacion de Exchange de los buzones, esta correcto. Ayer tuve problemas con El DAG el cual perdieron los permisos, y lo solucione. Yo creo que es por ese lado. que las copias no estan saludables(Aunque el informe aparecen que estan bien). Creo que los indixes sean los malos. Ayudame a visionar por donde puede ser el error, dado que ya hice todo lo que tu me comentas. Saludos,

    Edwin Duran Ospina Si la respuesta ha Colaborado con tu solución, favor marcarla como correcta.

    miércoles, 7 de octubre de 2015 23:35
  • Estimado,

    Ejecuto lo siguiente:

    Set-MailboxDatabase -Identity databasename -DataMoveReplicationConstraint None

    Reinicio en los dos CAS el servicio Exchange Replication Manager; y de una me pasa los Buzones a la otra Base de datos.

    Ingreso de nuevo al original de Microsoft:

    Set-MailboxDatabase -Identity databasename -DataMoveReplicationConstraint SecondCopy.

    Reinicio en los dos CAS el servicio Exchange Replication Manager; y me queda de nuevo en cola el traspaso del buzon.

    Como lo puedo solucionar?

    Que debo fijarme?

    Esto es entonces seguro un problema de replicacion, dado que el comando


    Edwin Duran Ospina Si la respuesta ha Colaborado con tu solución, favor marcarla como correcta.


    jueves, 8 de octubre de 2015 2:55