none
De Windows Server 2003 R2 a Windows Server 2008 R2 RRS feed

  • Pregunta

  • Cambie de Servidor y de O.S de server 2003 R2 a server 2008 R2. El servidor se cambio de urgencia, porque el anterior se quemo, asi que todo se levanto desde cero.

    Ahora que levante mis respaldos de los sistemas que se usaban, Mis usuarios me dicen que los sistemas estan lentos, tengo como 15 usuarios y todos usan Workstation con windows XP professional. Necesito correr alguna utileria o algo para mejorar el desempeño de mis sistemas. Los sistemas que estan corriendo actualmente son Quickbooks (contablidad), MTI Horizon (Transporte). No me explico que pueda estar pasando. Mi dominio anterior se llamaba CALVINK y al actual lo nombre como TNEXPRESS, todo lo levante desde cero, no emigre nada.

    Neesito correr alguna utileria de windows 2008 R2 o alguien tiene una idea de lo que pudiera estar pasando??????

     

    martes, 22 de marzo de 2011 4:12

Respuestas

  • Hola Carmen,

    revisa este enlace, ojala te sirva:

    http://www.youtube.com/watch?v=_DCkWqbMGio

    por otro lado, en las propiedades de la configuración de red IPV4 de tu SErvidor debe estar su misma dirección IP como Servidor primario de DNS y secundario puedes poner al de Internet.

    En tus clientes puedes ejecutar el comando ipconfig /flushdns para vaciar toda la cache de cada uno de ellos.

    A mi me sirvió en las propiedades del DNS Server (Dentro de la consola de administración DNS) limpiar todos los registros que apuntaban a mi Server a una dirección vieja, ejemplo: mi Server actual tiene la ip 192.168.0.122----mx.local y existian registros que apuntaban a 192.168.0.2----mx.local, cuando borre estos ultimos pude entonces agregar PCs al dominio sin problemas.

    Como decia Leo Ponti, asegurate que en el scope que hayas creado este bien configuradas todas las preferencias de la red, ya que estas serán las que tomen tus equipos clientes para navegar en la red local, todas tus PCs deben tener como Server primario al server local.

    Espero haber ayudado.

    Saludos cordiales,

    AOrtega

    • Propuesto como respuesta Ismael Borche lunes, 18 de abril de 2011 18:59
    • Marcado como respuesta Ismael Borche martes, 19 de abril de 2011 20:34
    martes, 12 de abril de 2011 18:01

Todas las respuestas

  • Hola Carmen

    El nuevo servidor, cual configuración de hardware tiene? es la misma que en 2003?

    Y cual antivirus tenía en 2003 y cual tiene ahora en 2008

    Saludos


    Ismael Borche - LATAM Forum Support Engineer
    Microsoft Corporation
    viernes, 25 de marzo de 2011 0:43
  • Hola Carmen

    Otro punto es acerca de los clientes. Como está configurado el DNS? Las entradas son del nuevo dominio?

    Si el DNS está configurado correctamente, pruebe mirar la compatibilidad de los sistemas que están ejecutando.

    El process Monitor puede ayudar a descubrir problemas con desempeño.

    http://technet.microsoft.com/en-us/sysinternals/bb896645

    Saludos


    Ismael Borche - LATAM Forum Support Engineer
    Microsoft Corporation
    lunes, 28 de marzo de 2011 14:34
  • Hola Carmen,

    Segun creo el problema tendrias que separarlo en dos partes, Siempre suponiendo que las capas del 1 al 6 esten bien no?

    Primero, veamos suponiendo que el problema este en AD, cuanto tardan los usuarios en loguearse, es decir, ingresan Usuario y pass le dan enter ¿Tarda mucho en abrir el perfil??? si es si la respuesta, lo que yo haria seria, Primero Asegurarme que en el sitio donde se loguean los usuarios hay un Global Catalog, Segunda bajaria e instalaria en las maquinas el UPHClean, y si nada de esto funciona, probaria con un perfil nuevo.   Ahora si la respuesta a la pregunta es NO tenemos varios esenarios.

    Uno, revisaria los tiempos en que tardan las maquinas en llegar al FS donde esta alojado el sistema, este sistema se usa por FS o por SQL ???

    si usa FS yo quitaria todos los permisos de las carpetas y los volveria a poner desde cero. si usa SQL, cuanto tardo en hacer una consulta del tipo COUNT por ejemplo.

    En los Logs tanto de los servers y de las maquinas No aparece nada que nos pueda dar una pista de que pueda estar pasando???
    Saludos y suerte

     


    Todo se puede, que no sepa como es otro tema
    miércoles, 30 de marzo de 2011 13:06
  • A que te refieres con las capas del 1 al 6????

    La cosa esta asi:

    1. Ya quite el AD, y por consiguiente el DNS Y DHCP los maneja el router, asi que el servidor ahora solo actua como File server.

    2. Al loguearse los usuarios no hay tardanza, no hay problema sigue siendo el mismo tiempo de antes. Con y sin dominio.

    3. Para los sitemas de red tengo mapeada una unidad F;\its80, que los usuarios accesan con su computadora y es aqui cuando al conectarse se queda colgada por bastante tiempo.

    4. En el Log del server no me marca nada, pero en el Log de los ausarios me marca

    application hang  event ID: 1002.

    Al conectarse los usuarios para correr el programa que se accesa a traves de la unidad mapeada, se hace muy lentamente y todos los procesos son lentisimos.

    EL DHCP del router les asigna el IP a las workstation.

    EL ip de mi server si es fijo: 192.168.0.10, Subnet: 255.255.255.0 Gateway: 192.168.0.1

    My router es: 192.168.0.1

    Ustedes creen que se mejore el desempeño si asigno a las worksations la IP fija?????????

    Que DNS les tengo que poner a las workstation la del gateway o la del server o los dos?????????????. ya que ayer estaba leyendo un articulo que decia que tambien tenia que ir el ip del server aunque este no actuara como server de DNS. 

    miércoles, 30 de marzo de 2011 15:49
  • Hola Carmen

    Cuando tiene un dominio que hace resolución de nombres, hay que apuntar para el servidor local de DNS (y no de internet).

    Lo recomendable es que habilite el servicio de DNS en tu server.

    Saludos


    Ismael Borche - LATAM Forum Support Engineer
    Microsoft Corporation
    jueves, 31 de marzo de 2011 0:17
  • Pero por ejemplo ahorita que no esta habilitado el DNS en mi server, que lo tiene el router. que es lo recomendable??????, recuerda que ahorita no tengo activado el active directory. Hacia donde tienen que apuntar el dns delas workstation??????????
    jueves, 31 de marzo de 2011 4:18
  • Hola Carmen

    La pregunta entonces no está bien planteada.

    Mismo sin AD es posible tener DNS en tu red. Cuando haces una consulta por algún recurso de tu red local, quien  resuelve el nombre es el servidor DNS de tu proveedor. Por eso ocurre demora.

    El siguiente enlace indica como instalar un DNS

    http://support.microsoft.com/kb/814591

    Saludos


    Ismael Borche - LATAM Forum Support Engineer
    Microsoft Corporation
    • Propuesto como respuesta Ismael Borche martes, 5 de abril de 2011 19:24
    jueves, 31 de marzo de 2011 18:25
  • Hola Ismael,

    Antes que nada, gracias por tomarte el tiempo de responderme, pero ya tengo tantas ideas en la cabeza que necesito que me respondas lo siguiente:

    Cual es el objetivo del DNS????

    El sistema operativo que tengo en este momento es Server 2008 R2, y el link que me mencionas en la respuesta anterior es para server 2003. Son los mismos pasos????

    Entonces lo mas recomendable es que el DNS este en el servidor???????

    Yo pensaba que si no tenias Active directory en el server, no se podia activar este servicio, porque al menos en windows 2008 r2, no se ve el servicio DNS, hasta que se instala el AD.  Estoy en lo correcto o no???????

    jueves, 31 de marzo de 2011 20:35
  • Ismael,

    Sabes que ya cheque los pasos del link que me mandaste y no son los mismos de server 2003 que para server 2008. Solo necesito que me confirmes si se puede tener un DNS sin tener active directory en windows 2008R2???????????????????

    jueves, 31 de marzo de 2011 21:00
  • Hola

    Puedes encontrar el link para 2008 acá:

    http://technet.microsoft.com/es-es/library/cc725925.aspx

    Saludos


    Ismael Borche - LATAM Forum Support Engineer
    Microsoft Corporation
    • Propuesto como respuesta Ismael Borche martes, 5 de abril de 2011 19:24
    • Votado como útil Ismael Borche martes, 5 de abril de 2011 19:24
    viernes, 1 de abril de 2011 18:58
  • Hola Ismael,

    Solo para confirmarte que no es posible tener DNS server,  sin active directory, al menos en windows server 2008R2.

    Gracias.

     

    martes, 5 de abril de 2011 20:42
  • No te deja añadir el rol de DNS sin instalar el AD?

    Yo lo acabo de probar en un "Member server" y me deja sin problemas.


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    Citrix CCA

    martes, 5 de abril de 2011 20:53
    Moderador
  • Hola Marc,

    Ismael habia comentado que se puede agregar un Servidor DNS sin tener Active Directory, pero ese rol solo aparece activo cuando creas el active directory.

    Hay alguna otra manera de agregar el rol de DNS sin tener dominio???????

    De todos modos el programa que corren mis usuarios localmente sigue lento, con o sin dominio. 

    El sistema operativo del server es de 64 bits y la aplicacion que corren las worstation en red es de 32 bits. Eso tiene algo que ver????

      

     

    martes, 5 de abril de 2011 21:02
  • Para añadir el rol de DNS, desde la consola de administración, Roles -> Add roles -> DNS Server y seguir el asistente.

    Por otro lado, que el servidor sea de 64 bits y los clientes de 32 bits no debería influir en el rendimiento de la aplicación máxime si la ejecución es local.

    Lo que se ha de mirar es qué tráfico de red se genera entre las estaciones y el servidor e intentar detectar dónde está el "cuello de botella". A veces es tan "tonto" como forzar la velocidad de las tarjetas y no dejar que la negocien

    Está claro que instalando un servicio DNS de modo correcto tanto en el servidor como en los clientes, mejorarás la búsqueda de recursos publicados en esa red pero no tiene porqué mejorar el rendimiento de la aplicación si ésta no usa DNS y, por ejemplo, hace broadcast NetBIOS a la red.


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    Citrix CCA
    martes, 5 de abril de 2011 21:09
    Moderador
  • Es que el rol para DNS ni siquiera aparece, y me acuerdo que la primera vez que levante el dominio, despues de haberlo levantado fue cuando me aparecio activo el rol DNS, para poderlo agregar..

    Como se si mi red hace broadcast??? esto para que sirve???? 

    miércoles, 6 de abril de 2011 5:03
  • Marc e Ismael, por fin encontre el Rol DNS en server 2008 R2?

    Hay alguna otra recomendación para la creación del DNS??????

    Esta es una pregunta, es por no tener un DNS server que cuando yo le doy un ping con la IP Addres: por ejemplo ping 192.168.0.10, si me da una respuesta, es decir reply 192.168.0.10, pero cuando yo le doy un ping al nombre de la compuatdora me regresa una Ip que ni siquiera conozco????????

    gracias, por toda su ayuda.

      

    viernes, 8 de abril de 2011 21:36
  • Qué nombre te responde al hacer "ping" al propio servidor?
    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    Citrix CCA
    viernes, 8 de abril de 2011 22:49
    Moderador
  • Hola Marc,

    Bueno ahorita no tengo dominio ni dns server, asi que unas PC's estan todavia en el dominio(porque tu sabes que si las saco tengo que volver a confugirar el profile) y otras las saque para checar si ese era el problema, entonces:

    1. Cuando yo doy un ping al server con una PC que esta en el dominio me muestra:

      con ping 192.168.0.10: reply  from 192.0168.0.10

    con ping TNE(nombre del server): reply from 208.48.81.133

    2. Cuando doy un ping al server con una PC que esta afuera del dominio me muestra lo mismo con ping 192.168.0.10 or ping TNE

    reply from 192.168.0.10

    3. Cuando doy un ping en el mismo server: ping TNE me muestra:

    reply from fe80::cdf4:e4b3:68d5:4700%10

      

    sábado, 9 de abril de 2011 22:38
  • Cuántas tarjetas de red tiene ese server?
    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    Citrix CCA
    lunes, 11 de abril de 2011 8:16
    Moderador
  • Solamente tiene una: Broadcomm NetXtreme Gigabits ethernet.

    y utilizo internet protocolo version 4 (TCP/IPv4), pero tambien tiene la opcion (TCP/IPv6). y cuando hago un diagnostico me dice que el servidor esta correctamente instalado pero que no encuentra el recurso DNS (porque no esta instalado).

    Pregunta: cuando instale el Dns en el server los clientes lo van a detectar automaticamente o no????  

    Thanks Marc

     

     

    lunes, 11 de abril de 2011 14:13
  • Se me olvido decirte que cuando le doy ipconfig al server me da:

    connection specifis dns-suffix:  nada

    ipv4 address: 192.168.0.1  subnet mask: 255.255.255.0, gateway: 192.168.0.1

    tunnel adapter isatap.(09bc5d6d......)

    tunnel adapter local area connection*11:

    connection specifis dns-suffix:  nada

    ipv6 address: 2001:0:4137: .........     link local ipv6 address:  fe80::cdf4:e4b3:68d5:4700%10  Gateway: nada

    Entonces cuando le doy un Ping  Tne(nombre del server) me devuelve ipv6 address.

    lunes, 11 de abril de 2011 14:27
  • Recapitulando una vez que ya tenga mi dns server, los clientes como los tengo que configurar con ip fija o dinamica???? que dns debo de poner???? 

    lunes, 11 de abril de 2011 22:08
  • Solamente tiene una: Broadcomm NetXtreme Gigabits ethernet.

    y utilizo internet protocolo version 4 (TCP/IPv4), pero tambien tiene la opcion (TCP/IPv6). y cuando hago un diagnostico me dice que el servidor esta correctamente instalado pero que no encuentra el recurso DNS (porque no esta instalado).

    Pregunta: cuando instale el Dns en el server los clientes lo van a detectar automaticamente o no????  

    Thanks Marc

     

     


    No, vas a tener que configurar en cada cliente, la IP del Server DNS que instalaste, de esa forma los clientes si iran hacer consultas DNS al nuevo servidor.-

    Salu2


    Leonardo Ponti
    MCSE (Windows Server 2003)
    MCSA (Windows Server 2003)
    MVA
    MAP 2010/2011
    lunes, 11 de abril de 2011 23:26
    Moderador
  • Si tienes un DHCP Server, no tienes mas que configurar en el scope, la IP del nuevo server DNS, de esa forma, independientemente si asignas una IP fija o dinamica, el cliente recibira la configuracion del nuevo DNS server al cual consultar, de esa forma evitas ir cliente por cliente a cargar la IP del Servidor que configuraras.

    Ahora si ya tienes implementado en tus clientes, la configuracion TCP/IP estatica (la IP cargada a mano), lamentablemente no te queda otra que ir cliente por cliente a cargar la IP del nuevo DNS Server.-

    Salu2


    Leonardo Ponti
    MCSE (Windows Server 2003)
    MCSA (Windows Server 2003)
    MVA
    MAP 2010/2011
    lunes, 11 de abril de 2011 23:28
    Moderador
  • ya instale mi server dns, sin active directory y sin dhcp y cuando le doy nslookup ya me detecta mi server: tne.tnexpress.local ip:192.168.0.10 y cuando doy un ping por ejemplo a www.google.com me devuelve: reply 174.125.227.18.

     Ahora, cuando entro por primera vez al nslookup y escribo: primero la IP(google) y luego el nombre(www.google.com

    server 74.125.227.18 (direccion IP)

    me devuelve: server address [74.125.227.18]

                        address 174.125.227.18

    y cuando escribo www.google.com (el nombre)

    me devuelve: server address [74.125.227.18]

                         address 174.125.227.18

                         DNS request timed out (4 veces me muestra este mensaje)

                         timeout was 2 seconds (4 veces me muestra este mensaje)

    Esto es correcto????? Que es lo que esta mal??? que modifico????

    pero cuando lo hago al reves, es decir entro por primera vez al nslookup y escribo primero el nombre(www.google.com) y luego la IP(google) me devuelve:

    www.google.com

    server  tne.tneesprexx.local

    address 192.168.0.10

    Non-authoritative answer

    name www.1.google.com

    addresses 174.125.227.19, 174.125.227.20, 174.125.227.17, 174.125.227.18,174.125.227.16, aliases: www.google.com

    con el IP ADDRESS:           server 74.125.227.19, default server [74.125.227.19], address 174.125.227.19

    Configure el dns de la siguiente manera:

    1. agregue el rol dns.

    2.di de alta una zona en forward lookup zones con el nombre y IP del servidor.

    3. di de alta una zona en reverse lokup zones, con el IP del server DNS.

    Me falta algo,???  en los forwarders que IP's deben de ir?? el de mi proveedor de internet????? 

    martes, 12 de abril de 2011 15:58
  • Hola Carmen,

    revisa este enlace, ojala te sirva:

    http://www.youtube.com/watch?v=_DCkWqbMGio

    por otro lado, en las propiedades de la configuración de red IPV4 de tu SErvidor debe estar su misma dirección IP como Servidor primario de DNS y secundario puedes poner al de Internet.

    En tus clientes puedes ejecutar el comando ipconfig /flushdns para vaciar toda la cache de cada uno de ellos.

    A mi me sirvió en las propiedades del DNS Server (Dentro de la consola de administración DNS) limpiar todos los registros que apuntaban a mi Server a una dirección vieja, ejemplo: mi Server actual tiene la ip 192.168.0.122----mx.local y existian registros que apuntaban a 192.168.0.2----mx.local, cuando borre estos ultimos pude entonces agregar PCs al dominio sin problemas.

    Como decia Leo Ponti, asegurate que en el scope que hayas creado este bien configuradas todas las preferencias de la red, ya que estas serán las que tomen tus equipos clientes para navegar en la red local, todas tus PCs deben tener como Server primario al server local.

    Espero haber ayudado.

    Saludos cordiales,

    AOrtega

    • Propuesto como respuesta Ismael Borche lunes, 18 de abril de 2011 18:59
    • Marcado como respuesta Ismael Borche martes, 19 de abril de 2011 20:34
    martes, 12 de abril de 2011 18:01
  • Todo ya lo habia hecho tal cual me mencionas. El scope al que te refieres es del dhcp???? Porque recuerda que no tengo DHCP ni active directory en el server. El dhcp lo maneja el SonycWall(router)

    En mis roles aparecen con una cruz roja file services(event ID:8193 Source VSS) and network policies and access services (que tengo que configurar en esta opcion y para que me sirve)????? 

    miércoles, 13 de abril de 2011 0:55
  • Hola Carmen

    Si me refiero a ese scope, no importa donde este, asegurate que este bien configurado y si tienes bien tu DNS interno, todo debera marchar bien.

    Para la parte de los roles, te dejo este enlace

    http://technet.microsoft.com/en-us/library/dd283014(WS.10).aspx

    saludos

    Aortega

    miércoles, 13 de abril de 2011 14:31