locked
Драйвер USBSTOR.SYS вылетает с синим экраном RRS feed

  • Pregunta

  • Проблема в следующем. С какого-то момента на ВинХР стало невозможно подключать фотик или мобильник. БСОД - ошибка D1. Вылечилось заменой файервола на более новую версию. Потом переехал на ВинХР СП3. На чистой все отлично подключалось и работало. После установки каких-то обновлений ситуация сталп повторяться, но уже с несколько другими симптомами. Фотик (или мобильник) можно подключить, можно даже зайти на него. Увидеть каталог, даже скопировать пару фоток. В общем где-то секунд 40-45 работы. В это время почему-то активность жесткого диска аномально высокая. Затем БСОД с ошибкой D1 в драйвере USBSTOR.SYS
    Смирился с этим на некоторое время. После этого поставил чистую Вин7 (ну естественно скачанную с офсайта). Каково же было мое удивление, когда при подключении фотика ситуация повторилась с точностью 100% (все это касается и мобильника). Можно зайти на диск, поработать 40 сек, затем БСОД с ошибкой D1 в драйвере USBSTOR.SYS. При этом любые другие ЮСБ накопители, а именно, флешки разных мастей, внешние ЮСБ винчестера, работают. Пробовал тыккать в разные ЮСБ-порты, использовал внешний PCI-USB-контроллер. Тот же БСОД с ошибкой D1 в драйвере USBSTOR.SYS
    Загружался с LiveCD Ubuntu - все подключается и работает нормально. Из єтого сделал вівод, что ошибка программная, а не апаратная. Поправьте меня, если я ошибаюсь. Если кто-то предложит решение проблемы, буду очень признателен. Спасибо.
    viernes, 10 de julio de 2009 12:10

Respuestas

  • Виновник найден! Это Hard Drive Inspector фирмы Altrixsoft. Они стали поддерживать ЮСБ винчестера и что-то там намутили. Вот такие дела. 

    • Marcado como respuesta Igogo domingo, 9 de agosto de 2009 12:37
    sábado, 8 de agosto de 2009 19:14

Todas las respuestas

  • По ходу материнка у Вас загибается. Посмотрите есть ли на ней визуально вздутые конденсаторы и другие артефакты. А еще вспомните: устанавливали вы что-то из оборудования на комп ПЕРЕД тем, как подобные ошибки начали Вас беспокоить.


    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    viernes, 10 de julio de 2009 12:15
  • По ходу материнка у Вас загибается. Посмотрите есть ли на ней визуально вздутые конденсаторы и другие артефакты. А еще вспомните: устанавливали вы что-то из оборудования на комп ПЕРЕД тем, как подобные ошибки начали Вас беспокоить.


    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!

    Материнке полтора года. Температуры нормальне. Визуально все ок. Ничего из оборудования НЕ ДОСТАВЛЯЛОСЬ. (отвечаю так быстро, потому что сначала тоже грешил на материнку и все это уже пересмотрел). Мне кажется проблемы начались после какого-то обновления винды, но могу ошибаться. Просто такое чувство. А почему тогда под убунтой все работало? (Это не к тому, что я на убунту хочу перейти. Я лучше от фотика откажусь) И почему проблемы только с фотиком и телефоном?
    viernes, 10 de julio de 2009 12:32
  • А пробовали с другими флешками? То же самое?
    Какие-то еще устройства USB у Вас подключены постоянно?
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    viernes, 10 de julio de 2009 12:40
  • Я пробовал с несколькими разными флешками, работают ДВА Внешних (разных) ЮСБ винчестера. Пробовал на РАЗНЫХ ЮСБ портах. Все отлично с другими устройствами. Другой фотик пока взять не могу. Постоянно работают - мышь и клавиатура (ЮСБ). И больше ничего.
    viernes, 10 de julio de 2009 12:45
  • Как вариант - скачать и установить новые драйвера для материнки.
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    viernes, 10 de julio de 2009 13:02
  • Если Вы говорите об Intel® Chipset Software Installation Utility, то стоят. Остальные звук и сеть. Тоже стоят. Что еще прикрутить?
    viernes, 10 de julio de 2009 13:14
  • У Вас стоят обновленные или те, что шли в комплекте с матплатой? Потому что я имел ввиду скачать новые версии.


    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    viernes, 10 de julio de 2009 13:24
  • У меня стоят САМЫЕ ПОСЛЕДНИЕ
    viernes, 10 de julio de 2009 13:28
  • Я пробовал с несколькими разными флешками, работают ДВА Внешних (разных) ЮСБ винчестера. Пробовал на РАЗНЫХ ЮСБ портах. Все отлично с другими устройствами. Другой фотик пока взять не могу. Постоянно работают - мышь и клавиатура (ЮСБ). И больше ничего.

    Как вариант возможны следующие варианты:
    1. В более новых дровах на ЮСБ (т.е те, которые поставились с обновлениями) брлее жесткое ограничение по нагрузке по току на порт.
    Можно проверить так: Посмотреть нагрузку по току для устройств, которые работают нормально, а потом посмотреть ток при подключенных проблемных девайсах. Лечится подсовыванием принудительно старых дров.
    2. Проблема в самих устройствах. Проверяется проверкой их работы на других компьютерах.
    3. Можно еще для исключения варианта нехватки питания - подключить их черех внешний ЮСБ хаб со своим питанием (т.е. активным, а не пасивным)
    domingo, 12 de julio de 2009 16:00
  • Скажите, а у Вас же, наверное, в трее постоянно висит запущенный Sony Ericsson PC suite? Если да, то попробуйте его полностью отключить и проверить изменится что-то или нет.
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    lunes, 13 de julio de 2009 7:46
  • > в трее постоянно висит запущенный Sony Ericsson PC suite? - Нет, не висит. У меня Самсунг.
    Alex Kh
    >
    Проблема в самих устройствах. Проверяется проверкой их работы на других компьютерах. - проверялось. Работают.

    > Можно еще для исключения варианта нехватки питания - не думаю. БП SeaSonic M12-500. Нагружен 170 ваттами (меряю внешним ваттметром на розетке)

    > В более новых дровах на ЮСБ (т.е те, которые поставились с обновлениями) брлее жесткое ограничение по нагрузке по току на порт. - а вот это похоже на истину. Гляну. Даже не думал в этом направлении.
    lunes, 13 de julio de 2009 18:09
  • В более новых дровах на ЮСБ (т.е те, которые поставились с обновлениями) брлее жесткое ограничение по нагрузке по току на порт.
    Странно, не видел такого в официальных сводках. А можно оригинал этой информации увидеть (статьи, блоги)?
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    martes, 14 de julio de 2009 8:58
  • > Можно еще для исключения варианта нехватки питания - не думаю. БП SeaSonic M12-500. Нагружен 170 ваттами (меряю внешним ваттметром на розетке)
    Я не говорю про БП. Я говорю именно про нехватку питания по линии ЮСБ.
    Поэтому и предложил подключить через ЮСБ хаб с собственныи источником питания.
    martes, 14 de julio de 2009 9:49
  • В более новых дровах на ЮСБ (т.е те, которые поставились с обновлениями) брлее жесткое ограничение по нагрузке по току на порт.
    Странно, не видел такого в официальных сводках. А можно оригинал этой информации увидеть (статьи, блоги)?
    А как в таком случае понимать вариант, когда внешний винт нормально запускается с виндой ХР, но при этом, когда стоит 7-ка второй операционкой - внешний винт ни в какую не запускается. Стоит перегрузиться в обратно в ХР - опять все нормально.
    Остается единственно возможный вариант - дрова, вернее управление питанием по ЮСБ.
    martes, 14 de julio de 2009 9:52
  • Давайте опираться на факты. "Факты - вещь упрямая" (с). Статью (либо официальный источник) Вы указать не можете. И мне на секунду показалось, что это Ваши личные домыслы. Я ошибаюсь? Вы можете меня опровергнуть, предоставив официальный источник этих данных.
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    martes, 14 de julio de 2009 10:09
  • Спасибо за активную дискуссию, но проблема все еще не решена.
    Психнул сегодня и сменил материнку. Абсолютно новая P5Q-E. Винду правда не переставлял. Прикол, но телефон опять не захотел подключиться. Снова БСОД с ошибкой Д1 в том же драйвере. Правда в єтот раз несколько позднее. Секунд на 15 может.
    >Я не говорю про БП. Я говорю именно про нехватку питания по линии ЮСБ. - подумал об єтом, но ведь раньше всего хватало. И в УБУНТЕ тоже хватает.
    А вот этот эксперимент интереснее - загрузился в безопасном режиме - вроде все работает. Ну ждал минуты три. Из этого делаю вывод, что что-то из софта или конфликтует или еще чего. Какие идеи?
    В идеале поставить Вин7 с нуля и смотреть потихоньку доставляя. Но еду в отпуск в субботу. Это уже через недели три. Может пока есть какие-то еще идеи попроще? Спасибо.

    Дрова то как-раз у них судя по их данным 2006 года

    martes, 14 de julio de 2009 13:49
  • А устройства, которые вызывают глюк, подключены через USB-удлинитель? А то может дело в нем?
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    miércoles, 15 de julio de 2009 9:16
  • Телефон - да. Удлиннитель не китайский за 20 баксов. Фотик - нет. Если бы глюк в удлиннителе или шнуре, то устройство бы не подключалось, не так ли? А так оно подключается, определяется и работает, правда недолго. И еще - в сейфмоде все ОК.

    miércoles, 15 de julio de 2009 13:08
  • Давайте исключим аппаратные ошибки - можете в настройках БИОС выставить Safe-Mode Settings и загрузить ОС в нормальном режиме?
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    miércoles, 15 de julio de 2009 13:17
  • Не думаю, что дело в этом. БИОС стоит по дефолту (все на авто), только питание на память увеличено (иначе не работает). Но ведь все работает в сейф-моде в Вин7 и в убунте. Следовательно - программный глюк так? И в нормальной винде - все подгружается и только потом вылетает. Причем на новой материнке абсолютно аналогично старой. Я не прав? Если да, то в чем.

    miércoles, 15 de julio de 2009 15:11
  • только питание на память увеличено (иначе не работает)


    Это как? Вообще-то SPD памяти содержит всю необходимую для БИОС инфу, относительно питания и таймингов. Поэтому память должна работать и без какого-либо вмешательства в ее работу. Она и на старой материнке у Вас отказывалась работать без повышения напряжения? Если так, то проверьте ее на наличие ошибок.
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    jueves, 16 de julio de 2009 7:19
  • Неправильно выразился, извините. Для работы по таймингам SPD - все норм, а для работы по таймингам заявленным производителем (память OCZ), нужно увеличивать питание. В сторону памяти не копать - там все норм. Пробовал даже по одной планке в разные слоты пихать. Симптомы те-же

    jueves, 16 de julio de 2009 8:14
  • Мыслю так - если проблема действительно в файле usbstor.sys и не в чем-то еще, то можно скачать более старую версию этого файла (уровня Windows XP, который корректно работал), заменить имеющийся и посмотреть как будет работать. Если будут ошибки и дальше, значит дело не в самом драйвере.
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    jueves, 16 de julio de 2009 8:34
  • Вообще я тоже так думал. Не подскажете где взять старую версию?

    jueves, 16 de julio de 2009 17:58
  • 1. Если у Вас есть лицензия предыдущей версии Windows, то можете взять этот файл оттуда из дистрибутива.
    2. Тут есть от Висты: http://support.microsoft.com/kb/936824
    3. Тут есть в составе хотфикса от Xp, но нужно отдельно заказывать: http://support.microsoft.com/kb/887173


    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    viernes, 17 de julio de 2009 7:24
  • Спасибо. Уезжаю в отпуск. Вернусь через 2 недели. Тогда и буду делать.

    viernes, 17 de julio de 2009 12:41
  • FYI. Вот еще человек, у которого после установки обновлений перестало работать USB-устройство: http://social.technet.microsoft.com/Forums/ru-RU/windows7ru/thread/56a862b5-d776-49ed-8b2e-b3371aed99b2
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    martes, 21 de julio de 2009 6:02
  • Сегодня психнул. Поставил заново на чистый диск Windows XP SP3 (лиценз) без всех обновлений и драйверов. Подключил телефон - подключился. Значит проблема не апаратная, а софтовая. И не в драйвере USBSTOR.SYS, а в каком-то конфликте софта. Буду теперь потихоньку доставлять обновления, драйвера, остальной софт и смотреть где вылетит. Так и определим виновника. О результатах конечно же напишу.

    sábado, 8 de agosto de 2009 15:54
  • Виновник найден! Это Hard Drive Inspector фирмы Altrixsoft. Они стали поддерживать ЮСБ винчестера и что-то там намутили. Вот такие дела. 

    • Marcado como respuesta Igogo domingo, 9 de agosto de 2009 12:37
    sábado, 8 de agosto de 2009 19:14