none
Correr Script programados por GPO RRS feed

  • Pregunta

  • Hola a todos. En mi empresa tenemos la necesidad de correr una diapositiva a cierta hora del día a todos los usuarios.

    He intentado por gpo de tareas programadas, pero solo funciona con la credencial del usuario logueado. Si configuro otra cuenta de la red para q corra el script, no funciona.Entonces tendria que crear una gpo por cada usuario(imposible).

    No uso script de logon, pues no debe correr al inicio sino a la hora que se programe. Espero me puedan ayudar. Gracias.

     

    lunes, 5 de mayo de 2014 16:12

Respuestas

Todas las respuestas

  • Hola Anthony,

    Debes generar una tarea programada desde GPO, de esa forma automatizarías el script en los equipos que indiques en la misma directiva. Sigue este articulo de TechNet donde muestran como realizar esto:

    http://technet.microsoft.com/en-us/library/cc725745.aspx

    También te puedes apoyar en este artículo:

    http://technet.microsoft.com/en-us/library/cc772785(v=ws.10).aspx

    De igual manera si quieres que ejecute con las credenciales locales de admin trata con un "run as" y le indicas: NT AUTHORITY\SYSTEM

    .


    Saludos cordiales | Exchange Trainer | MCDST-MCTS-MCITP-MCSA-MCT

    • Propuesto como respuesta Uriel Almendra martes, 6 de mayo de 2014 16:15
    • Marcado como respuesta Uriel Almendra miércoles, 7 de mayo de 2014 17:11
    lunes, 5 de mayo de 2014 18:44
  • Hola Geovany

    Cuando uso Scheduled Tasks, solo funciona si uso en "Security options" un usuario que sea el mismo que se loguea en el cliente.

    Cualquier otra opcion, con otro usuario o "Run whether user is logged on or not", no funciona.

    Mi script es: "C:\Program Files\Microsoft Office\Office15\POWERPNT.EXE" Argumentos: /S \\fileserver\rrhh\BIENVENIDA.ppsx

    Me gustaria que se ejecute el script con cada usuario logueado(user1,user2,etc), intente con variables para que la tarea se ejecute con el usuario autenticado como (domain\%logonuser% , domain\%userprofile%) pero no coge el usuario. 

    La opcion que me das es: Domain\system ?? no te entendi bien.

    lunes, 5 de mayo de 2014 21:37
  • Yo creo que no es que no se ejecute, si no que no lo ves; si a esa hora abres el administrador de tareas y miras las tareas de todos los usuarios probablemente verás que el proceso está en ejecución.

    Podrías usar PsExec en el script para invocar el comando, con el modificador -i, que hace que se vea en la sesión activa.


    Un saludo

    Fernando Reyes
    MCSA 2000/2003/2012
    MCSE 2000/2003
    MCITP Enterprise Administrator
    Web: http://freyes.svetlian.com
    Blog: http://urpiano.wordpress.com
    RSS: http://urpiano.wordpress.com/feed/


    martes, 6 de mayo de 2014 9:24
    Moderador