none
No se puede establecer una conexión con el catálogo global. RRS feed

  • Pregunta

  • Tengo una red con un servidor con Windows 2000 donde tiene asignadas todas la funciones:  pcd, rid, de infraestructura, maestro de operaciones, de esquema, y tiene marcada la casilla de catalogo global. En su día había otro servidor que era el principal de todo pero que se quito del dominio sin degradarlo. Parece ser que el catálogo global no se replicó correctamente y ahora me encuentro con que los usuarios no pueden  acceder a los recursos de red del servidor , o les pide usuario y contraseña.

    No deja añadir usuarios, en la herramienta de usuarios y equipos de active directoy, y me da el error de que no puede añadirle el identificador relativo. Así que tengo bloqueada la autenticación y la asignación de usuarios y equipos.

    He intentado limpiar la información de servidor antiguo con la herramienta ntdsutil pero creo que no lo acaba de hacer correctamente. Tampoco me deja eliminar el servidor antiguo en sitios y servicios de active directory, indicándome que hay muchos objetos antes de denegarme la acción.

     

    Me gustaría saber como puedo hacer para que este servidor sea el responsable del catálogo global y funcione la red y la autenticación correctamente, muchas gracias.

     

    El error que tengo en el registro de sucesos de active directory es:

     

    Tipo de suceso: Error
    Origen del suceso: NTDS General
    Categoría del suceso: (18)
    Id. del suceso: 1126
    Fecha:  05/09/2007
    Hora:  13:30:41
    Usuario:  Todos
    Equipo: SERVIDOR1
    Descripción:
    No se puede establecer una conexión con el catálogo global.

     

    Y en el de replicación:

     

    Tipo de suceso: Advertencia
    Origen del suceso: NtFrs
    Categoría del suceso: Ninguno
    Id. del suceso: 13508
    Fecha:  04/09/2007
    Hora:  20:15:51
    Usuario:  No disponible
    Equipo: SERVIDOR1
    Descripción:
    El Servicio de replicación de archivos tiene problemas habilitando la replicación desde SERVIDOR a SERVIDOR1 para c:\winnt\sysvol\domain utilizando el nombre DNS servidor.arzobispado.org. FRS continuará reintentando.
     A continuación observará algunas de las razones por las que aparecerá esta advertencia.
     
     [1] FRS no puede resolver correctamente el nombre DNS servidor.arzobispado.org desde este equipo.
     [2] FRS no se está ejecutando en servidor.arzobispado.org.
     [3] La información de topología de esta replicación en Active Directory aún no ha sido replicada a todos los controladores de dominio.
     
     Este mensaje de registro de sucesos aparecerá una sola vez para cada conexión. Una vez que se haya resuelto el problema volverá a ver otro  mensaje de registro de sucesos indicando que la conexión se ha establecido.
    Datos:
    0000: ba 06 00 00               º...   

     


     


     

     

    miércoles, 5 de septiembre de 2007 12:40

Respuestas

  •  

    Bueno a ver empezemos de a poco ... En principio asegurate de que tus dos DC que por lo que veo son Servidor y servidor1 apunten su direccion DNS primaria a si mismos y la secundaria al otro controlador de dominio.

    Luego de eso intenta hacer una replicacion manual y vemos que pasa.

    Instala las support Tools en el controlador de dominio ejecuta un dcdiag y postea los resultados , asi vemos que otro problema puede estar habiendo.

    Slds
    Sebastian del Rio

    miércoles, 5 de septiembre de 2007 13:37
    Moderador
  • Hola Maxi...

     

    En pincipio evidentemente el servicio LDAP no se conecta.

    Éste debe tener un valor ERRONEO.

    Para verificarlo deberías abrir la consola DNS y buscar en la zona ACTIVE DIRECTORY los valores LDAP.

    O está apuntando a un server inexistente lo que deberías de cambiar o eliminar o apunta a una IP equivocada o en DESUSO.

     

    Si eliminas la entrada deberías ejecutar desde el CMD lo siguiente:

    net stop NETLOGON

    net start NETLOGON

    ipconfig /flushdns

    ipconfig /registerdns

     

     

    Saludos.
    lunes, 17 de septiembre de 2007 21:03
    Moderador
  • Mira si los siguientes LINKS te ayudan:

    LDAP server locally not available on domain controller because of Winsock program

    http://support.microsoft.com/kb/315182/en-us

     

    You receive LDAP bind errors after you run Dcpromo to install the first Windows Server 2003 computer in a domain

    http://support.microsoft.com/kb/834317/en-us

     

     

    Saludos, "Warrior of the Net" 

    lunes, 17 de septiembre de 2007 21:05
    Moderador

Todas las respuestas

  •  

    Bueno a ver empezemos de a poco ... En principio asegurate de que tus dos DC que por lo que veo son Servidor y servidor1 apunten su direccion DNS primaria a si mismos y la secundaria al otro controlador de dominio.

    Luego de eso intenta hacer una replicacion manual y vemos que pasa.

    Instala las support Tools en el controlador de dominio ejecuta un dcdiag y postea los resultados , asi vemos que otro problema puede estar habiendo.

    Slds
    Sebastian del Rio

    miércoles, 5 de septiembre de 2007 13:37
    Moderador
  • Hola, como estas? se que este post es viejo, pero lo encontre, y yo tengo exactamente el mismo problema, hice lo que dijiste, el dcdiag me da esto:
    Microsoft Windows 2000 [Versión 5.00.2195]
    (C) Copyright 1985-2000 Microsoft Corp.

    C:\Documents and Settings\administrador.SERVER01.003>dcdiag

    Domain Controller Diagnosis

    Performing initial setup:
       Done gathering initial info.

    Doing initial required tests

       Testing server: Nombre-predeterminado-primer-sitio\MAILS
          Starting test: Connectivity
                *** Warning: could not confirm the identity of this server in
                   the directory versus the names returned by DNS servers.
                   If there are problems accessing this directory server then
                   you may need to check that this server is correctly registered
                   with DNS
             ......................... MAILS passed test Connectivity

    Doing primary tests

       Testing server: Nombre-predeterminado-primer-sitio\MAILS
          Starting test: Replications
             [SERVERHI] DsBind() failed with error 1722,
             El servidor RPC no estß disponible..
             ......................... MAILS passed test Replications
          Starting test: NCSecDesc
             ......................... MAILS passed test NCSecDesc
          Starting test: NetLogons
             ......................... MAILS passed test NetLogons
          Starting test: Advertising
             ......................... MAILS passed test Advertising
          Starting test: KnowsOfRoleHolders
             ......................... MAILS passed test KnowsOfRoleHolders
          Starting test: RidManager
             ......................... MAILS passed test RidManager
          Starting test: MachineAccount
             ......................... MAILS passed test MachineAccount
          Starting test: Services
             ......................... MAILS passed test Services
          Starting test: ObjectsReplicated
             ......................... MAILS passed test ObjectsReplicated
          Starting test: frssysvol
             There are errors after the SYSVOL has been shared.
             The SYSVOL can prevent the AD from starting.
             ......................... MAILS passed test frssysvol
          Starting test: kccevent
             ......................... MAILS passed test kccevent
          Starting test: systemlog
             ......................... MAILS passed test systemlog

       Running enterprise tests on : administracion.api.org.ar
          Starting test: Intersite
             ......................... administracion.api.org.ar passed test Intersi
    te
          Starting test: FsmoCheck
             [SERVERHI] LDAP connection failed with error 58,
             El servidor especificado no puede ejecutar la operaci¾n solicitada..
    lunes, 17 de septiembre de 2007 13:04
  • Hola Maxi...

     

    En pincipio evidentemente el servicio LDAP no se conecta.

    Éste debe tener un valor ERRONEO.

    Para verificarlo deberías abrir la consola DNS y buscar en la zona ACTIVE DIRECTORY los valores LDAP.

    O está apuntando a un server inexistente lo que deberías de cambiar o eliminar o apunta a una IP equivocada o en DESUSO.

     

    Si eliminas la entrada deberías ejecutar desde el CMD lo siguiente:

    net stop NETLOGON

    net start NETLOGON

    ipconfig /flushdns

    ipconfig /registerdns

     

     

    Saludos.
    lunes, 17 de septiembre de 2007 21:03
    Moderador
  • Mira si los siguientes LINKS te ayudan:

    LDAP server locally not available on domain controller because of Winsock program

    http://support.microsoft.com/kb/315182/en-us

     

    You receive LDAP bind errors after you run Dcpromo to install the first Windows Server 2003 computer in a domain

    http://support.microsoft.com/kb/834317/en-us

     

     

    Saludos, "Warrior of the Net" 

    lunes, 17 de septiembre de 2007 21:05
    Moderador
  • Hola rafa!! , ya lo pude arreglar, estaba mal el dns... Pero lo pude arreglar ayer a la mañana, tube indicios de eso en el visor de sucesos... Lo arregle, redireccione todo como debia ser, y pude migrar los roles sin problemas desde el active directoy, mmc, etc.
    Se replico todo bien, igual, lo que me tira un error en la replicacion es el servicio de licencias. Me tira este error en el visor de sucesos:

    Tipo de suceso:    Advertencia
    Origen del suceso:    LicenseService
    Categoría del suceso:    Ninguno
    Id. del suceso:    213
    Fecha:        18/09/2007
    Hora:        10:44:10 a.m.
    Usuario:        No disponible
    Equipo:    SERVERHI
    Descripción:
    La réplica de la información de licencias ha fallado porque no se puede ponerse en contacto con el Servicio de registro de licencias en el servidor Mails.administracion.api.org.ar.
    Datos:
    0000: 17 00 02 c0               ...À   

    martes, 18 de septiembre de 2007 13:46
  • Lo típico es deshabilitar el servicio.

     

    Sin embargo te dejo un link con varias visiones sobre dich evento:

    http://www.eventid.net/display.asp?eventid=213&eventno=52&source=LicenseService&phase=1

     

     

    No te olvides de marcar las respuestas válidas para que otros sepan que está solucionado.

    Saludos Maxi!!
    martes, 18 de septiembre de 2007 13:59
    Moderador
  • gracias por la info.

    Entre a sitio y servicios de ad - nombre predeterminado primer sitio - Licensing site setings, y en la parte de equipo de licencias, lo cambie por el nuevo servidor, y en el visor de sucesos dejo de aparecer el mensaje.
    Asi creo que ya estaria todo, el tema es que cuando pongo en el servidor nuevo de dominio "dcdiag", ma sale esto:

    C:\Documents and Settings\Administrador.ADMINISTRACION>dcdiag

    Domain Controller Diagnosis

    Performing initial setup:
       Done gathering initial info.

    Doing initial required tests

       Testing server: Nombre-predeterminado-primer-sitio\SERVERHI
          Starting test: Connectivity
             ......................... SERVERHI passed test Connectivity

    Doing primary tests

       Testing server: Nombre-predeterminado-primer-sitio\SERVERHI
          Starting test: Replications
             ......................... SERVERHI passed test Replications
          Starting test: NCSecDesc
             ......................... SERVERHI passed test NCSecDesc
          Starting test: NetLogons
             ......................... SERVERHI passed test NetLogons
          Starting test: Advertising
             ......................... SERVERHI passed test Advertising
          Starting test: KnowsOfRoleHolders
             ......................... SERVERHI passed test KnowsOfRoleHolders
          Starting test: RidManager
             ......................... SERVERHI passed test RidManager
          Starting test: MachineAccount
             ......................... SERVERHI passed test MachineAccount
          Starting test: Services
             ......................... SERVERHI passed test Services
          Starting test: ObjectsReplicated
             ......................... SERVERHI passed test ObjectsReplicated
          Starting test: frssysvol
             There are errors after the SYSVOL has been shared.
             The SYSVOL can prevent the AD from starting.
             ......................... SERVERHI passed test frssysvol
          Starting test: kccevent
             ......................... SERVERHI passed test kccevent
          Starting test: systemlog
             An Error Event occured.  EventID: 0x00000457
                Time Generated: 09/18/2007   12:41:02
                (Event String could not be retrieved)
             An Error Event occured.  EventID: 0x00000452
                Time Generated: 09/18/2007   12:41:02
                (Event String could not be retrieved)
             ......................... SERVERHI failed test systemlog

       Running enterprise tests on : administracion.api.org.ar
          Starting test: Intersite
             ......................... administracion.api.org.ar passed test Intersi
    te
          Starting test: FsmoCheck
             ......................... administracion.api.org.ar passed test FsmoChe
    ck

    Fijate que me da todo bien excepto el sysvol
    martes, 18 de septiembre de 2007 15:46
  • Hola Maxi...

     

    Fijate en los siguientes links que están relacionados con temas de SHARES en SYSVOL:

    http://support.microsoft.com/kb/316790/en-us

    http://support.microsoft.com/kb/257338

     

     

    Saludos.

     

    martes, 18 de septiembre de 2007 18:15
    Moderador