none
Problema con Servidor Windows 2003 y un servicio llamado "Servidor" RRS feed

  • Pregunta

  •  

    Mi problema es el siguiente:

     

    Tengo un servidor Windows 2003 Server R2  Enterprise Edition, Service Pack 1.  En este servidor esta corriendo SQL Server 2000 y Softland. Además de tener estos programas, existen tres carpetas compartidas; una es del Softland y las otras dos son de programas que requieren de ciertos archivos para funcionar.

     

    El problema radica en el Servidor Windows 2003, ya que de un momento a otro simplemente dejo de compartir las carpetas.  Al ver las propiedades de las carpetas compartidas, estas ya no poseen la pestaña “compartir”, simplemente desapareció.

     

    Lo primero que se me ocurrió, fue pensar en algún virus o spyware que me estuviese molestando; revise el servidor con el antivirus AVAST 4.7 (que ya estaba caducado) y no encontró nada. Así que para asegurarme lo revise con Kapersky Online y nada.

     

    Revise el visor de sucesos, pero no me indicaba nada como muy tangible para darle solución al problema.

     

    Al copiar cierto programa (ShareWatch.exe) y ejecutarlo me indica que el servicio Servidor no estaba iniciado. Lo fui a ver y magia ese era el problema o mejor dicho parte del problema; ya que al iniciarlo y esperar unos minutos (5 a 10 minutos)  se volvía a deshabilitar este servicio. Por lo que leí este servicio mantiene o permite compartir Carpetas, impresoras etc. etc.

     

    ¿Cómo soluciono esto? No puedo esta viendo si el servicio esta arriba a cada momento.

    El problema que cuando se cae o deja de funcionar, el Softland en los equipos conectados se cuelga.

     

    Agradecería cualquier ayuda.

     

    Como dato adicional, existen algunos pc que se conectaban al servidor y presentan el mismo problema con el servicio "Servidor". Lo raro es que son pc con Windows XP SP3 con todas las actualizaciones existentes, su correspondiente antivirus (AVAST 4.8) que no ha detectado nada y como 3 antispyware ya intalados.

    martes, 25 de noviembre de 2008 16:41

Respuestas

  • Buenas tardes,

     

    Si lo que tenéis es un cuelgue aleatorio de svchost (mirar en el visor de eventos, debería tener un ID 1000) que provocan la caída de entre otros el servicio "Servidor", probar con la kb liberada de MS siguiente

     

    support.microsoft.com/kb/958644

     

     

    un saludo
    • Marcado como respuesta Ricardo.rspk miércoles, 18 de marzo de 2009 15:57
    miércoles, 26 de noviembre de 2008 19:10

Todas las respuestas

  • Hola Ricardo, en mi red me pasa desde hace unos días exactamente lo mismo. Has podido encontrar ya alguna solución o al menos un diagnóstico? Parace que a mí me ha ayudado instalar actualizaciones de Windows y meter el SP2. Ya me cuentas. Saludos.

    Kuka

     

     

    martes, 25 de noviembre de 2008 22:01
  • Bueno, hasta el momento nada mucho, pero al identificar que era el servicio "Servidor", me dirigi a Herramientas Administrativas -> Servicios y busque el servicio "Servidor", el cual se detiene(no se inhabilita) sólo se detiene. Lo inicio y ya.

    El problema es que es relativo cuanto tiempo se mantiene arriba, luego se cae.

    Si tienes algun dato agradecería que me lo dijeras. KukaWare
    miércoles, 26 de noviembre de 2008 2:49
  • Con respecto al servicio, ya lo sabemos y por si te ayuda pinchando con el boton derecho "propiedades" hay una pestaña "recovery" donde donde en first, 2nd y subsequent failure puedes elegir "restart service" con ello se te reiniciará el servicio solo.

    Esto no evita que se siga cayendo, es una contingencia, pero al menos no tienes que estar atento al servicio. Por otro lado nosotros ayer por la tarde pusimos las actualizaciones que te dije y desde ayer por la tarde no se ha caído. (No se si habrá valido de algo, pero por el momento si).

    Si averiguas algo, me dices.

     

    miércoles, 26 de noviembre de 2008 7:07
  • Buenas tardes,

     

    Si lo que tenéis es un cuelgue aleatorio de svchost (mirar en el visor de eventos, debería tener un ID 1000) que provocan la caída de entre otros el servicio "Servidor", probar con la kb liberada de MS siguiente

     

    support.microsoft.com/kb/958644

     

     

    un saludo
    • Marcado como respuesta Ricardo.rspk miércoles, 18 de marzo de 2009 15:57
    miércoles, 26 de noviembre de 2008 19:10
  • Hola, yo estoy con el mismo problema. Encontraron alguna solucion ???. Gracias

    jueves, 27 de noviembre de 2008 17:16
  • Hola a mi me comenzo a pasar el fin de semana anterior 22 de Nov, me tiene muy complicado, agradeceria si alguien a encontrado algo.

    jueves, 27 de noviembre de 2008 20:53
  • Hola buenas!

     

    A mi me pasa lo mismo. En principio miramos a ver si podía ser un problema de replicación, ya que me pasa en un DC, y nada, había algun fallo por ahi que fue solventado y listo. Pero este problema seguia pasando.

    A mi se me caen los servicios workstation, server, automatic updates, logical disk manager, computer browser, y alguno más aleatorio. Como bien dijo ORBAYU, el svchost.exe me da este fallo:

     

    Faulting application svchost.exe, version 5.2.3790.1830, faulting module shell32.dll, version 6.0.3790.2662, fault address 0x0003568c.

     

    Habéis probado alguien la KB que puso ORBAYU?

     

    Muchas gracias.

    1 Saludo!

    viernes, 28 de noviembre de 2008 12:50
  • Muchas gracias Orbayu,

    Lo hemos instalado y parece que ahora todo va perfecto.

    Eres un crack!

     

    KukaWare

     

    viernes, 28 de noviembre de 2008 15:38
  •  Gracias  orbayu

    He descargado la Kb958644 desde Microsoft, la instale y problema solucionado.

    Un error parecido me encontre despues en Windows xp y busque la misma Kb958644 pero para XP, tambien funciono.
    lunes, 1 de diciembre de 2008 15:34
  •  

    Gracias Orbayu.. yo estaba con el mismo problema y ahora todo Ok.
    lunes, 1 de diciembre de 2008 20:38
  • Buenos días!

     

    Ayer probé a instalar el kb que nos pusiste Orbayu y nada, hoy ha vuelto a amanecer con los servicios computer browser, automatic updates, cryptographic services, local disk manager, secondary logon, shell hardware detection, workstation caidos....

     

    He estado haciendo pruebas y realmente el servicio que falla es el computer browser. puedo estar un día entero sin que se caigan sin este servicio arriba pero con el resto levantados. Pero una vez levanto el computer browser se caen todos...

     

    Me da dos eventos de informacion iguales que aquí os pongo, antes de que me de el error del svchost que os pongo a continuacion:

     

    Information: Reporting queued error: faulting application svchost.exe, version 5.2.3790.1830, faulting module shell32.dll, version 6.0.3790.2662, fault address 0x0003568c.

     

    Error : Faulting application svchost.exe, version 5.2.3790.1830, faulting module shell32.dll, version 6.0.3790.2662, fault address 0x0003568c.

     

    Aver si me podéis echar un cable...

    Muchas gracias!

    jueves, 4 de diciembre de 2008 9:09
  •  

    Buenas noches.

     

    Yo tambien tengo el mismo problema, he instalado este parche y me sigue pasando.

     

    He pasado varios antivirus, y he detectado el downlaup.

     

    Si os ocurre una solución ....

     

    Muchas gracias !!

    viernes, 9 de enero de 2009 22:44