none
Ayuda urgente Exchange 20003. "El almacen de versiones ha alcanzado un tamaño excesivo" RRS feed

  • Pregunta

  • Hola, tengo Exchange 2003 SP2 standard sever y de repente no puedo conectar con la base de datos en los clientes. En el visor me aparecen los sucesos 9791 diciendo que "el almacen de versiones del motor de la base de datos ha alcanzado un tamaño excesivo".

    Tambien me aparecen los errores 623 y 1092.

    ¿Que puedo hacer por favor?.

    Muchas gracias.


    • Editado pocholo22 lunes, 19 de noviembre de 2012 14:32
    lunes, 19 de noviembre de 2012 13:31

Respuestas

  • Por si alguine le interesa, despues de crear una nueva base de datos (con los problemas que ello conlleva para el personal) todo ha vuelto a la normalidad. De momento llevo una semana y todo ok. Lo que me preocupa es que no se que ha pasado, por lo tanto nosé que puedo hacer para prevenirlo. Si alguien tiene alguna idea será bienvenida.

    Gracias y un saludo.

    jueves, 29 de noviembre de 2012 9:52

Todas las respuestas

  • Hola,

    Revisa este link http://blogs.technet.com/b/exchange/archive/2008/05/23/3405532.aspx por si puede serte de ayuda.


    Saludos,

    Marc
    Microsoft MVP - Directory Services
    MCSA/MCSE 2003
    MCSA 2008 Core
    MCITP: Enterprise Administrator, Enterprise Messaging Administrator, Lync Server Administrator 2010
    MCTS: SCOM 2007, Configuring; SCCM 2007, Configuring; Windows 7 and Office 2010, Deploying; Windows Server 2008 R2, Server Virtualization
    MCC: Microsoft Community Contributor
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card

    lunes, 19 de noviembre de 2012 15:39
    Moderador
  • Gracias. Mientras he instalado el hotfix

    http://support.microsoft.com/?kbid=919417

    Y por si no tuviese suficientes problemas al iniciar el equipo (w2003 enterprise server SP2) se queda colgado en "Preparando la configuración del equipo" antes de entrar en el sistema. ¿Que puedo hacer por favor para quitar en hotfix?, En modo a prueba de fallos entra bien.

    lunes, 19 de noviembre de 2012 15:52
  • Hola,

    Prueba de arrancar el equipo en "Última configuración buena conocida"


    Saludos,

    Marc
    Microsoft MVP - Directory Services
    MCSA/MCSE 2003
    MCSA 2008 Core
    MCITP: Enterprise Administrator, Enterprise Messaging Administrator, Lync Server Administrator 2010
    MCTS: SCOM 2007, Configuring; SCCM 2007, Configuring; Windows 7 and Office 2010, Deploying; Windows Server 2008 R2, Server Virtualization
    MCC: Microsoft Community Contributor
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card

    lunes, 19 de noviembre de 2012 16:03
    Moderador
  • Gracias pero nada. He conseguido indentificar el fix y desinstalarlo en modo a prueba de fallos, pero me ocurre lo mismo, se queda colgado en el mismo punto ¿que puedo hacer por favor? estoy desesperado.
    lunes, 19 de noviembre de 2012 16:13
  • Bueno, he conseguido entrar pero no puedo montar el lamacen de información de exchange. Me dice "iniciando" pero nada. ¿Que puedo hacer por favor?, me han aparecido los errores comentados pero nosé que hacer para que vuelva a funcionar. Necesito ayuda.

    Muchas gracias.

    lunes, 19 de noviembre de 2012 18:17
  • Hola Pocholo22,

    Ante todo, lamento tu situción :-(.

    En primera instancia, te sugiero hacer lo siguiente:

    1. Un backup completo de tu sistema. REQUISITO ABSOLUTO!
    2. ¿Tu sistema operativo tiene muchos updates pendientes? En caso que si, y habiendo completado el paso 1, te sugiero realizarlos. Los relacionados a sistema operativo y todo lo de ambiente, no propiamente del Exchange Server.
    3. Luego hacer los updates de tu Exchange Server, tal como te comentaba Marc Salvador.

    Siguiendo este orden, no deberías tener problemas. Si los problemas continúan, y tenés que salir de la situación, te sugiero abrir un caso en Microsoft (esto depende de la criticidad de tu situación).

    Un abrazo, espero que podamos ayudarte.

    Esperamos tu feedback.


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    martes, 20 de noviembre de 2012 4:07
  • Muchas gracias por responder. He restaurado una copia de hace un par de dias y de momento bien, pero obviamente no me fio.

    Efectivamente tengo algunos updates pendientes, los voy a realizar ahora mismo.

    Respecto al link que adjunta Marc Salvador lo que explican es como prevenir que esto ocurra, pero no qué hacer cuando ya ha ocurrido. De todas maneras, uno de los puntos es, por ejemplo, que la gente no tenga más de 5000 elementos en la bandeja de entrada (¿incluidas subcarpetas?) y esto nosé como puede controlarse (a parte de cómo decirle ahora a la gente que haga limpieza y que tenga esto en cuenta). Tengo límites en los buzones, pero nosé como poner límites de elementos en "Bandeja de entrada". Los otros dos punto tampoco los acabo de enteder, nosé a que se refiere el articulo cuando dice que "puede haber demasiadas búsquedas activadas o algo así". Lo único que tenemos en los equipos es Windows Search, y la gente busca correos con la herramienta de búsqueda de Outlook.

    Muchas gracias por la ayuda y el interés.

    martes, 20 de noviembre de 2012 8:17
  • Otro apunte, desde he actualizado, al hacer la copia de seguridad del Information Store tambien me aparece ahora Site Replication Store ¿que és y que es debido?.

    Muchas gracias.

    martes, 20 de noviembre de 2012 15:37
  • Hola, despues de unas horas se ha vuelto a desmontar la base de datos. Ahora en el visor me aparece sólo el suceso 9518 Error 0xfffffdfd y consigo montarla ni reiniciando. Por favor, necesito ayuda!!!!. Muchas gracias.
    martes, 20 de noviembre de 2012 20:53
  • Hola Pocholo22,

    Recapitularizando:

    • Restauraste una copia de seguridad de días anteriores
    • Hiciste updates pendientes
    • Reiniciaste y no te monta la base de datos

    ¿Es correcto?

    Te invito a revisar lo siguiente:

    • Si tenés antivirus instalado en el equipo, deberías tener las excepciones correspondientes al Exchange Server. Fijate el artículo "Overview of Exchange Server 2003 and antivirus software" en la URL http://support.microsoft.com/kb/823166?wa=wsignin1.0 especial atención al apartado "Exclude the following folders from both on-demand file-level scanners and memory resident file-level scanners".
    • Verificá, a través de un ESEUTIL /MD el estado de la base de datos que no monta. Esto te dará resultado. Lo esperable es que esté en "Clean Shutdown". Si no lo está, te podrá dar "DIRTY SHUTDOWN". Lo esperable es que aparezca algo parecido a la siguiente imagen:

    • Si no está en Clean Shutdown, primero realizá las excepciones de antivirus y luego intentá repararla utilizando ESEUTIL. Aquí tenés guías de como hacer esto: http://support.microsoft.com/?kbid=313184

    En base a esto, esperamos tu feedback.

    Saludos!


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    miércoles, 21 de noviembre de 2012 7:10
  • Muchas gracias. El antirivus lo tengo deshabilitado pero haré igualmente lo que comentas. Los pasos que he hecho són correctos, excepto que sí me montó la base de datos y funcionó durante unas horas, pero luego se desmontó mostrando el error que he comentado. Eso sí, restauré la base de datos con una imagend de disco que tengo, no a traves de las herramientas de Exchange. Probaré lo que comentais e informo.

    Muchas gracias sinceras por la ayuda.

    miércoles, 21 de noviembre de 2012 7:32
  • Bueno, efectivamente me da "Dirty Shutdown" y en Log required: 79960-79960(0x13858-1385b), en priv1.edb y en pub1.edb.

    Intentaré la reparación como siguiente paso.

    Os informo. Muchas gracias.

    miércoles, 21 de noviembre de 2012 7:51
  • La reparación no ha funcionado (con /r) y es escaneo (/p) tampoco me ha aclarado nada. Como realicé el backup desde una imagen de disco voy a realizarlo de nuevo como Dios manda desde la copia de seguridad. Aver que ocurre.

    Un saludo.

    miércoles, 21 de noviembre de 2012 9:20
  • Pocholo22,

    Podrías utilizar eseutil /h para un hard recovery. A diferencia del eseutil /r, que es una reparación lógica, la que te digo es una reparación física. Puede tener en pérdida de datos y depende del tamaño de tu base y la velocidad de tus discos, puede tardar unas horas.

    Ahora, lo que me preocupa, es que tengo entendido que habías recuperado la base de un backup hacía muy poco tiempo.

    Yo chequearía las excepciones de antivirus y, además, trataría de rastrear por qué entró en modo dirty shutdown (es decir por qué tiene faltante de logs).

    Esperamos tu feedback.

    Saludos!


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    miércoles, 21 de noviembre de 2012 11:24
  • Gracias; mi base de datos tiene 62Gb, llevo dos horas y media de restauración. En cuanto esté montada (si puedo) lo comunico para que, mientras funciona, a ver que puedo hacer para que no vuelva  pasar. Lo que quiero es que, una vez restaurada, pasarle un eseutil /MH a ver que me indica en State. Si vuelve a poner "Dirty Shutdown", ¿que paso me recomiendas?.

    He desinstalado todo mi antivirus para evitar histórias.

    Muchas gracias.



    • Editado pocholo22 miércoles, 21 de noviembre de 2012 11:44
    miércoles, 21 de noviembre de 2012 11:35
  • Ay!!. he restaurado la copia pero a la hora de hacer el eseutil /cc del archivo temporal me da el error:

    "Operatino terminate with errors error -939523485(El archivo de registro existente no es contiguo).

    y por supuesto el almacen no se monta. Ya nosé que hacer. Voy a hacer un esetutil /h  como comentas.

    Un saludo.

    miércoles, 21 de noviembre de 2012 12:23
  • Bueno, buenas noticias. Antes de nada he decidido elminar los logs del directorio Mdbdata y al hacer un eseutil /cc para recuperar la copia me ha funcionado bien y he podido montar la base de datos. Ahora estamos funcionando.

    He hecho un eseutil /mh y como State me indica "Clean Shutdown" y ningún error. Tiene buena pinta pero me sigo sin fiar.

    Para estar seguro de que esto no vuelva a suceder ¿que pruebas podría hacer que me diesen tranquilidad por favor?.

    Una cosa que veo es que me crea un montón de logs ¿es normal?, la verdad es que nunca me habia fijado; creo que deberian desaparecer con cada copia de seguridad que se realiza.

    Muchas gracias por la ayuda y un saludo.

    miércoles, 21 de noviembre de 2012 14:06
  • Me vuelve a aparecer el error 9791. Madre mía, vuelta a emprezar.

    Tipo de suceso:                Advertencia

    Origen del suceso:          MSExchangeIS Mailbox Store

    Categoría del suceso:    Limpieza en segundo plano

    Id. suceso:          9791

    Fecha:                  21/11/2012

    Hora:                    15:19:48

    Usuario:                              No disponible

    Equipo:                MAIL

    Descripción:

    La limpieza de la tabla DeliveredTo de la base de datos 'Primer grupo de almacenamiento\Almacén del buzón (MAIL)' se ha pospuesto ya que el almacén de versiones del motor de la base de datos ha alcanzado un tamaño excesivo. Se purgaron 0 entradas.

    ¿que hago por favor?

    Muchas gracias.

    miércoles, 21 de noviembre de 2012 14:24
  • Se me acaba de caer la base de datos de nuevo. Vuelta a empezar, estoy como al principio, ya nosé si reinstarlo todo o montar otro servidor. En fin.

    ¿Alguna sugerencia por favor?.

    Muchas gracias.

    miércoles, 21 de noviembre de 2012 14:51
  • Pocholo22,

    Me alegro con las buenas noticias y lamento las malas. Te comento las siguientes dos cosas:

    • Después de instalar Exchange Server 2003 SP2, el límite por defecto para cada base de datos es de 18 GB, pero puede ser configurado para llegar a un tamaño máximio de 75 GB en el caso de la edición Standard y las versiones SBS 2003. Si tenés o contás con la versión Enterprise, podrás llegar a 8 TB por base de datos (solo versión Standard).
    • Por otro lado, desconozco los porcentuales de espacio libre de tu infraestructura.

    En base a estos dos items, te pregunto:

    • ¿Qué versión tenés instalada?
    • ¿El Exchange tiene los últimos updates?
    • ¿Qué espacio libre tenés en la unidad?
    • ¿Existe algún problema en el storage donde está la base de datos?

    Esperamos tu feedback.

    Saludos!


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    miércoles, 21 de noviembre de 2012 16:26
  • Gracias. Tengo Exchange 2003 Standard Server SP2 sobre un Enterprise server SP2. Mi base de datos (la priv1.edb) tiene 63Gb y sé que el límite són 75, pero por un lado no llego y por otro tengo modificado el registro para que acepte esos 75Gb.

    Exchange está al día de los últimos updates y en la unidad donde está ubicado hay espacio de sobra, es un disco sas en raid uno y no presenta problemas.

    Necesito respuesta urgente por favor.

    Muchas gracias!!!

    miércoles, 21 de noviembre de 2012 16:36
  • La ultima noticia es que me he visto obligado ha eliminar la base de datos y crear una nueva. De momento funciona pero estoy recuperando los buzones de la gente.

    Lo único que no me gusta es que ayer, despues de dejar esto funcionando, realizé una copia de seguridad (con el programa de copia de segurdad de W2003) de el "primer grupo de almacenamiento" (como hago siempre) y me pregunta "si quiero copia de seguridad de los datos de Alacenamiento remoto migrados". ¿que significa eso por favor?.

    Muchas gracias.

    jueves, 22 de noviembre de 2012 7:38
  • Por si alguine le interesa, despues de crear una nueva base de datos (con los problemas que ello conlleva para el personal) todo ha vuelto a la normalidad. De momento llevo una semana y todo ok. Lo que me preocupa es que no se que ha pasado, por lo tanto nosé que puedo hacer para prevenirlo. Si alguien tiene alguna idea será bienvenida.

    Gracias y un saludo.

    jueves, 29 de noviembre de 2012 9:52
  • Hola Pocholo!

    Gracias por el update. Me alegro mucho que hayas podido normalizar la situación.

    Con respecto a la prevención, te puedo recomendar:

    • Que el Storage esté en buen estado.
    • Hacer copias de seguridad (tal como lo hacías) en forma periódica.
    • Revisar Event Viewer a diario para detectar eventos relacionados con Exchange.
    • Mantener tu plataforma de correo actualizada con los últimos parches.
    • Verificar que la defragmentación online se esté dando correctamente, y no coincida con las ventanas de tiempo de backup. Esto es muy importante para mantener la base de datos saludable y optima.

    En conclusión, todo lo que sirva para mantener tu plataforma saludable es bienvenido y ayuda a prevenir algunos problemas relacionados con la misma. Sin embargo, más allá de todo esto, hay eventos que pueden darse que están fuera de control.

    Un abrazo!


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    jueves, 29 de noviembre de 2012 12:31
  • Muchas gracias. Todo lo que comentan lo cumplo en principio. Tan sólo una pregunta más si eres tan amable. Respecto a "Mantener el Storege en buen estado" ¿que procesos me recomiendas realizar y con que periodicidad?.

    Muchas gracias.

    jueves, 29 de noviembre de 2012 14:13
  • Hola pocholo!

    "Que el Storage esté en buen estado" encierra aspectos físicos y lógicos:

    En lo físico:

    • Que no tengas discos alertados o rotos en los arreglos de RAID (se valida a través de tu equipo físico o a través del panel de control RAID de tu fabricante).

    En lo lógico:

    • Que el disco no esté altamente fragmentado (se valida por sistema operativo).
    • Que en la base de datos de Exchange se realicen satisfactoriamente los procesos de defragmentación online en las ventanas de tiempo pactadas y estás tareas no sean interrumpidas por backup u otro proceso (se revisa por Event Viewer).

    Salvo que a otro compañero de foro se le ocurra algo más, esto sería algo lógico.

    Saludos!!


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    jueves, 29 de noviembre de 2012 14:48
  • Muchas gracias; ¿y en cuanto a esetutil?¿a parte de desfragmentar (¿cada cuanto?) de vez en cuando que procesos se recomiendan?.

    Muchas gracias.

    jueves, 29 de noviembre de 2012 16:57
  • Hola pocholo22!

    En cuanto a la utilización de eseutil, si la defragmentación on-line funciona correctamente en tu Exchange, no es cortado por procesos de backup y la ventana de tiempo asignada en la configuración alcanza, no deberías correr el eseutil salvo en situaciones de gran cambio de datos o modificaciones masivas. Tené en cuenta que para correr eseutil dejás a los usuarios sin servicio (salvo que tengas algún esquema de alta disponibilidad).

    Con respecto a los procesos recomendados, siempre verificá el Event Viewer, cuidá la fragmentación de tu disco local y verificá la defragmentación on-line.

    Un abrazo!!


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    lunes, 10 de diciembre de 2012 3:01