locked
error certificado RRS feed

  • Pregunta

  • Hola a todos,

    Tengo la siguiente consulta

    Tengo un servidor exchange server 2010 sp1 configurado con un certificado publico,sucede que los usuarios no estan en dominio sino en Grupo de Trabajo y cuando ingresan al OWA les aparece un mensaje con referencia al certificado ,intente instalarlo pero aun asi , sigue mostrando el mensaje del certificado, estos errores estan apareciendo en mi LAN tengo aproximadamente 500 usuarios con equipos Windows XP y 7, como podria solucionar este problema del certificado en mi LAN, teniendo en cuenta que tengo configurado un certificado publico (hacia e exterior no tengo este problema solo en mi lan)

    Gracias por la ayuda

    viernes, 15 de febrero de 2013 15:51

Respuestas

  • Hola Mikent,

    Si tu problema se presenta solamente en tu LAN, debes generar nuevamente tu certificado y agregar el FQDN de tu servidor a los subject alternative names (namespace dentro del certificado SAN). Esto solucionara tu problema de certificado en OWA dentro de tu LAN

    Te dejo una imagen para que ubiques un poco mejor a lo que me refiero, tu certificado debe tener aqui el fqdn de tu servidor Exchange CAS:


    Saludos cordiales | Exchange Trainer | MCDST-MCTS-MCITP-MCSA-MCT

    • Marcado como respuesta Uriel Almendra viernes, 28 de marzo de 2014 16:15
    viernes, 28 de marzo de 2014 3:54

Todas las respuestas

  • Hola Mikent,

    Si tu problema se presenta solamente en tu LAN, debes generar nuevamente tu certificado y agregar el FQDN de tu servidor a los subject alternative names (namespace dentro del certificado SAN). Esto solucionara tu problema de certificado en OWA dentro de tu LAN

    Te dejo una imagen para que ubiques un poco mejor a lo que me refiero, tu certificado debe tener aqui el fqdn de tu servidor Exchange CAS:


    Saludos cordiales | Exchange Trainer | MCDST-MCTS-MCITP-MCSA-MCT

    • Marcado como respuesta Uriel Almendra viernes, 28 de marzo de 2014 16:15
    viernes, 28 de marzo de 2014 3:54
  • Hola Mikent,

    Aquí hay de 2, una el certificado aparece debido a que es correspondiente a otra entidad (Switch, Router, Firewall, etc) que al iniciar la conexión hace que te solicite el certificado y como no lo tienes te manda el warning.

    La forma de validar esto es realizando lo siguiente, dentro del mismo segmento de red que se encuentra tu server de exchange, conecta un cliente Outlook y haz la prueba, si no te manda warning entonces pues es algo dentro de tu infraestructura.

    La siguiente sería es que tu URL's internas son diferentes a las de tu certificado, tal como lo indica Geovany.

    En ese sentido lo que recomendaría es que dejaras todas las URL's bajo el mismo nombre 

    Ejemplo

    OWA:

    InternalURL: https://owa.dominio.com/owa

    ExternalURL: https://owa.dominio.com/owa

    Autodiscover:

    InternalURL: https://owa.dominio.com/Autodiscover/autodiscover.xml

    ExternalURL: https://owa.dominio.com/Autodiscover/autodiscover.xml

    etc....

    Recuerda que para cambiar las url debes realizar lo siguiente:

    Get-OWAVirtualDirectory |Set-OwaVirtualDirectory -InternalURL https://owa.dominio.com/owa -ExternalURL https://owa.dominio.com/owa

    Y despues realizar un reinicio de IIS.

    Managing Exchange 2010 External/Internal URL's via PowerShell

    viernes, 28 de marzo de 2014 15:51