none
Forefornt no aplica la nueva configuración RRS feed

  • Pregunta

  • Buenas tardes:

    Actualmente tengo un problema con Forefront TMG SP2, ya que al realizar y aplicar cambios de configuración los mismos no quedan efectivos y es necesario reiniciar el servidor para que esto ocurra.

    En la rama Supervisión, sobre la solapa Configuración el campo estado queda permanentemente en "Actualizar" y la fecha de última actualización figura como 29/11/1999 00:00 pm.

    Agradeceré cualquier ayuda que me puedan brindar para resolver este problema.

    Muchas gracias y saludos,

    Enrique

    jueves, 12 de enero de 2012 16:26

Respuestas

  • Hola Jimcesse:

    Si, había probado esa opción pero no resolvió el problema ya que no se aplicaban las nuevas configuraciones. Finalmente pude solucionarlo desconectándo el servidor de la Empresa y conectándolo nuevamente. Probablemente se hayan actualizado algunas cuestiones de Active Directory porque volvió a tener acceso a la BD de configuración.

    Desde ya muchas gracias por tu colaboración.

    Saludos,

    Enrique

    martes, 24 de enero de 2012 11:45

Todas las respuestas

  • Hola Enrique

    El sintoma que mencionas podría deberse a problemas de conexion contra tu Active Directory o inclusive privilegios... Te recomiendo para recopilar mayor información corras un analisis con BPA.

    http://jimcesse.wordpress.com/2011/12/30/troubleshooting-best-practices-analyzer-tmg-2010/

    Saludos,


    Jimcesse
    Mi Blog: http://jimcesse.wordpress.com/
    
    viernes, 13 de enero de 2012 1:52
    Moderador
  • Hola Jimcesse:

    Te comento que realicé análisis con BPA y el único problema que me reportó estaba relacionado con falta de permisos a la cuenta servicio de red y systema sobre el directorio Logs de Forefront, lo cual ya fue corregido. Igualmente, el problema persiste.

    Cuando reviso la solapa Configuración el campo estado queda permanentemente en "Actualizar" y la fecha de última actualización figura como 29/11/1999 00:00 pm.

    Desde ya muchas gracias y saludos,

    Enrique

    viernes, 13 de enero de 2012 11:21
  • Hola Enrique

    Si te marco ese error, quiere decir que tienes la base de datos en otros directorios y/o particiones a como viene por defecto !? Me podrias confirmar ese dato !!!

    Saludos,


    Jimcesse
    Mi Blog: http://jimcesse.wordpress.com/
    
    viernes, 13 de enero de 2012 18:05
    Moderador
  • Hola Jimcesse:

    Efectivamente, las base de datos del registro de firewall y proxy web y la cola de registros se encuentran en un disco diferente. Te comento que en un momento las volví a su ubicación por defecto y el problema persistía, por lo cual las dejé nuevamente en el otro disco. Ahora, revisando el estado de la configuración, veo un error con el siguiente mensaje:

    "Administración de Forefront TMG no puede establecer una conexión con el servidor de almacenamiento de configuración 'SRV-TMG-1' ".

    SRV-TMG-1 es el nombre del equipo donde se encuentra instalado Forefront TMG.

    Como puedo verificar donde se encuentra almacenada la configuración?

    Desde ya muchas gracias.

    Enrique

    lunes, 16 de enero de 2012 11:36
  • Si vas a la opcion de Logs & Reports > Task > Configure Logging ahi puedes ver donde tienes las bases de datos... Te cuento que te pregunte si tienes las DBs en otras particiones ya que hace unos días estuve leyendo este articulo: http://blogs.technet.com/b/isablog/archive/2008/09/08/isa-administrative-roles-ntfs-and-registry-permissions.aspx aplica para ISA Server pero no creo que en TMG sea diferente...

    Basicamente lo que entiendo es que cada vez que los servicios de ISA Server se reinician le quita los siguientes privilegios:

    Network Service: Full Control
    System: Full Control
    Administrators: Full Control

    A las carpetas donde se encuentran las bases de datos si no es la ruta default !!! Asi que creo que por ahi debe andar tu problema... Revisa el articulo y esto otro link: http://social.technet.microsoft.com/Forums/en-US/Forefrontedgegeneral/thread/371be65d-08d5-4471-ade6-3f8193e720c4 y comentanos si te ayudan...

    Saludos,


    Jimcesse
    Mi Blog: http://jimcesse.wordpress.com/
    
    jueves, 19 de enero de 2012 23:42
    Moderador
  • Gracias nuevamente por tu atención. Te comento que revisé los artículos que me indicaste.

    Efectivamente, al reiniciar los servicios de Forefront, se quitan los permisos necesarios de las carpetas de Logs, no solo en la ubicación alternativa sino también en el directorio por defecto. Esto ocurre cada vez que se reinicia el servicio de firewall, lo que ocurre es que desaparece el permiso configurado para la cuenta "Servicio de red". Los permisos de las cuentas System y Administradores permanecen sin cambios.

    Cualquier cambio que realizo sobre la configuración de TMG no se aplica, ni si quiera los relacionados con la ubicación de los logs. Esta es una captura del estado de la configuración de mi servidor:

    Voy a seguir investigando el tema de los permisos. Agradeceré cualquier consejo que me puedan brindar.

    Muchas gracias y saludos,

    Enrique

    viernes, 20 de enero de 2012 11:26
  • Si anteriormente lo que yo habia hecho fue devolver las DB a su locacion original y eso me corrigio el problema... Ya probastes esa opcion !?

    Saludos,


    Jimcesse
    Mi Blog: http://jimcesse.wordpress.com/
    
    • Propuesto como respuesta Ismael Borche lunes, 23 de enero de 2012 12:37
    viernes, 20 de enero de 2012 14:29
    Moderador
  • Hola Jimcesse:

    Si, había probado esa opción pero no resolvió el problema ya que no se aplicaban las nuevas configuraciones. Finalmente pude solucionarlo desconectándo el servidor de la Empresa y conectándolo nuevamente. Probablemente se hayan actualizado algunas cuestiones de Active Directory porque volvió a tener acceso a la BD de configuración.

    Desde ya muchas gracias por tu colaboración.

    Saludos,

    Enrique

    martes, 24 de enero de 2012 11:45
  • Muchas gracias enrique y que excelente noticia que ya pudiste solucionar tu inconveniente, cualquier otra duda por acá estaremos...

    Saludos,


    Jimcesse
    Mi Blog: http://jimcesse.wordpress.com/
    
    martes, 24 de enero de 2012 15:20
    Moderador