none
Problema migrando W2K3 a W2K8: No hay servidores de inicio de sesión disponibles para atender la solicitud de inicio de sesión RRS feed

  • Pregunta

  • Bien, sigo a vueltas con mis problemas en la migración de Windows 2003 a Windows 2008 (con lo sencillo que debería ser esto...).

    Situación actual:

    Servidor principal:

    1. Windows 2003 Server R2

    Servidor secundario:

    1. Windows 2008 Standard
    2. Todas las actualizaciones instaladas
    3. Configurado como servidor secudario del dominio
    4. Transferidos correctamente todos los roles entre el w2k3 y el w2k8

    Problema: si apago el servidor principal, en las máquinas puedo entrar con el usuario habitual de la máquina (entiendo que porque los datos están en la caché y como son iguales me sigue dejando entrar). Para comprobar que realmente funciona, lo que hago es crear en el w2k8 un nuevo usuario con su correspondiente contraseña. Me voy a una de las máquinas e intento iniciar sesión con ese usuario. En ese momento me sale el mensaje de error del asunto:

    No hay servidores de inicio de sesión disponibles para atender la solicitud de inicio de sesión

    Y no me deja entrar, claro... Con lo cual, algo está fallando.

    Otro fallo que encontré es que en el servidor nuevo no puedo ver las políticas de grupo si el servidor antiguo está apagado, si está encendido sí que las veo y además veo que replican bien si hago algún cambio en el antiguo... Estuve mirando las políticas y veo que en el servidor antiguo se ejecutan al iniciar sesión, varios .bat que conectan unidades, etc... y que apuntan a un directorio donde están alojados en el servidor antiguo y que no están en el nuevo (quería cambiar esos archivos después, me da igual que en la migración no aplique las políticas). ¿Sabéis si esto le puede afectar al primer problema?

    Un saludo y gracias de antemano. Es URGENTE, querría hacer este cambio el domingo para no molestar a ningún usuario el lunes :D

     


    --Eclat
    domingo, 29 de mayo de 2011 10:44

Respuestas

  • Bien, parece que seguimos avanzando. He seguido el procedimiento descrito (casi todo) en el siguiente artículo:

    http://support.microsoft.com/kb/315457

    Básicamente, en el servidor W2K3 paré el servicio FRS con: net stop ntfrs, luego modifiqué el parámetro de BurFlag a D4. En el W2K8 paré igualmente el servicio y modifiqué el parámetro a D2.

    Arranqué el servicio en W2K3 y después de un poquito arranqué el servicio en W2K8. Una vez hecho esto vi como se empezaban a llenar los datos en el W2K8 y si hacía en este último un net share ya veía las carpetas sysvol y netlogon compartidas.

    Ahora voy a volver a hacer las pruebas, a apagar el W2K3 y a ver si el W2K8 ya es capaz de controlar los inicios de sesión...


    --Eclat
    • Marcado como respuesta Eclat2k domingo, 29 de mayo de 2011 19:17
    domingo, 29 de mayo de 2011 16:04

Todas las respuestas

  • Sigo investigando el problema y haciendo un NET SHARE desde el servidor de dominio que quiero que pase a ser el nuevo, veo que no existe el recurso compartido SYSVOL ni el NETLOGON... umm, esto no es bueno.

    Si alguien sabe como hacer que aparezcan estos recursos le quedaría muy agradecido, sigo investigando... Os mantendré informados...


    --Eclat
    domingo, 29 de mayo de 2011 12:48
  • Hola , bien . El quetiene los FSMO es el 2008 , ahora? Como dejastes las configuraciones de Sites , DNS ?
    Jorge Cavallin - Argentina
    domingo, 29 de mayo de 2011 14:13
  • Buenas tardes Jorge, gracias por contestar. Sí, el 2k8 es ahora mismo el que tiene todo, de hecho si hago un: netdom query fsmo, todos los resultados son del 2k8, así que parece que está ok. Si borro un registro DNS en el 2k3, al poco tiempo se replica la eliminación en el 2k8, así que parece que esto también está funcionando bien. Con respecto a los Sites, ¿qué te parece que debo mirar?

    Sigo buscando información sobre el problema del SYSVOL y el NETLOGON, que en el 2003 sí me aparecen como recursos compartidos, pero en el 2k8 no y eso no está bien, verdad?

    Muchas gracias por la ayuda


    --Eclat
    domingo, 29 de mayo de 2011 14:52
  • Bien, parece que seguimos avanzando. He seguido el procedimiento descrito (casi todo) en el siguiente artículo:

    http://support.microsoft.com/kb/315457

    Básicamente, en el servidor W2K3 paré el servicio FRS con: net stop ntfrs, luego modifiqué el parámetro de BurFlag a D4. En el W2K8 paré igualmente el servicio y modifiqué el parámetro a D2.

    Arranqué el servicio en W2K3 y después de un poquito arranqué el servicio en W2K8. Una vez hecho esto vi como se empezaban a llenar los datos en el W2K8 y si hacía en este último un net share ya veía las carpetas sysvol y netlogon compartidas.

    Ahora voy a volver a hacer las pruebas, a apagar el W2K3 y a ver si el W2K8 ya es capaz de controlar los inicios de sesión...


    --Eclat
    • Marcado como respuesta Eclat2k domingo, 29 de mayo de 2011 19:17
    domingo, 29 de mayo de 2011 16:04
  • Listo, todo funcionando ok. He instalado W2k8 en el que antes estaba el W2k3 y funcionó todo correctamente... como debería ser... ahora a configurar los recursos compartidos, etc... pero todo ok.

    Gracias por la ayuda Cavallin :D


    --Eclat
    domingo, 29 de mayo de 2011 19:17