none
Encuestas anónimas con braches piden autenticación RRS feed

  • Pregunta

  • Hola a todos,

    estoy trabajando en una encuesta para usuarios anónimos en Sharepoint Foundation 2010. 

    La configuración del acceso anónimo es correcta y los usuarios anónimos pueden guardar las respuestas.

    El caso es que los branches no funcionan correctamente. En concreto a mi lo que me ocurre es:

    - no hace caso a la lógica del primer branch

    - después pide autenticación

    El caso es que en internet sólo he encontrado este enlace.

    http://social.technet.microsoft.com/Forums/en/sharepointadminlegacy/thread/2b4fcec0-0d16-4157-8fe0-cd59cfc287bd

    Básicamente dice que me olvide de usar branch con encuestas anónimas y me cuesta reconocerlo (además de que ya se ha apalabrado con el cliente de que no habría problema). 

    Alguien sabe si hay alguna manera de resolver esto?

    Muchas gracias!


    viernes, 2 de noviembre de 2012 14:23

Todas las respuestas

  • Para identificar mejor el problema, remito el error que aparece en el log, si cuando pide la autenticación se le dan unas credenciales válidas:

    Microsoft.SharePoint.SPException: No existe ningún elemento en http://Server/Lists/Lista/EditForm.aspx?ID=48&FirstField=_x0035__x002e__x0020_Titulaci_x0. Puede que otro usuario lo haya eliminado o le haya cambiado el nombre.    en Microsoft.SharePoint.SPContext.get_Item()     en Microsoft.SharePoint.SPContext.ContentTypeInternal(String contentTypeId)     en Microsoft.SharePoint.WebPartPages.ListFormWebPart.get_TemplateName()     en Microsoft.SharePoint.WebPartPages.ListFormWebPart.ShowRibbon()     en Microsoft.SharePoint.WebPartPages.ListFormWebPart.OnInit(EventArgs e)     en System.Web.UI.Control.InitRecursive(Control namingContainer)     en System.Web.UI.Control.AddedControl(Control control, Int32 index)     en System.Web.UI.WebControls.WebParts.WebPartManager.WebPartManagerControlCollection.AddWebPartHelper(WebPart webPart)     en System.Web.UI.WebControls.WebParts.WebPartManager.WebPartManagerControlCollection.AddWebPart(WebPart webPart)     en System.Web.UI.WebControls.WebParts.WebPartManagerInternals.AddWebPart(WebPart webPart)     en Microsoft.SharePoint.WebPartPages.SPWebPartManager.AddWebPartWithRetry(WebPart webPart)     en Microsoft.SharePoint.WebPartPages.SPWebPartManager.CreateWebPartsFromRowSetData(Boolean onlyInitializeClosedWebParts)     en Microsoft.SharePoint.WebPartPages.SPWebPartManager.LoadWebParts()     en Microsoft.SharePoint.WebPartPages.SPWebPartManager.OnPageInitComplete(Object sender, EventArgs e)     en System.EventHandler.Invoke(Object sender, EventArgs e)     en System.Web.UI.Page.OnInitComplete(EventArgs e)     en System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    viernes, 2 de noviembre de 2012 17:22
  • Hola,

    Pues si se trata de un bug me parece que no hay nada que hacer al respecto salvo tirar por un desarrollo personalizado.

    Saludos


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.gavd.net/servers/compartimoss/compartimoss_main.aspx
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------

    viernes, 2 de noviembre de 2012 17:24
  • Para terminar, parece que los separadores también dan problemas. Una vez eliminados los separadores y los branches, un usuario anónimo puede cumplimentar la encuesta sin problema.

    Si alguien tiene solución o un workaround más elegante que lo comente please!

    Gracias

    viernes, 2 de noviembre de 2012 17:25