none
Problemas con NLB RRS feed

  • Pregunta

  • Presento inconveniente con el nlb, tengo instalado un cluster de apache con 2 equipos que tienen Windows server 2012 y una tercera maquina como el balanceador, de un momento a otro no resuelve las direcciones de las paginas y al validar cada nodo el servicio de apache se encuentra arriba, para que las paginas vualvan a cargar, debo reiniciar los servicios afectando la operatividad de la empresa
    lunes, 27 de junio de 2016 18:42

Todas las respuestas

  • Hola E.David_P

    Podrías poner más detalles de la configuración del servicio? Por lo que comentas podría ser el Cluster VIP Configuration o la configuración del Virtual Service que estas asociando. 

    Mientras tanto podrías hacer un ping a ambos servicios para ver si responden y despúes asociar un VS a alguno de los servicios relacionados y probar el ruteo a través de ese VS para saber si tienes algún problema en la configuración del balanceador.

    Te adjunto una configuración básica http://www.serverlab.ca/tutorials/windows/web-servers/load-balancing-web-servers-with-windows-server-2012-r2/

    Si tu configuración no es tan compleja para este entorno podrías probar también el balanceador de Kemp y obtener diagnósticos más detallados, https://kemptechnologies.com/server-load-balancing-appliances/virtual-loadbalancer/vlm-download/

    Saludos!


    David Rendón @DaveRndn

    jueves, 30 de junio de 2016 3:20
  • Hola David Rendón

    Gracias por contestar, te informo los detalles del cluster que tengo instalado:

    Son 3 maquinas virtuales con Windows server 2012 r2

    Dos de estas maquinas las tengo configuradas como nodos las ip son nodo1: 192.168.146.40 y el nodo2: 192.168.146.41 en ellas tengo instalado el servicio de Apache 2.4 y la tercera es donde tengo configurado el nlb que es la ip 192.168.146.42 la ip virtual que me da la tercera maquina es 192.168.146.43.

    El ping desde cualquier nodo me responde, pero de un momento a otro se vuelven lentas las aplicaciones y no cargan, al validar el servicio de apache se encuentra arriba pero las aplicaciones no cargan, en ocasiones debo ejecutar el comando nlb reload o reiniciar el servicio de apache para que vuelvan a cargar lo cual genera indisponibilidad del servicio. 

    De acuerdo al link que me envías observo que solamente se utilizan dos servidores y configuro sobre cualquier nodo el rol de nlb para levantar la ip virtual, te pregunto ¿en la configuración que tengo me sobra un maquina? ¿A cada nodo o  servidor se debe agregar dos tarjetas de red? ¿Una con gw y la otra sin gw? En el caso que si ¿Estas dos tarjetas deben estar en la misma vlan?.

    Agradezco la ayuda que me puedas brindar

    viernes, 1 de julio de 2016 2:46
  • Hola E.David_P,

    Respecto a si te sobra una máquina, podrías utilizar el default gateway del Server como el LB y ahi la recomendación sería utilizar la configuracion del NAT Mode en Layer4, por otro lado, si tienes las VIP de los web servers en la misma subnet lo podrías utilizar en modo DR.

    Se recomienda tener múltiples NIC´s para poder asegurar la comunicación entre los recursos que tienes dentro de tu cluster, además de que nos ayuda a separar el tráfico suponiendo si tienes un front-end y back-end. 

    Como nota adicional podrías tener un par de LB´s para asegurar la disponibilidad del servicio, los nodos 1 y 2 que comentas (nodo1: 192.168.146.40 y el nodo2: 192.168.146.41), podrían estar dentro de la misma VLAN, te sugiero revisar la configuración del VS del cluster con las IP Adresses asociadas. 

    Espero tus comentarios

    Saludos!


    David Rendón @DaveRndn

    • Propuesto como respuesta Dave RendónMVP jueves, 27 de diciembre de 2018 0:36
    domingo, 3 de julio de 2016 21:13