none
mensaje de error 202 en server de Terminal Server W2003 RRS feed

  • Pregunta

  • Hola,

    hace unos días he configurado 2 servidores (A y B) para que puedan usar el servicio de Terminal Service por usuario (para unos 15 usuarios), obteniendo las licencias de TS de un servidor C.

    Lo he hecho siguiendo estas indicaciones:

    http://www.ajpdsoft.com/modules.php?name=News&file=article&sid=258

    El servidor C solo es server de licencias de TS, y no lo he configurado para que también acepte mas de 2 conexiones de TS (las de defecto).

    No sé si este será el problema, pero desde entonces en el servidor C obtengo el siguiente error en el visor de sucesos de aplicaciones:

    *******************************
    Tipo: Error
    Id. de suceso: 202
    Descripción:

    No hay más licencias para Windows Server. Use el Administrador de licencias de la carpeta Herramientas administrativas para más información sobre qué usuarios están sin autorización y cuántas licencias deben adquirirse.

    *******************************

    Por lo que he leído en internet, se trata de un problema con las licencias de TS, y no sé como resolverlo. Me preocupa el hecho de que en 120 días más podría dejar de funcionar, y por tanto los usuarios no podrán mas entrar via TS a los servidores A y B.

    Los 3 servidores son Windows 2003 Estandar SP2.
    Tanto el server A, como el B, detectan al server C como un servidor válido de licencias de TS, y ni el A ni el B me dan ningún tipo de error en sus visores de sucesos respectivos.

    Gracias x la ayuda.
    miércoles, 1 de julio de 2009 15:01

Todas las respuestas

  • TS requiere licencias específicas (TS-CAL) para los clientes ¿las tienes? ¿las haz puesto en el servidor de licencias?

    No tienen nada que ver con las dos incluidas que son para administración remota.

    Guillermo Delprato - MVP - MCT - MCSE - MCSA - MCTS:AD Buenos Aires, Argentina
    jueves, 2 de julio de 2009 12:26
    Moderador
  • Si, las tengo, y si miras el tutorial que seguí, verás que en un momento de la instalación del server de licencias (que es mi servidor C) las pide: fue en ese momento que las puse.

    ¿Podría ser un problema con las CAL de usuario, y no con las de TS? Porque el server C también tiene el Active Directory (aunque no es el PDC principal). Y hace unos días descubrí que los otros servers de mi red con Active Directory daban un error en el event viewer diciendo que no podían contactar con el server de licencias (que era una antiguo server que se rompió, y que no existe mas). Entonces entré en el registro, y en la clave de registro en donde se tiene que meter el nombre del server de licencias (que, x lo que leí, se refería al server de licencias de TS, y no al de CAL de usuarios) puse el nombre de mi server C.

    No obstante, también tengo comprados CALs de usuarios normales... aunque no tengo ni idea si tengo que poner esas licencias en alguna parte del servidor, o solo es suficiente con tenerlas compradas a Microsoft (para no estar ilegal).

    Gracias.

    PD: te paso mas datos, a ver si esto aclara la situación.

    1. la clave de registro de los otros server con AD de mi red es
             EnterpriseServerMulti: serverc.dominio.com

    2. dejé vacía la clave
             DomainLicenseServerMulti: nada

    3. si miro el "Administrador de licencias" del server C, veo que aparecen listados todos los usuarios de mi red: en la columna "uso con licencia" aparecen todos "0", y en la columna "uso sin licencia" aparecen todos "1".

    4. en "Sitios y servicios de AD" he puesto que mi server de licencias es el server C.

    5. lo raro de todo esto, es que anteriormente mis 2 servers con AD, a los cuales ahora he configurado para que usen el server C como servidor de licencias, me daban el error de que no encontraban el servidor antiguo (el roto), pero nada mas. Y a partir de este momento me aparecieron los errores en el server C.
    • Editado Argie01 viernes, 3 de julio de 2009 8:51
    viernes, 3 de julio de 2009 7:28
  • Habría que verificar en el servidor de licencias de TS, pero me da por lo que pones que el mensaje de error no se refiere a TS.

    TS no es algo que conozca demasiado :-(, a ver si aparece por el hilo alguno que pueda dar una mano

    Guillermo Delprato - MVP - MCT - MCSE - MCSA - MCTS:AD Buenos Aires, Argentina
    viernes, 3 de julio de 2009 12:20
    Moderador
  • Si Guillermo, yo pienso lo mismo.

    Pero entonces el problema podría ser mayor, ya que no sé que sucede en una red Windows si los usuarios no tienen las CALS de usuarios instaladas en el server de licencias:

    ¿tendré problemas de AD? ¿podré seguir dando de alta/baja users de red sin problemas?

    Ojalá alguien me pueda aclarar estas dudas... pero igual gracias x tu ayuda!
    lunes, 6 de julio de 2009 8:39
  • Argie , definitivamente el error no parece ser de TS licensing, cuando instalaste el DC recuerdas si lo instalaste con licencias per seat , o per server ? Chequea la consola de Licensing en Administrative Tools fijate ahi si tienes asignadas licencias a usuarios que por ejemplo ya no existan , puedes  hacer un revoke , de otra manera quizas realmente estes out of licences.

    202 The product ProductName is out of licenses. Use Licensing from the Administrative Tools folder for more information on which users are out of compliance and how many licenses should be purchased.

    Indicates a licensing violation. All the licenses for the specified product have been assigned to users. Use Licensing in Administrative Tools to find out which users are out of compliance. You can find out how many licenses should be purchased or revoke licenses from users who are not using them.

    http://technet.microsoft.com/en-us/library/cc784728(WS.10).aspx


    Sebastian del Rio - MCP - MCSA +S - MCSE +S - MCTS: AD - MCTS: ISA 2006 Buenos Aires - Argentina
    lunes, 6 de julio de 2009 10:24
    Moderador
  • Sebastian,

    muy probablemente lo instalé con licencias per server. De hecho, ya me di cuenta que estoy out of licences.

    Ahora bien, tengo 2 preguntas relacionadas con esto:

    1. Suponiendo que tuviera compradas CALs de usuario (que no sé si las tengo), sería posible cambiar el licence key del DC para usar una licencia con CALs?
    2. Y si no hago nada, es decir, dejo el error así: ¿me traerá problemas de AD, tales como no poder dar de alta mas usuarios, o que estos no se puedan logar? o es un problema de si MS viene a ver las licencias que tengo?

    La pregunta 2 es la mas importante para mí. Porque si el AD deja de funcionar (o algo así) necesito hacer algo ya, como por ejemplo desinstalar el server TS de mi server C, e instalarlo en otro server (ya que configuré mis Sitios y Servicios de AD para que el server de licencias sea el C, entonces supongo que si lo instalo en un server con nombre diferente, a lo sumo volveré a tener los errores que me daban antes mis otros servers con AD...)

    Gracias!
    lunes, 6 de julio de 2009 11:02
  • Argie01, son dos licencias diferentes, unas son las CAL (para que el cliente se conecte al servidor)
    Y otras diferentes las TSCAL que son específicas de Terminal Server

    El licenciamiento CAL siempre se puede pasar de Per Server a Per Seat, la condición legal a cumplir es que tengas tantas licencias como clientes existan en tu empresa.

    Cuando excedes el número de licencias CAL Per Server, no es que no puedas crear más usuarios, es que no puede haber más de X cantidad de cuentas conectadas al servidor.

    Guillermo Delprato - MVP - MCT - MCSE - MCSA - MCTS:AD Buenos Aires, Argentina
    lunes, 6 de julio de 2009 13:17
    Moderador
  • Gracias Guillermo,

    si que me queda claro lo que me explicas, pero parece que no me estoy explicando bien, y entonces tu respuesta no es lo que yo intentaba saber.

    De todas maneras creo que tanto tú como Sebastian ya se han molestado bastante en contestarme, así que os lo agradezco de nuevo, y podemos cerrar este tema.
    martes, 7 de julio de 2009 10:16
  • Argie , me atrevo a contestar por guillermo tambien, y te digo que no molestas :), asi que intenta explicarte mejor a ver si podemos darte la respuesta que tu esperas , o bien alguien mas que pueda colaborar , que despues de todo esa es la finalidad del foro :)
    Sebastian del Rio - MCP - MCSA +S - MCSE +S - MCTS: AD - MCTS: ISA 2006 Buenos Aires - Argentina
    martes, 7 de julio de 2009 11:00
    Moderador
  • Gracias Sebastian,

    el status del problema ahora es el siguiente:

    1. tengo la cantidad de CALs de usuarios necesarios para todos los users de mi red, compradas a un proveedor.
    2. Voy a mi server de AD, y de licencias de TS, a la ventana "Otorgamiento de licencias" (Administrador de licencias), y en el menú Licencias-->Agregar nueva licencia, las agrego (simplemente marcando el nro de licencias que tengo, es decir, no tengo que poner nro de serie, ni nada similar).
    3. Veo entonces que en la pestaña "Ver productos" tengo X licencias (la misma cantidad que agregué en el punto 2) asignadas por usuario o dispositivo, y que en cambio en la pestaña "Clientes" aparecen todos mis usuarios, pero solo 1 de ellos está marcado con un "1" en la columna "uso con licencia", y todos los demás aparecen con un "1" en la columna "uso sin licencia".

    Resumiendo, el punto 3 es el verdadero problema, ya que a pesar de agregar licencias, aparentemente todos los usuarios de mi red no están funcionando con ellas. ¿Como puedo solucionar esto?

    Gracias de nuevo.
    jueves, 16 de julio de 2009 13:37