none
Disco Duro desaparece RRS feed

  • Pregunta

  • Estimados,

    Muy buenas tardes, vengo con una pregunta a la que no logro encontrarle una respuesta/solución y agradeceré sugerencias. 

    En la oficina tenemos un servidor con Windows Server 2008 (no r2) el cual consta de dos discos duros. Inicialmente se instalaría un tercer disco duro, por lo que el segundo disco se configuro como dinámico (para posteriormente crear la raid), este es el disco que contiene los archivos que se comparten en la red. 

    El segundo disco se instalo hace aproximadamente tres semanas, pero desde la semana pasada el disco comenzó a "desaparecer" durante la noche (cuando volvíamos en la  mañana, el disco no aparecía en "Equipo"),  al buscar un poco leí dos posibles causas: 1.- Los discos dinámicos con uso intermitente o corruptos se desactivan y la otra opción era las opciones de energía y que windows a veces no puede "reactivar" algunos discos. 

    En base a las posibles soluciones que encontré, decidí cambiar el disco a básico nuevamente y hacerle un chequeo, el scan arrojo que el disco no tenia errores (Lo realice con HD TuneUp y SMART no muestra errores) y en opciones de energía, el disco esta configurado para nunca apagarse. 

    Lamentablemente el problema persiste y ya se me están acabando las posibles soluciones, si alguien tiene alguna sugerencia se los agradecería mucho. 

    Saludos,

    • Editado Xgito sábado, 21 de febrero de 2015 16:18
    sábado, 21 de febrero de 2015 16:17

Respuestas

Todas las respuestas

  • Hola Xgito,

    Es bastate extraño el caso que comentas, y preocupante, sobre todo si en ese disco están los datos que compartes por red, supongo que es un disco interno.

    En primer lugar espero que tengas un backup al día de los ficheros, no sea que tarde o temprano ese disco no de más de sí, o en alguna de las pruebas lo pierdas, no se si ya tienes un RAID 1 o  es justo lo que pensabas hacer cuando introdujeras el tercer disco.

    • Puedes mirar si el driver de tu disco es el último, y tu sistema lo tiene al día.
    • Puedes contactar con el fabricante del disco por si es un problema del que tengan constancia.
    • Intenta averiguar a que hora comienza el "apagado" del disco, busca todo lo que puedas en los visores de eventos, seguro que encuentras alguna pista.
    • Tu server no se le habrá activado o modificado a un modo de ahorro de energía?


    Daniel Graciá - Madrid / España

    MCSA 2012, MCSA 2008, MCITP Enterprise Admin
    MCTS SCOM 2007, Windows Vista Configuration
    MCSA 2003 + Security, MCSE 2003 + Security
    MCP ISA SERVER 2000,ITIL Foundation v3

    El Blog de Dani Gracia
    Dani Gracia en Twitter
    Dani Gracia en LinkedIn

    sábado, 21 de febrero de 2015 19:56
  • Estimado Daniel,

    Muchas gracias por tu respuesta. Si, mantengo un backup diario. Respecto a la pregunta de la RAID, pensaba habilitarla, pero es un tema que esta pendiente hasta que se compre el otro disco (Que no se cuando sera o si es que se comprara).

    Respecto a tus sugerencias, busque nuevos drivers y no encontré nada, tampoco encontré nada relacionado con Western Digital (Excepto lo que comente al comienzo, respecto a los discos dinámicos y al ahorro de energía). Aunque no revise si en la BIOS existe algún tema respecto al ahorro de energía ni tampoco revise el visor de Eventos. 

    Lo que se me olvido mencionar, es que el disco vuelve a aparecer una vez que se reinicia el servidor, pero se debe reiniciar dos veces. 

    La primera vez que se reinicia (Reinicio, no apagar y prender) el servidor, durante el boot de BIOS se queda "pegado" detectando el segundo disco durante un par de minutos y luego pasa a iniciar windows, el cual se queda cargando eternamente (Lo más que he esperado ha sido 10 minutos), luego de esperar a que cargue sin éxito me veo forzado a apagar el servidor a la fuerza y volver a encenderlo y es luego de esto que el servidor prende y el disco aparece como si nunca hubiera pasado nada. 

    Ahora que lo pienso (luego de escribir esto),  tal vez no sea un problema directamente de Windows, si no que de la BIOS o del servidor en si. De todas maneras, todas las sugerencias son bienvenidas. 

    sábado, 21 de febrero de 2015 20:08
  • Mira bien la BIOS ... no sea que el origen del problema esté ahí, y no olvides los visores de eventos, que muchas veces son la clave para detectar problemas.

    Por lo que comentas hasta que no haces un apagado del server, y vuelves a encender no se vuelve a detectar el Disco, así que es como si tu BIOS tampoco lo detectase o lo desactiva.

    Cuando suceda y hagas el primer reinicio entra en BIOS para investigar todo lo que puedas, si ves el disco, etc.

    Es un tanto descabellado pero por comprobar, mira si todo está bien a nivel de cableado, y conexión del disco.

    Todo son suposiciones.



    Daniel Graciá - Madrid / España

    MCSA 2012, MCSA 2008, MCITP Enterprise Admin
    MCTS SCOM 2007, Windows Vista Configuration
    MCSA 2003 + Security, MCSE 2003 + Security
    MCP ISA SERVER 2000,ITIL Foundation v3

    El Blog de Dani Gracia
    Dani Gracia en Twitter
    Dani Gracia en LinkedIn

    • Propuesto como respuesta Moderador M domingo, 22 de febrero de 2015 0:01
    sábado, 21 de febrero de 2015 20:28
  • Revisa el tema comentado en este blog, a ver si hay suerte:

    http://hispaniolasoft.blogspot.com.es/2012/04/normal-0-21-false-false-false-es-do-x.html

    Si se trata de un disco de Western Digital es posible que la función PUIS que tienen algunos modelos de esta marca este provocando el fallo.

    Utiliza también la herramienta de diagnostico del fabricante:

    Data Lifeguard Diagnostic for Windows
    http://support.wdc.com/product/download.asp?groupid=502&sid=3&lang=en

    Al descomprimir el archivo .zip se puede ejecutarlo desde la carpeta sin necesidad de instalación.


    Saludos cordiales. Ivan


    • Editado IvanCG sábado, 21 de febrero de 2015 22:16
    • Propuesto como respuesta Moderador M domingo, 22 de febrero de 2015 0:01
    • Marcado como respuesta Moderador M martes, 24 de febrero de 2015 23:19
    sábado, 21 de febrero de 2015 22:16