none
Inventario Hardware RRS feed

  • Pregunta

  • Buenas

    Yo he testeado con mofcomp una clase y una vez añadida al repositorio de una maquina de referencia

    la he añadido a System Center ( al apartado de Client Agent ) pero mis otras máquinas no estan tomando ese valor

    aunque fuerce el inventario. En el log de una maquina en la que no se añade indica: class do no exist

    ¿ a que se rerfiere? ¿ Que pasos he de seguir??

    Gracias y un saludo


    MCITP

    jueves, 22 de enero de 2015 20:17

Respuestas

  •  Marcela... Yo no necesito añadir información

     Necesito que System Center agregue la nueva clase al espacio WMI y luego obtenga los valores

     que ya existen en dicha clave del registro

     Como podría hacerlo?? No entiendo porque System Center no agrega la nueva clase en el

     cliente  tras mi edición del  .MOF en el servidor de System Center

     Un saludo

    MCITP


    • Editado Ralpph lunes, 2 de febrero de 2015 15:51
    • Marcado como respuesta Ralpph miércoles, 4 de febrero de 2015 11:37
    lunes, 2 de febrero de 2015 15:51

Todas las respuestas

  • Buenos días.

    Te dejo la referencia para agregar nuevas clases en ConfigMgr.

    https://technet.microsoft.com/en-us/library/gg712290.aspx 

    Saludos.


    Ayuda a la comunidad. Si consideras que la respuesta te fue util, marcala por favor como respuesta final. Marcela Berri Instructor/Consultor Senior IT MCT–MVP Enterprise Client Management MCTS Server Admin/AD2008/Network Inf/Srv Virt2012R2/W7yOff2010 MCTS SCCM2012/2007/SCOM2007 MCITP Exchange 2010/2007-MCTS Exch2010/2007-MCTS Lync2010 ITTechnologySite.blogspot.com

    viernes, 23 de enero de 2015 15:49
  • Lo hice asi y la clase esta agregada pero al Forzar el Inventario Hardware ..en :

    InventoryAgent.Log del cliente me indica que : class do no exist

    Sabes porque podria ser?

    Saludos y gracias


    MCITP

    viernes, 23 de enero de 2015 18:09
  • Si el procedimiento está hech, seguramente significa que ese tipo de cliente, no tiene esa clase por su arquitectura.

    Saludos.


    Ayuda a la comunidad. Si consideras que la respuesta te fue util, marcala por favor como respuesta final. Marcela Berri Instructor/Consultor Senior IT MCT–MVP Enterprise Client Management MCTS Server Admin/AD2008/Network Inf/Srv Virt2012R2/W7yOff2010 MCTS SCCM2012/2007/SCOM2007 MCITP Exchange 2010/2007-MCTS Exch2010/2007-MCTS Lync2010 ITTechnologySite.blogspot.com

    viernes, 23 de enero de 2015 18:15
  •  OK. Si no tiene esa clase... No debería System Center añadirla en el cliente o como funciona este tema??

     Yo edito el .MOF , lo añado en el sitio correspondiente y despues...fuerzo el inventario , el cliente busca

     los datos correspondientes y los transfiere a la Consola de System Center ( Resource Explorer )

     O....

    ¿ Alguien puede explicarme la secuencia en 5 pasos  ??

     Saludos y gracias


    MCITP

    jueves, 29 de enero de 2015 16:10
  • Buen día.

    A tu pregunta: "OK. Si no tiene esa clase... No debería System Center añadirla en el cliente o como funciona este tema??"  la respuesta es NO.

    El hecho que generes una nueva entrada o clase que decidas inventariar, no significa que haya alguna aplicación que llene esa entrada necesariamente.
    No te olvides que el WMI es un repositorio en el que hay aplicaciones que escriben ahí y otras leen (como ConfigMgr).

    Por eso es que dependiendo del SO y arquitectura, el WMI cambia.

    Si la entrada es personalizada, tendrás que llenar la respuesta a mano (por la razón expuesta arriba)

    Saludos,


    Ayuda a la comunidad. Si consideras que la respuesta te fue util, marcala por favor como respuesta final. Marcela Berri Instructor/Consultor Senior IT MCT–MVP Enterprise Client Management MCTS Server Admin/AD2008/Network Inf/Srv Virt2012R2/W7yOff2010 MCTS SCCM2012/2007/SCOM2007 MCITP Exchange 2010/2007-MCTS Exch2010/2007-MCTS Lync2010 ITTechnologySite.blogspot.com

    lunes, 2 de febrero de 2015 14:37
  •  Lo que quiero inventariar concretamente es la Wireless de cada equipo con Win 7 y eso aparece en

     esta clave ya rellenada de por si :

     HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0012

     Si añado esta entrada en : configuration.mof (...\hinv\.... ) del servidor ...debería despues

     System Center añadirla AUTOmaticamente al espacio WMI de cada equipo no?? o en

     que me equivoco??

     Esto lo quiero hacer para 500 equipos

     Saludos y gracias


    MCITP



    • Editado Ralpph lunes, 2 de febrero de 2015 14:49
    lunes, 2 de febrero de 2015 14:47
  • A ver si esto te ayuda.

    how to report only the wireless type

    Además, otra alternativa, ya que sabés la entrada de registry, es buscarlo e informar por "Compliant Settings" (DCM)

    Saludos.


    Ayuda a la comunidad. Si consideras que la respuesta te fue util, marcala por favor como respuesta final. Marcela Berri Instructor/Consultor Senior IT MCT–MVP Enterprise Client Management MCTS Server Admin/AD2008/Network Inf/Srv Virt2012R2/W7yOff2010 MCTS SCCM2012/2007/SCOM2007 MCITP Exchange 2010/2007-MCTS Exch2010/2007-MCTS Lync2010 ITTechnologySite.blogspot.com

    lunes, 2 de febrero de 2015 15:01
  •  Ya revise ese Blog que indicas y añadi las entradas al .MOF pero System Center no añade

     la NUEVA clase al espacio WMI de los clientes Windows 7

     En cuanto a la otra alternativa...como funciona eso que me indicas .... DCM ???

     Gracias


    MCITP

    lunes, 2 de febrero de 2015 15:05
  •  Marcela... Yo no necesito añadir información

     Necesito que System Center agregue la nueva clase al espacio WMI y luego obtenga los valores

     que ya existen en dicha clave del registro

     Como podría hacerlo?? No entiendo porque System Center no agrega la nueva clase en el

     cliente  tras mi edición del  .MOF en el servidor de System Center

     Un saludo

    MCITP


    • Editado Ralpph lunes, 2 de febrero de 2015 15:51
    • Marcado como respuesta Ralpph miércoles, 4 de febrero de 2015 11:37
    lunes, 2 de febrero de 2015 15:51
  • Vamos por partes:

    1) Has podido "importar" la nueva clase en los "DEFAULT client Settings"? NO custom.

    Administration - Client Settings - Default Client Settings - Hardware Inventory -   Default Client Settings - “Set Classes” - Import.

    Digo, ves la nueva clase ahí??

    2) Existe CAS? el import debe ser ahí.

    3) Es necesario dar tiempo a que replique la estructura si es grande

    Saludos.


    Ayuda a la comunidad. Si consideras que la respuesta te fue util, marcala por favor como respuesta final. Marcela Berri Instructor/Consultor Senior IT MCT–MVP Enterprise Client Management MCTS Server Admin/AD2008/Network Inf/Srv Virt2012R2/W7yOff2010 MCTS SCCM2012/2007/SCOM2007 MCITP Exchange 2010/2007-MCTS Exch2010/2007-MCTS Lync2010 ITTechnologySite.blogspot.com

    martes, 3 de febrero de 2015 17:11