none
Workflow en SharePoint Designer 2013 - Crear elemento de lista con una columna de búsqueda múltiple RRS feed

  • Pregunta

  • Hola a tod@s,

    Tengo un SharePoint online de Office 365, donde a través de SharePoint Designer 2013 he creado un flujo de trabajo utilizando como plantilla SharePoint 2013. Hay una acción que es Crear elemento de lista donde indico todas las columnas obligatorias y que coja los valores del Elemento actual.

    El problema viene cuando quiero que la columna Departamentos, que es una columna de búsqueda múltiple (donde muestro los valores de la lista Departamentos). Los valores se rellenan con los valores del elemento actual, pero el flujo de trabajo no termina de funcionar correctamente porque nunca crea el elemento y tampoco muestra si hay error ni nada.

    ¿Alguien me puede aclarar cómo poner el valor de una columna de búsqueda múltiple en el flujo de trabajo para crear un elemento?

    Espero que me podáis ayudar.

    Gracias por todo.

    David


    • Editado David Uru lunes, 12 de enero de 2015 14:08
    lunes, 12 de enero de 2015 14:05

Todas las respuestas

  • Hola, el valor debería tener un formato de este estilo:

    {ITEM ID};#{ITEMVALUE};#{ITEM ID};#{ITEMVALUE}

    Para 2010 no podías tener un ciclo, ahora para 2013 podés tener un loop.

    http://www.wonderlaura.com/Lists/Posts/Post.aspx?ID=224

    Deberías recorrer la columna Departamentos, y guardarlos en un diccionario, y después guardarlos en el formato requerido para la columna {ITEM ID};#{ITEMVALUE};#{ITEM ID};#{ITEMVALUE}

    Saludos.

    Actualización: ejemplo.

    http://www.concurrency.com/blog/setting-multi-value-lookup-column-using-sharepoint-designer-workflow-part-1/

    ------------------------------------------------

    Christian Azcón

    Blog: http://todosharepoint.blogspot.com.ar

    MCTS-MCITP-MCPD-MCSA-MCSE

    • Editado ChristianAzcón martes, 13 de enero de 2015 10:29 Actualizacion
    • Propuesto como respuesta Moderador M martes, 13 de enero de 2015 22:29
    • Marcado como respuesta Moderador M miércoles, 14 de enero de 2015 15:24
    • Desmarcado como respuesta David Uru miércoles, 14 de enero de 2015 16:53
    lunes, 12 de enero de 2015 23:20
  • Hola Christian,

    Antes de nada, agradecerte la respuesta.

    El problema es que yo no consigo que me funcione.

    Por "después guardarlos en el formato requerido para la columna", ¿te refieres a ponerlo como cadena? Es decir, poner en la columna multi (departamentos) los valores componiéndolos como indicas utilizando el ;#.

    te muestro un pantallazo:

    Donde pone 1;#Dpto 1; sería el ID;#Título.

    ¿qué es lo que estoy haciendo mal?

    Gracias de antemano.

    Un saludo.

    David

    

    miércoles, 14 de enero de 2015 9:06