none
Configurar dos tarjetas (VLANs diferentes) en clúster RRS feed

  • Pregunta

  • Hola, me gustaría configurar un clúster Microsoft de pruebas. Tengo dos servidores con dos tarjetas cada uno:

    SERVIDOR-1

    ========

    Publica:

        IP: 10.10.10.100

        Máscara: 255.255.255.0

        Gateway: 10.10.10.1

    Heartbeat:

        IP: 20.20.20.200

        Máscara: 255.255.255.0

        Gateway: No tiene

    SERVIDOR-2

    ========

    Publica:

        IP: 10.10.10.150

        Máscara: 255.255.255.0

        Gateway: 10.10.10.1

    Heartbeat:

        IP: 20.20.20.250

        Máscara: 255.255.255.0

        Gateway: No tiene

    El caso es que si hago ping a la IP  De Heartbeat del otro servidor no contesta (por ejemplo desde el SERVIDOR-1 hago ping a la IP de heartbeat del SERVIDOR-2):

    c:\>Hostname

    SERVIDOR-1

    c:\>ping 20.20.20.250 -t

    Haciendo ping a 20.20.20.250 con 32 bytes de datos:
    Tiempo de espera agotado para esta solicitud.
    Tiempo de espera agotado para esta solicitud.

    Pero en el momento que en el SERVIDOR-2 le configuro el Gateway, el ping empieza a funcionar:

    c:\>ping 20.20.20.250 -t

    Haciendo ping a 20.20.20.250 con 32 bytes de datos:
    Tiempo de espera agotado para esta solicitud.
    Tiempo de espera agotado para esta solicitud.
    Respuesta desde 20.20.20.250: bytes=32 tiempo<1m TTL=128
    Respuesta desde 20.20.20.250: bytes=32 tiempo<1m TTL=128
    Respuesta desde 20.20.20.250: bytes=32 tiempo<1m TTL=128
    Respuesta desde 20.20.20.250: bytes=32 tiempo<1m TTL=128

    No entiendo qué está pasando.

    Gracias y saludos

    miércoles, 13 de septiembre de 2017 17:56

Respuestas

  • Gracias. Lo he estado revisando pero al desconectar y reconectar la red, vuelve a ser pública.

    No obstante he encontrado el problema: La tarjeta privada no tenía su VLAN asignada en el host ESX.

    Gracias

    • Propuesto como respuesta XavierCA viernes, 15 de septiembre de 2017 12:28
    • Marcado como respuesta Moderador M lunes, 18 de septiembre de 2017 21:31
    viernes, 15 de septiembre de 2017 12:28

Todas las respuestas

  • Ese síntoma es típico de cuando reconoce la red como "Pública" ¿lo has revisado? Aunque también puede ser tema del cortafuegos, ya que por omisión salvo en los Controladores de Dominio no está habilitado

    Por otro lado, para crear un "Failover Cluster" además de ambos nodos necesitas un medio de almacenamiento compartido ¿tienes una SAN o NAS?

    La única excepción, y para poder crear un "Failover Cluster" sin almacenamiento compartido es con Windows Server 2016 Enterprise

    Windows Server 2016 – “Storage Spaces Direct” – “Shared Nothing Hyper-V Cluster” (I) | WindowServer
    https://windowserver.wordpress.com/2017/04/04/windows-server-2016-storage-spaces-direct-shared-nothing-hyper-v-cluster-i/

    Windows Server 2016 – “Storage Spaces Direct” – “Shared Nothing Hyper-V Cluster” (II) | WindowServer
    https://windowserver.wordpress.com/2017/04/11/windows-server-2016-storage-spaces-direct-shared-nothing-hyper-v-cluster-ii/ 

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MVP - MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    miércoles, 13 de septiembre de 2017 20:21
    Moderador
  • Gracias Guillermo.

    Ciertamente el disco compartido lo tengo en SAN mediante FC.

    Me decías que "ese síntoma es típico de cuando reconoce la red como Pública". Esto se me escapa, ¿a qué te refieres exactamente?

    Gracias.

    jueves, 14 de septiembre de 2017 5:52
  • En las versiones más o menos actuales de los sistemas operativos el sistema tiene un sistema de detección de redes, que puedes configurar como "Pública" o "Privada", y en caso de Dominio el sistema la configura automáticamente como "Dominio". Entre otras cosas esto determina lo permitido o no por el cortafuegos integrado, y además los servicios que provee a la red

    Cómo Cambiar en Windows de Red Pública a Privada [Actualizado Windows 8/ Windows Server 2012] | WindowServer
    https://windowserver.wordpress.com/2011/10/22/cmo-cambiar-en-windows-de-red-pblica-a-privada/

    Cambiar Perfil de Red Pública a Privada o Privada a Pública (Fácil) | WindowServer
    https://windowserver.wordpress.com/2015/10/15/cambiar-perfil-de-red-pblica-a-privada-o-privada-a-pblica-fcil/

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MVP - MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    jueves, 14 de septiembre de 2017 9:54
    Moderador
  • Gracias. Lo he estado revisando pero al desconectar y reconectar la red, vuelve a ser pública.

    No obstante he encontrado el problema: La tarjeta privada no tenía su VLAN asignada en el host ESX.

    Gracias

    • Propuesto como respuesta XavierCA viernes, 15 de septiembre de 2017 12:28
    • Marcado como respuesta Moderador M lunes, 18 de septiembre de 2017 21:31
    viernes, 15 de septiembre de 2017 12:28