Error Code: 0x80041010 during scripted Office 2010 Activation


  • Hello,

    I am currently trying to configure Office 2010 to do an unattended install on a Windows XP SP3 system. I have it setup to install using OCT and a handful of scripts that perform the activation portion of the Office installation.

    The particular script I am having issues with is the ospp.vbs script with the /act switch applied. The Office 2010 MAK license key is applied via OCT. When the script is run after Office is installed and after I ensure the Office Software Protection Platform is running and then the activation script is run. For whatever reason, it is giving me the following error.

    ERROR CODE: 0x80041010
    Installed product key detected - attempting to
    ERROR DESCRIPTION: An unknown error occurred.

    I have been able to use this exact script on other computers with no issues. Just this one computer is giving me problems. Any help is much appriciated. Let me know if there is any other information needed to help resolve this issue.

    Thank you,

    Tyler Jacobs

    jueves, 29 de julio de 2010 14:28

Todas las respuestas

  • Could you please paste the output of these commands from the computer that is giving you issues?

    cscript ospp.vbs /dstatusall

    cscript ospp.vbs /act

    Ted Way [MSFT], Program Manager, Microsoft Office: Enterprise Licensing, Group Policy, and 64-bit Office
    • Marcado como respuesta Jennifer Zhan viernes, 13 de agosto de 2010 9:54
    • Desmarcado como respuesta Max MengModerator martes, 14 de agosto de 2012 5:14
    miércoles, 04 de agosto de 2010 0:35
  • How is this an accepted answer?? there is no information. I'm getting this same thing.

    When I run the command you asked for I get:

    ERROR CODE: 0x80041010
    ERROR DESCRIPTION: Run the following: cscript ospp.vbs /ddescr:0x80041010
    ERROR CODE: 0x

    When I run those I get a popup:


    Windows Activation prompt, "you can also contact Microsoft by phone to help resolve this problem.
    Code: 0x80041010
    Description: Invalid Class"

    I need to deploy this. not call anyone.

    oh, and I can't run any switch with ospp.vbs. i get the same thing every time I think


    Lawfirm IT guy
    • Editado brooklynotss jueves, 22 de diciembre de 2011 23:04 formatting and clarification
    jueves, 22 de diciembre de 2011 23:01
  • Hi @brooklynotss,

    this error is most likely due to an invalid configuration being present, or an invalid argument/parameter, or incorrect privilege.
    (it's mostly associated with a WMI failure)

    Could you please start your own new thread, describe your scenario/configuration, your method/steps so far, so we can help diagnose with you?

    jueves, 22 de diciembre de 2011 23:55
  • I am having the same ERROR CODE: 0x80041010 and I am using the parameter cscript "c:\Program Files\Microsoft Office\Office14\OSPP.VBS" /sethst:host name here

    it tells me to do 

    ERROR CODE: 0x80041010
    ERROR DESCRIPTION: Run the following: cscript ospp.vbs /ddescr:0x80041010
    ERROR DESCRIPTION: An unknown error occurred.

    I do that and I get error code above 0x80041010 and says to Contact Microsoft by Phone to resolve it.

    if anyone could answer this i would really appreciate it on what I shoud do. The Computer is Windows 8 btw.

    miércoles, 28 de noviembre de 2012 21:55
  • @xtreme23 - are you running this elevated (run as admin)?

    Office activation requires local admin (unlike Windows activation){well, Office2010 did, I guess 2013 does too)

    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    jueves, 29 de noviembre de 2012 8:22