none
Error al importar VM RRS feed

  • Pregunta

  • hola a todos tengo un problema al importar un VM desde Windows 8.1 a un Windows Server 2012 (no es la versión R2). Cuando ejecuto la acción de importar en el server 2012 me arroja el error "the operations failed with code error 32784". He estado investigando el tema y entiendo que para las versiones de Win 8.1 y Win Server 2012 R2 han cambiado al WMI v2, pero no encuentro una solución adecuada a este problema.

    Agradezco cualquier ayuda a este tema.


    Daniel Muñoz


    • Editado Jacobo Muñoz jueves, 5 de junio de 2014 14:35 Redacción
    jueves, 5 de junio de 2014 14:06

Respuestas

  • Hola Daniel,

    Hay algunas diferencias entre ambas versiones de Hyper-V, sin embargo la importación debería funcionar transparentemente.. A menos que hayas creado la VM de Generación 2, recuerda que la Generación 2 solo está soportado por Windows Server 2012R2 y Windows 8.1.

    Si este no es el caso y sigues teniendo problemas con la importación, puedes crear una nueva VM y le atachas el disco existente!

    A ver como te va!

    Saludos,


    Jesús Peñaranda| MCP,MCT,MCTS,MCITP,MCSA,MCSE


    jueves, 5 de junio de 2014 14:45

Todas las respuestas

  • Hola Daniel,

    Hay algunas diferencias entre ambas versiones de Hyper-V, sin embargo la importación debería funcionar transparentemente.. A menos que hayas creado la VM de Generación 2, recuerda que la Generación 2 solo está soportado por Windows Server 2012R2 y Windows 8.1.

    Si este no es el caso y sigues teniendo problemas con la importación, puedes crear una nueva VM y le atachas el disco existente!

    A ver como te va!

    Saludos,


    Jesús Peñaranda| MCP,MCT,MCTS,MCITP,MCSA,MCSE


    jueves, 5 de junio de 2014 14:45
  • Pues en efecto he cometido el error de crear la VM de Generación 2. En este caso cual es la mejor practica o que me recomienda ya que es necesario cambiar el nodo de virtualización sobre el que correo esta VM.

    Muchas gracias.


    Daniel Muñoz

    jueves, 5 de junio de 2014 15:01
  • Hola Daniel,

    Pues lamentablemente el problema radica en los distintos tipos de arranque BIOS y UEFI, hay quienes han publicado alguna información de apoyo para este tipo de situaciones, sin embargo es muy complejo y no asegura nada, igual te dejo el enlace al final.

    Dos cosas que podrías probar (de ser posible) es :

    1. Hacerle un SYSPREP a la VM antes de intentar agregar el VHD a una VM de Generación 1, si tienes la posibilidad de hacerle esto a tus VMs sería una opción interesante.

    2. Hacerle una imagen a la VM (con el ImageX por ejemplo) y luego restaurar esa imagen en una VM de Generación 1 (previo SYSPREP por supuesto)

    Te dejo el enlace:

    http://blogs.technet.com/b/jhoward/archive/2013/11/14/hyper-v-generation-2-virtual-machines-part-10.aspx

    Espero tengas un buen resultado!

    Saludos,


    Jesús Peñaranda| MCP,MCT,MCTS,MCITP,MCSA,MCSE


    jueves, 5 de junio de 2014 15:15