locked
Se pierde o daña el certificado digital del banco sin saber motivo. RRS feed

  • Pregunta

  • Hola, queria consultarles sobre un problema que tiene un cliente mio con los certificados de bancos. El tiene Windows 7 e internet explorer 8. Van 3 veces que al querer hacer transferencias de banco santander rio y galicia desde su pc, le da error, diciendo que no encuentra el certificado digital del banco o que el mismo está dañado. Pense en el ccleaner que le corro al hacer mantenimiento, pero consultando al banco santander rio, indicaron que puede ser las actualizaciones y que quedaba a criterio del cliente si las bajaba o no ... Cosa que no es lógico ni fue lo que recomende a mi cliente. Me paso lo mismo en otro cliente pero que tiene windows XP y banco galicia. Cada tanto pierde el certificado digital. Por lo que creo que esto vas mas alla del sistema operativo, tal vez alguna actualización de IE, estoy averiguando. Alguien sabe algo al respecto? He buscado información en ambos bancos pero no hay nada al respecto. Desde ya muchisimas gracias. Fabian
    viernes, 6 de julio de 2012 16:46

Respuestas

  • ... Pense en el ccleaner que le corro al hacer mantenimiento, ...

    El Ccleaner, solo por arrancarlo y sin necesidad de autorizar nada, elimina las claves de registro que contienen un cero binario embebido y que tipicamente son descriptores de seguridad.

    Es decir es el candidato.

    Este es un error de todas las herramientas que "dicen" que limpian el registro: lo abren usando el API Win32 el cual no es capaz de tratar estas claves y debe usarse el antiguo y clasico API NT. (la eliminacion de dichas claves no es consciente el CCleaner, sino que lo hace indirectamente por uso de un API indebido).

    Ningun profesional te acosnejará esta herramienta, ni similares, debido que los sistemas cada vez tienen mas descriptores de seguridad.

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com


    viernes, 6 de julio de 2012 17:04

Todas las respuestas

  • ... Pense en el ccleaner que le corro al hacer mantenimiento, ...

    El Ccleaner, solo por arrancarlo y sin necesidad de autorizar nada, elimina las claves de registro que contienen un cero binario embebido y que tipicamente son descriptores de seguridad.

    Es decir es el candidato.

    Este es un error de todas las herramientas que "dicen" que limpian el registro: lo abren usando el API Win32 el cual no es capaz de tratar estas claves y debe usarse el antiguo y clasico API NT. (la eliminacion de dichas claves no es consciente el CCleaner, sino que lo hace indirectamente por uso de un API indebido).

    Ningun profesional te acosnejará esta herramienta, ni similares, debido que los sistemas cada vez tienen mas descriptores de seguridad.

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com


    viernes, 6 de julio de 2012 17:04
  • Hola Jose, muchas gracias por tu respuesta.

    En cuanto a ccleaner, ¿solo por arrancarlo borra los descriptores? Pues es pràctico, limpia temporales etc, pero entonces por lo que me decis, lo puedo correr destildando alguna opcion para que no me borre los descriptores de seguridad que mencionas? O deberé hacerlo a mano desde el Inernet explorer?

    En cuanto al certificado, el tema es que en el momento en el que le paso al cliente, no se habia realizado mantenimiento desde su ultima transferencia, es decir, "en esa osasion puntual", por lo que solo queda por pensar entonces en la actulizacion de w7?. Gracias!

    lunes, 9 de julio de 2012 14:55
  • Hola Jose, muchas gracias por tu respuesta.

    En cuanto a ccleaner, ¿solo por arrancarlo borra los descriptores? Pues es pràctico, limpia temporales etc, pero entonces por lo que me decis, lo puedo correr destildando alguna opcion para que no me borre los descriptores de seguridad que mencionas? O deberé hacerlo a mano desde el Inernet explorer?

    En cuanto al certificado, el tema es que en el momento en el que le paso al cliente, no se habia realizado mantenimiento desde su ultima transferencia, es decir, "en esa osasion puntual", por lo que solo queda por pensar entonces en la actulizacion de w7?. Gracias!

    Si se borran los descriptores de seguridad, despídete de un buen funcionamiento de tu maquina, y sobre todo despídete de la seguridad.


    Jose Manuel Tella Llop news://jmtella.com


    lunes, 9 de julio de 2012 15:22
  • Gracias Jose, sigue el problema, el cliente restaura los certificados y en un cierto tiempo deja de poder realizar transferencias. Ya no se usa el ccleaner... pero sucede lo mismo..., hay algo que se instala que daña el certificado digital. Que puede ser?, la actualizacion de windows como dice la gente del banco?  Gracias!

    lunes, 16 de julio de 2012 20:11
  • Gracias Jose, sigue el problema, el cliente restaura los certificados y en un cierto tiempo deja de poder realizar transferencias. Ya no se usa el ccleaner... pero sucede lo mismo..., hay algo que se instala que daña el certificado digital. Que puede ser?, la actualizacion de windows como dice la gente del banco?  Gracias!


    ¿usa java la aplicacion de ese banco?

    Jose Manuel Tella Llop news://jmtella.com

    lunes, 16 de julio de 2012 20:14
  • Hola, queria consultarles sobre un problema que tiene un cliente mio con los certificados de bancos. El tiene Windows 7 e internet explorer 8. Van 3 veces que al querer hacer transferencias de banco santander rio y galicia desde su pc, le da error, diciendo que no encuentra el certificado digital del banco o que el mismo está dañado. Pense en el ccleaner que le corro al hacer mantenimiento, pero consultando al banco santander rio, indicaron que puede ser las actualizaciones y que quedaba a criterio del cliente si las bajaba o no ... Cosa que no es lógico ni fue lo que recomende a mi cliente. Me paso lo mismo en otro cliente pero que tiene windows XP y banco galicia. Cada tanto pierde el certificado digital. Por lo que creo que esto vas mas alla del sistema operativo, tal vez alguna actualización de IE, estoy averiguando. Alguien sabe algo al respecto? He buscado información en ambos bancos pero no hay nada al respecto. Desde ya muchisimas gracias. Fabian

    Hola Kebon:

    Tiene toda la pinta de que esa instalación de Windows sufrió algún problema, probablemente se deba a un software que está causando malfuncionamientos en el sistema, algo que el cliente no instaló a sabiendas de que le causaría un problema pero se lo está provocando.

    Lo ideal sería que se crease un nuevo usuario y probase si sigue sufriendo el mismo problema con los certificados y a raíz de ahí seguimos analizando. Crear un nuevo usuario es muy sencillo, Kebon, solo debe dirigirse a Inicio == Panel control == Cuentas de usuario y protección infantil == Cuentas de usuario.

    Espero que esto le pueda ayudar y si necesita más ayuda no dude en solicitarla.

    David Segura.

    Ing. en electrónica

    lunes, 16 de julio de 2012 22:31