none
Problemas post instalacion del Sharepoint Services 3.0 RRS feed

  • Pregunta

  • Tengo instalado el Sharepoint Services 2.0, trate de instalar la version 3 y me pidio que instalara lo siguiente: Net Framework 2.0, windows Workflow Foundation 3.0 que forma parte del Framework 3.0, ASP Net v2.0 el cual debe estar configurado en permitir en la lista de extensiones del servidor web del IIS y por ultimo actualizar el Sharepoint 2.0 con el SP2...  bueno instale el framework 3.0, el asp net 2.0 y actualice con el sp2 de sharepoint 2.0... ok despues de esto se pudo instalar la nueva version del sharepoint 3.0... pero el problema esta ahora al ejecutarse el Asistente para configuracion de productos y tecnologias de sharepoint se detiene y manda el siguiente mensaje: Error de Configuracion.  Al parecer es al momento de "Configurar la aplicacion Web de Administracion Central de Sharepoint"

    Total que no puedo ejecutar la nueva version porque primero debe terminar el asistente de configuracion, pero aun funciona la version anterior la 2.0... espero que alguien me pueda ayudar, de antemano se los agradezco... saludos

    martes, 16 de enero de 2007 22:53

Respuestas

  • Ya resolvi el problema, la solucion fue antes de ejecutar el asistente de actualizacion de productos y tecnologias de sharepoint hay que correr el prescanl desde msdos en la siguiente ruta /program files/common files/microsoft shared/web server extensions/12/bin>prescan.exe /all

    Despues de ejecutarse este proceso te genera un archivo de resultados de la prueba, si no te marca algun error, listo ya puedes utilizar la nueva version de Sharedpoint v3...  espero esto les ayude, ya que yo estaba por tirar la toalla.

    Saludos de tu amigo Mayuma

    jueves, 25 de enero de 2007 20:31

Todas las respuestas

  • Hola Mayuma

    Veras, nunca he actualizado ya que prefiero instalar de 0.

    Mi recomendación es que hagas un backup de tu sitio, montes una maquina virtual con sharepoint 2007 y migres tu sitio en ella para ver si todo va bien.

    Si prefieres seguir intentandolo, mira el log de la instalación que seguro que te da alguna pista.

    Un saludo.

     

    *******************************************************************************************************************

    Colabora con el foro: Si la respuesta te es de utilidad marca la pregunta como respondida.

    *******************************************************************************************************************

    Daniel Matey.

    MVP

    MCSE, MCSA, MCSD, MCDBA.

    Blog: http://geeks.ms/blogs/dmatey

     

    miércoles, 17 de enero de 2007 6:22
  • Mira, soy principiante en esto, no entiendo muy bien eso de la maquina virtual del sharepoint 2007, el 2007 lo puedo bajar gratis de internet? creo que es de prueba verdad?... por otra parte te detallo mas lo que hago, gracias por tu tiempo... y pues si de plano no encuentro la solucion tendre que hacer lo que dices, primero creo tendre que eliminar el sharepoint 2.0 y el 3.0 para despues instalar el 2007, Saludos

    La primer pantalla muestra lo siguiente:

    Este asistente actualizara Productos y Tecnologias de Sharepoint... al darle siguiente aparece una ventana con lo siguiente:

    Puede que tengan que reiniciarse o restablecerse los siguientes servicios... IIS, Servicio de Admon de Sharepoint y Servicio de Temporizador de Sharepoint... elija si para reiniciar los servicios, si fuera necesario, y continuar con el asistente...

    Le doy la opcion Si y aparece otra ventana:

    Si tiene una biblioteca de plantillas de WSS, descargue e instale ahora el nuevo paquete de idiomas de WSS...

    Le doy aceptar y enseguida muestra la pantalla de configurar la aplicacion Web donde se especifica:

    El numero de puerto:44205 y tambien el Proveedor de autenticacion el cual selecciono NTLM... presiono siguiente y aparece la ventana con lo siguiente:

    Finalizando el asistente para configuracion... Se aplciaran los siguientes parametros de configuracion:

    -Servidor de Base de datos de configuracion: dgpya

    -Nombre de la base de datos de configuracion:dgpya

    -Alojar la aplicacion Web de la Admon Central:Si

      *Direccion URL de la Admon Central: http://dgpya:44205/

      *Proveedor de Autentificacion:NTLM

    Al darle siguiente empieza a hacer 10 tareas pero apenas va en la primera o segunda tarea me aparece lo siguiente:

    Error en una o mas configuraciones. No pueden deshacerse los parametros configurados. Resuleva el problema y vuelva a ejecutar el asistente. A continuacion se detalla la informacion sobre el error:

    Error al inicializar la actualizacion de productos y tecnologias de sharepoint.

    Se inicio una excepcion de tipo Microsoft.Sharepoint.PostSetupConfigurationTaskException. Informacion adicional de la excepcion: Aun no se ha ejecutado correctamente la herramienta de deteccion previa a la actualizacion en las bases de datos de contenido del conjunto de los servidores. Debe completarse sin errores para continuar con el proceso de actualizacion.

    Para diagnosticar el problema, revise el registro de eventos de la aplicacion y el archivo de registro de configuracion ubciados en: C:/ruta/archivo.log

    Pues aqui esta el registro, es muy extenso solo puse el ultimo bloque de lineas donde creo aparece el error:

    Entering function Common.RunCommand 01/17/2007 12:00:21 6 INF Starting process C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\bin\prescan.exe and waiting 600000 for it to stop 01/17/2007 12:00:21 6 INF Entering function SimpleStreamReader.SimpleStreamReader 01/17/2007 12:00:21 6 INF Leaving function SimpleStreamReader.SimpleStreamReader 01/17/2007 12:00:21 6 INF Entering function SimpleStreamReader.SimpleStreamReader 01/17/2007 12:00:21 6 INF Leaving function SimpleStreamReader.SimpleStreamReader 01/17/2007 12:00:21 7 INF Entering function SimpleStreamReader.Read 01/17/2007 12:00:21 8 INF Entering function SimpleStreamReader.Read 01/17/2007 12:00:27 7 INF Read from stream: 1 01/17/2007 12:00:27 8 INF No additional data read from the stream 01/17/2007 12:00:27 7 INF Leaving function SimpleStreamReader.Read 01/17/2007 12:00:27 8 INF Leaving function SimpleStreamReader.Read 01/17/2007 12:00:27 6 ERR The process C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\bin\prescan.exe exited with return code 1 01/17/2007 12:00:27 6 INF Leaving function Common.RunCommand 01/17/2007 12:00:27 6 ERR Detected that the prescan.exe has not been run yet. 01/17/2007 12:00:27 6 INF Entering function StringResourceManager.GetResourceString 01/17/2007 12:00:27 6 INF Resource id to be retrieved is PreUpgradeScanErrorMessage for language Spanish (Spain) 01/17/2007 12:00:27 6 INF Resource retrieved id PreUpgradeScanErrorMessage is Aún no se ha ejecutado correctamente la herramienta de detección previa a la actualización en las bases de datos de contenido del conjunto de los servidores. Debe completarse sin errores para continuar con el proceso de actualización. 01/17/2007 12:00:27 6 INF Leaving function StringResourceManager.GetResourceString 01/17/2007 12:00:27 6 INF Entering function Common.BuildExceptionMessage 01/17/2007 12:00:27 6 INF Entering function StringResourceManager.GetResourceString 01/17/2007 12:00:27 6 INF Resource id to be retrieved is ExceptionInfo for language Spanish (Spain) 01/17/2007 12:00:27 6 INF Resource retrieved id ExceptionInfo is Se inició una excepción de tipo {0}. Información adicional de la excepción: {1} 01/17/2007 12:00:27 6 INF Leaving function StringResourceManager.GetResourceString 01/17/2007 12:00:27 6 INF Leaving function Common.BuildExceptionMessage 01/17/2007 12:00:27 6 ERR Task initialize has failed with a PostSetupConfigurationTaskException Se inició una excepción de tipo Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException. Información adicional de la excepción: Aún no se ha ejecutado correctamente la herramienta de detección previa a la actualización en las bases de datos de contenido del conjunto de los servidores. Debe completarse sin errores para continuar con el proceso de actualización. 01/17/2007 12:00:27 6 INF Entering function Common.BuildExceptionInformation 01/17/2007 12:00:27 6 INF Entering function Common.BuildExceptionMessage 01/17/2007 12:00:27 6 INF Entering function StringResourceManager.GetResourceString 01/17/2007 12:00:27 6 INF Resource id to be retrieved is ExceptionInfo for language Spanish (Spain) 01/17/2007 12:00:27 6 INF Resource retrieved id ExceptionInfo is Se inició una excepción de tipo {0}. Información adicional de la excepción: {1} 01/17/2007 12:00:27 6 INF Leaving function StringResourceManager.GetResourceString 01/17/2007 12:00:27 6 INF Leaving function Common.BuildExceptionMessage 01/17/2007 12:00:27 6 INF Leaving function Common.BuildExceptionInformation 01/17/2007 12:00:27 6 ERR Se inició una excepción de tipo Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException. Información adicional de la excepción: Aún no se ha ejecutado correctamente la herramienta de detección previa a la actualización en las bases de datos de contenido del conjunto de los servidores. Debe completarse sin errores para continuar con el proceso de actualización. Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException: Se produjo una excepción de tipo 'Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException'. en Microsoft.SharePoint.PostSetupConfiguration.InitializeTask.PrepareForUpgrade() en Microsoft.SharePoint.PostSetupConfiguration.InitializeTask.Run() en Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask() 01/17/2007 12:00:27 6 INF Entering function Common.BuildExceptionInformation 01/17/2007 12:00:27 6 INF Entering function Common.BuildExceptionMessage 01/17/2007 12:00:27 6 INF Entering function StringResourceManager.GetResourceString 01/17/2007 12:00:27 6 INF Resource id to be retrieved is ExceptionInfo for language Spanish (Spain) 01/17/2007 12:00:27 6 INF Resource retrieved id ExceptionInfo is Se inició una excepción de tipo {0}. Información adicional de la excepción: {1} 01/17/2007 12:00:27 6 INF Leaving function StringResourceManager.GetResourceString 01/17/2007 12:00:27 6 INF Leaving function Common.BuildExceptionMessage 01/17/2007 12:00:27 6 INF Leaving function Common.BuildExceptionInformation 01/17/2007 12:00:27 6 INF Entering function TaskBase.OnTaskStop 01/17/2007 12:00:27 6 INF Creating the OnTaskStop event for task initialize 01/17/2007 12:00:27 6 ERR Task initialize has failed 01/17/2007 12:00:27 6 INF friendlyMessage for task initialize is Se inició una excepción de tipo Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException. Información adicional de la excepción: Aún no se ha ejecutado correctamente la herramienta de detección previa a la actualización en las bases de datos de contenido del conjunto de los servidores. Debe completarse sin errores para continuar con el proceso de actualizacion.

    miércoles, 17 de enero de 2007 18:25
  • Ya resolvi el problema, la solucion fue antes de ejecutar el asistente de actualizacion de productos y tecnologias de sharepoint hay que correr el prescanl desde msdos en la siguiente ruta /program files/common files/microsoft shared/web server extensions/12/bin>prescan.exe /all

    Despues de ejecutarse este proceso te genera un archivo de resultados de la prueba, si no te marca algun error, listo ya puedes utilizar la nueva version de Sharedpoint v3...  espero esto les ayude, ya que yo estaba por tirar la toalla.

    Saludos de tu amigo Mayuma

    jueves, 25 de enero de 2007 20:31
  •  Mayuma Escribió:

    Ya resolvi el problema, la solucion fue antes de ejecutar el asistente de actualizacion de productos y tecnologias de sharepoint hay que correr el prescanl desde msdos en la siguiente ruta /program files/common files/microsoft shared/web server extensions/12/bin>prescan.exe /all

    Despues de ejecutarse este proceso te genera un archivo de resultados de la prueba, si no te marca algun error, listo ya puedes utilizar la nueva version de Sharedpoint v3...  espero esto les ayude, ya que yo estaba por tirar la toalla.

    Pues a mi me pasa lo mismo; pero una vez hecho el prescan.exe /all no se que más tengo que hacer... ¿podéis ayudarme? ¿Es decir, cómo puedo utilizar la v3?

    Gracias.

     

     

    lunes, 12 de febrero de 2007 20:49
  • Solamente ejecute eso y despues volvie a correr el asistente el cual por fin pudo terminar todas las tareas... resulta que ya pude entrar a Administracion Central de SharePoint v 3 pero ahora me aparece lo siguiente:

    La implementación de Productos y Tecnologías de SharePoint aún no se ha completado.

    Para crear sitios, debe configurar los servidores y los servicios del conjunto de servidores. Esta lista de tareas de administrador proporciona tareas por orden de prioridad para ayudarle a realizar una implementación satisfactoria.

    Para obtener más información sobre cómo configurar el conjunto de servidores, consulte el sistema de Ayuda o la Guía de implementación.

    Si ya ha terminado esta tarea, puede eliminar este elemento haciendo clic en Eliminar elemento en la parte superior de esta página.

    Elimine el elemento de las tareas administrativas cuando haya completado la configuración.
     
    Trato de abrir el enlace al tutorial que viene pero no me deja, no tiene activa la ayuda y me muestra este mensaje:
     
    No se puede mostrar la ayuda.

    Detalles técnicos: no se encontró HC. (MS.WSS.ADMIN.manifest , 3082)
     
     
    lunes, 12 de febrero de 2007 21:01
  • Muchas gracias! A mi también me funcionó hacer el Scan antes de hacer el upgrade. El Scan del Administración Central no consigue acabar y para el resto de la migración.
    lunes, 19 de febrero de 2007 14:37
  •  Germanico Escribió:
    Muchas gracias! A mi también me funcionó hacer el Scan antes de hacer el upgrade. El Scan del Administración Central no consigue acabar y para el resto de la migración.

    Siguiendo con mi problema... entonces debo desinstalar antes y hacer primero el prescan... Es que a mi ni me deja desinstalar el Sharepoint 2007. (Tengo un SBS 2003 por si sirve de algo saberlo).

    Gracias.

     

    domingo, 25 de febrero de 2007 19:00
  • Yo segui con problemas, luego de que se instalo "bien" empece a ver ciertos efectos raros.. por ejemplo al tratar de desplegar las opciones de algunas listas desplegables me las mostraba muy rapido y se volvian a cerrar...p.ej. en Acciones del sitio me mostraba muy rapido las opciones y se volvia a cerrar, por otra parte, varios servicios no se iniciaban como el caso del servidor de busquedas estaba detenido y al darle iniciar no se iniciaba... despues detuve la aplicacion web y ya no me dejo entrar al sitio... trate de iniciar nuevamente la aplicacion y me mandaba una pagina de error... antes de todo esto hice un respaldo de las bases de datos... total que al final tuve que eliminar todo, desinstalar el sharepoint ver 2... despues la version 3... y entre al sql y trate de eliminar desde ahi todo lo referente a las bases de datos de contenido... total que despues de tanto volvi a instalar solo la version 3 y al parecer ya funciono mejor... todas el proceso fue bien, entre a la adminstracion central de sharepoint y todo perfecto...ya todos los servicios estan iniciados... lo que si que tengo en ceros todo lo referente a la informacion... voy a tratar de recuperar el respaldo que realice o igual vuelvo a empezar de ceros, ya que prefiero asi a tener que volver a tener problemas... abro el sitio y me aparece bien, solo tengo ese problema que no me muestra las opciones de los menus desplegables... pero si abro la aplicacion con el Mozilla Firefox ahi no tengo ese problema... bonita cosa, jajaj... bueno espero esto le sirva a alguien y ojala me puedan ayudar para poder corregir ese problemita que hay todavia con las listas desplegables, gracias y un saludo a todos los que pasen por aqui... hasta luego 
    viernes, 16 de marzo de 2007 17:58
  • Hola a todos

     

    Estoy aprendiendo apenitas, la duda que tengo es la siguiente, a la hora de entrar al administrador central sharepoint no he conseguido entrar en èl ya que me sale un mensaje diciendo que he movido la pagina o la he eliminado, y la verdad no he hecho ningun cambio, pero podrian ayudarme a recuperlarlo, a repararlo, por favor ayuda es urgente..., ah no puedo volverla a montar tengo demasiada informacion y no he podido sacar los backups por este problema

     

    pamela (medellin - colombia) "AYUDITA POR FAVOR"

     

     

    martes, 10 de abril de 2007 14:56
  •  Tengo un problema... con sharepoint ver 2 batalle para ubicar las bases de datos de contenido en una particion especifica, instale en C y la base de contenido la ubique en E lo logre instalando el sql en la unidad E... pero ahora que instale la version 3 no me di cuenta que nuevamente me paso las bases de datos a la unidad C al parecer la version 3 instala el sql 2005... hasta ahora me doy cuenta donde estaba la base de datos porque ya me quede sin espacio en la unidad C... como es un servidor de almacenamiento todo el espacio lo tengo en la unidad E... ahora no se como mover la base de datos o si tendre que volver a instalar todo el asunto... espero que alguien tenga solucion a esto... por otra parte hice una prueba subiendo una imagen algo pesada para ver si el contenido estaba en C y pues si aumento el archivo de contenido, despues elimine la imagen del sitio y veo que la base de contenido no bajo, se quedo igual... creo que existe alguna forma de depurar la base de datos y que muestre el contenido real... ojala tambien me ayuden en este problema, gracias

     

    Total que no puedo tener funcionando bien el sharepoint... tendre que contar hasta 1000... saludos y gracias por leer esto... y si me ayudan mil gracias mas... hasta pronto

    martes, 17 de abril de 2007 16:17
  •  

    Buenas tardes, mi problema es que necesito pautas para trabajar con sharepoint services 3.0, ya que mi tema de tesis trata sobre un sistema administrativo en el que realizo toda una gestión documental, seguimientos de los documentos, plantillas de la misma formularios con office 2007, y deseo que me ayuden a integrar los documentos de mi facultad en sharepoint services y workflows como lo hago, si alguien puede asesorarme se lo agradeceria.
    lunes, 30 de julio de 2007 19:13
  •  

    hola foro ... soy nuevo enesto y me gustaria ver un documento completo en el cual se detalle paso a paso la instalacion de sharepoint services v 3.0..... y el poder validar si la instalacion  fue un exito.......... agradezco sui atencion y espero no molestarlos mucho..

     

    saludos

    jueves, 30 de agosto de 2007 15:04
  • Hola Ignacio estoy en tu misma situacion y no consigo ningun manual te importaria mandarme si consigues algun manual.

    mail. h.gh1975@hotmail.com

     

    Gracias y un salduo

     

    jueves, 27 de septiembre de 2007 15:25
  • Les envío un link paso a paso de como instalar la version 3.0 en un Small Business Server 2003. Espero les sirva.

    http://technet2.microsoft.com/WindowsServerSolutions/SBS/en/library/07fe109b-1421-4052-acc2-d2898afc0d951033.mspx?mfr=true

    jueves, 22 de mayo de 2008 15:46
  • Hola.

     

    Lo del prescan.exe es para WSS 2.

     

    Para solucionar el problema del HC en WSS 3 hay que seguir los siguientes pasos;

     

    En una ventanilla de CMD, cambia a la ruta:

     

    \archivos de programa\archivos comunes\microsoft shared\web server extensions\12\bin

     

    desde esta carpeta se ejecuta:

     

    hcinstal.exe /act InstallAllHCs

     

    Termina con un codigó de resultado 4, pero ya funcionara el vinculo de "lea el tutorial" en tareas de administrador.

     

    Para mas información: KB939313

     

    Saludos

    Un Ingles (disculpa mi español Stick out tongue)

     

    martes, 27 de enero de 2009 13:32
  • Ok, eso funciona perfecto, ya puedo leer el tutorial. Gracias!!!
    domingo, 1 de agosto de 2010 5:26