none
Dominio Active Directory DHCP RRS feed

  • Pregunta


  • Hola, soy nuevo aquí en el foro, así que espero no estar retomando algún tema ya visto.

       He instalado un windows 2003 server basándome en una guía de microsoft configuré un dominio, el active directory, así también como el dhcp.

       Mi problema es el siguiente, actualmente tengo mi conexión de DSL y el cable del modem va a el puerto de un router 3com wireless, tengo el servidor con 2003 conectado a uno de los puertos LAN y a su vez tengo un aproximado de 10 equipos que se conectan al router de forma inalámbrica. De un puerto del router  se conecta un cable que va directo a un switch 3com para otros equipos que se conectan por LAN y no por inalámbrico.

     Entoces en los puertos del 3com está la conexión al DSL, el servidor con 2k3 y el servidor con linux y el cable que hace el puete para el switch 3com.

     La configuración de router 3com es con ip´s estáticas. Así que cada equipo de mi red tiene asignada su propia IP. Ahora bien, que tengo que hacer para que los equipos por cable e inalámbricos se firmen en el dominio.

       1.- Puede haber algún conflicto con el dominio, active directory y DHCP del servidor Windows 2k3 y el router 3com.
       2.- Con esta configuración sería necesario que el servidor Windows 2k3 tenga una segunda interface de Red.
       3.- Hay alguna otra opción para configurar el controlador de domino de manera que yo pueda asignar las ips de los equipos sin el DHCP y aún así tener las funcionalidades del Active Directory para establecer políticas en los equipos.
       4.- Con esta configuración podría filtrar las conexiones de los equipos a traves del Windows 2k3 Server.


      Son algunas incógnitas que tengo. Quizá parezca que estoy muy perdido pero realmente no he trabajado con el active directory, con el DCHP ni con el controlador de dominio.

      Saludos
    viernes, 14 de diciembre de 2007 1:06

Respuestas

  • Cuando uno instala el Active Directory por defecto se instala el Servicio DNS, va integrado. Ahora si me dices que luego de que cambiaste el DNS en los clientes no salen, es problema de reenvío de consultas DNS a un servidor DNS de Internet. Lo que debes configurar es un reenvío de consultas DNS.

    Esto solucionará tu problema:

    http://www.petri.co.il/configure_dns_forwarding.htm

     

    Si esto te ayudo marca la respuesta como Correcta,

    Saludos,

     

    martes, 18 de diciembre de 2007 4:30

Todas las respuestas

  • Hola, respondo a tus preguntas:

    1. Mientras las PCs, servidores y routers tengan diferentes IPs y diferentes nombres no existirá conflicot.

    2. El servidor Windows 2003 que es DC, aloja el Active Directory puede trabajar solo con una NIC, a través de esta NIC se comunicará con los clientes.

    3. La mejor forma es instalar el servicio DHCP y autorizarlo en el Active Directory. SObre un DC puedes correr servicios como DNS, DHCP sin problemas. SI deseas políticas, une las computadoras al dominio y empieza a trabajar en GPOs y su despliegue para las estaciones y usuarios.

    4. No me queda claro, quieres que el servidor sea un enrutador?

     

    JC

    viernes, 14 de diciembre de 2007 3:25

  • Gracias por tus respuestas. En cuanto a lo que me preguntas, lo que quiero hacer es por ejemplo firmar los clientes al dominio y que puedan seguir conectados a internet.

    ¿Como hago para conectar los equipos inalámbricos al dominio? y que puedan seguir teniendo su conexión a internet. Aquí es donde tengo algo de confusión. Que otra cosa tendría que configurar en el dominio o el dhcp para que al firmarse los equipos en el dominio, tengan aún así la posibilidad de conectarse a internet. Supongo que bajo ese esquema entonces los clientes conectarían a travez del Windows 2003 server para tener acceso a internet y pertenecer al dominio.

    Si es así o estoy algo confundido.
    viernes, 14 de diciembre de 2007 17:22
  • Tienes que configurar en los clientes inalámbricos una IP, Máscara y DNS (la IP del Controlador de dominio Windows 2003), puerta de enlace (IP del router). Luego unes las computadoras al dominio: http://support.microsoft.com/kb/295017/es. Finalmente configuras el reenvío de consultas hacia un DNS de internet, esto se debe realizar desde la consola DNS.

    Yo te recomiendo que tráfico de Internet siga saliendo por tu router.

    Saludos,

    viernes, 14 de diciembre de 2007 18:15
  • Te comento que inicié el DCHP, a una laptop con conexión inalámbrica le puse que obtuviera una ip de forma dinámica y en puerta de enlace le especifiqué la dirección ip del servidor DHCP. Pude agregar la máquina al dominio de forma satisfactoria. También lo probé con una pc de escritorio y funcionó.

     

    En el servidor con Windows2k3, le asigné una ip tal cual decía un manual de microsoft para hacer pruebas:

     

       ip 10.0.0.2

       mascara: 255.0.0.254

    Puerta de Enlace: ip del router que reparte la conexión de internet.

     

    Cuando abro el internet explorer no veo ninguna página de internet. Me marca un error de que la página no es correcta. Mi pregunta ahora en este punto es la siguiente:

     

       ¿Si al poner la puerta de enlace en el servidor me marca que está en un segmento distinto de red, es posible que por esto no conecte a internet?, ¿Dada la configuración de red del servidor windows 2k3 que dirección de puerta de enlace serìa la màs adecuada?

     

        Por lo mismo supongo que aunque la laptop se conecta o al menos indica que tiene conexión con la antena inalámbrica, no se puede navegar en internet.

     

        Ahora bien del Dominio, pasa algo curioso, cuando reinicié la laptop para que se hicieran los cambios y configuraciones del dominio. Me permite seleccionar el dominio de la lista para ingresar con una cuenta del dominio a la laptop. Pero despuès de un rato que intenta conectar me marca un error en donde especifica que el dominio no está disponible y no se puede conectar. Y efectivamente en el windows2k3 cuando consulto en dhsp las ips asignadas puedo ver claramente la laptop pero si me voy a las opciones de active directory para administrar ese equipo, me marca que no està conectada al dominio y pues no es posible administrar el equipo. Según yo todo está iniciado, ¿Existe alguna aplicación de las que hay en herramientas administrativas que permitan iniciar o dentener el dominio?

     

        La configuración del router y puertos LAN y WAN siguen siendo los mismos que al principio de este tema.

     

       De antemano gracias por tus respuestas me han sido muy ùtiles para avanzar.

    lunes, 17 de diciembre de 2007 7:50
  •  Jorge Córdova Escribió:

    Tienes que configurar en los clientes inalámbricos una IP, Máscara y DNS (la IP del Controlador de dominio Windows 2003), puerta de enlace (IP del router). Luego unes las computadoras al dominio: http://support.microsoft.com/kb/295017/es. Finalmente configuras el reenvío de consultas hacia un DNS de internet, esto se debe realizar desde la consola DNS.

    Yo te recomiendo que tráfico de Internet siga saliendo por tu router.

    Saludos,

     

    Hola de nuevo. Creo que caí en una confusión. Con lo que me posteaste para la configuración de los clientes todo bien. De hecho ya pude conectar un cliente al dominio e iniciar sesión como un usuario de dominio en la computadora portatil con la tarjeta inalámbrica. Lo que si no he logrado es que se conecten a internet con la ip del router que tiene la conexión del ADSL puesto como default gateway. Te pongo aquí las configuraciones de prueba que estoy utilizando:

     

    Datos Servidor Windows 2003 Server:

    IP: 10.0.0.2

    Mascara: 255.0.0.0

    Gateway: 192.168.2.1 (ip router)

    DNS:10.0.0.2

     

    Datos Cliente Windows XP

    IP: dinámica

    Gateway: 192.168.2.1 (ip router)

    DNS: 10.0.0.2

     

    Con esta configuración puedo firmarme dentro del dominio e iniciar sesión desde el equipo portatil con un usuario del dominio sin problemas; pero lo que no se puede es lograr que conecten a internet tanto el equipo portatil como el de escritorio.

     

    Lo que si no tengo configurado y creo que puede ser el problema es la parte donde dices "Finalmente configuras el reenvío de consultas hacia un DNS de internet, esto se debe realizar desde la consola DNS", eso del reenvío de consultas hacia un DNS creo que no lo tengo configurado. Solamente configuré el windows 2003 como un controlador de dominio y la guía solamente indicaba como crear un dominio, configurar el DHCP y el ACtive Directory.

     

    ¿cómo vez la configuración?

     

    lunes, 17 de diciembre de 2007 21:29
  • Cuando uno instala el Active Directory por defecto se instala el Servicio DNS, va integrado. Ahora si me dices que luego de que cambiaste el DNS en los clientes no salen, es problema de reenvío de consultas DNS a un servidor DNS de Internet. Lo que debes configurar es un reenvío de consultas DNS.

    Esto solucionará tu problema:

    http://www.petri.co.il/configure_dns_forwarding.htm

     

    Si esto te ayudo marca la respuesta como Correcta,

    Saludos,

     

    martes, 18 de diciembre de 2007 4:30
  • Resulta que cuando configuré el servidor como controlador de dominio, y el dhcp al parecer no instaló nada del DNS. Por este motivo cuando entraba en herramientas administrativas no aparecía el icono de DNS y no podía configurar los reenvíos.

     

    Entonces ahora en el servidor tengo lo siguiente:

    Ip: 10.0.0.2

    Mascara: 255.0.0.0

    Puerta de Enlace: 192.168.2.1 (cuando la establezco me marca un error de que está fuera del segmento de red??)

     

    DNS:10.0.0.2

     

    En los clientes solamente les pongo lo siguiente:

    ip dinámica, DNS:10.0.0.2. Y en la puerta de enlace le dejo 192.168.2.1(ip del router)

     

    Los clientes se pueden conectar bien al dominio e iniciar sesión sin problema.

     

    Configuraciones del Servidor

    En la configuración DNS(Herramientas administrativas/DNS), seleccione el nombre de mi servidor y tengo lo siguiente en propiedades:

     

    En la pestaña interfaces tengo seleccionado "Todas las direcciones IP".

     

    En la pestaña de reenviadores tengo:

       Opción Dominio DNS: "Todos los otros dominios DNS" pero agregé entonces uno nuevo y le puse el nombre de mi servidor.

       Lista de direcciones ip del reenviador de dominio seleccionado: está seleccionado el nombre de mi servidor y agregué las siguientes direcciones, 192.168.2.1(ip del router), 200.23.242.201 y 200.23.242.196 (DNS del ISP que los he visto en la configuración del router inalámbrico que tengo).

     

       He puesto esa configuración, y al parecer todo bien, pero cuando intento entrar desde el servidor a internet me marca un error al poner alguna página, por ejemplo pongo google.com y después de un rato me pone "internet explorer no puede abrir la página solicitada" o algo así. Ya no aparece el mensaje en la ventana de internet explorer de que no encuentra la página pero ahora como que quiere conectar pero algo sucede que no es posible.

     

       En el router también encontré el gateway que utiliza el ISP. ¿Ese me sirve para algo?. ¿Cambia algo de todo esto si tenemos asignada una IP fija?

     

     Creo que está próxima la conexión de internet, pero algo me debe de estar haciendo falta.

     

     

    martes, 18 de diciembre de 2007 18:51