none
Error ejecutando Script RRS feed

  • Pregunta

  • Buenas!!

    Por favor su ayuda para dar con la solución del error que me esta generando al momento de ejecutar un script.

    Este es el error:

    Get-Item : Cannot find path 'D:\Program Files\Microsoft Learning\Base\Drives\MT14A-LON-DC1.vhd' because it does not
    exist.
    At D:\Program Files\Microsoft Learning\20410\Drives\VM-Pre-Import-20410D.ps1:8 char:105
    + ... ) -ParentPath (Get-Item ($path + "Drives\MT14A-LON-DC1.vhd"))
    +                    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (D:\Program File...14A-LON-DC1.vhd:String) [Get-Item], ItemNotFoundExcep
       tion
        + FullyQualifiedErrorId : PathNotFound,Microsoft.PowerShell.Commands.GetItemCommand

    Set-VHD : Cannot validate argument on parameter 'Path'. The argument is null or empty. Provide an argument that is not
    null or empty, and then try the command again.
    At D:\Program Files\Microsoft Learning\20410\Drives\VM-Pre-Import-20410D.ps1:8 char:15
    + Set-VHD -Path (Get-Item ($path2 + "20410D-LON-DC1\Virtual Hard Disks\20410D-LON- ...
    +               ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidData: (:) [Set-VHD], ParameterBindingValidationException
        + FullyQualifiedErrorId : ParameterArgumentValidationError,Microsoft.Vhd.PowerShell.SetVhdCommand

    Get-Item : Cannot find path 'C:\Program Files\Microsoft Learning\20410\Drives\20410D-LON-CL1\Virtual Hard
    Disks\20410D-LON-CL1.vhd' because it does not exist.
    At D:\Program Files\Microsoft Learning\20410\Drives\VM-Pre-Import-20410D.ps1:9 char:16
    + Set-VHD -Path (Get-Item ($path2 + "20410D-LON-CL1\Virtual Hard Disks\20410D-LON- ...
    +                ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (C:\Program File...10D-LON-CL1.vhd:String) [Get-Item], ItemNotFoundExcep
       tion
        + FullyQualifiedErrorId : PathNotFound,Microsoft.PowerShell.Commands.GetItemCommand

    El error es mucho mas largo, sin embargo repetitvo. 

    Por lo poco que puedo entender, podria ser que no esta reconociendo las unidades a las que estoy extrayendo los discos virtuales (Que es lo que hace el script). 

    Sin embargo el servidor contiene las dos unidades o particiones (Tanto C como D).

    Me podrian ayudar a entender y saber como puedo solucionar este problema? Que podria ser?

    Gracias de ante mano

    jueves, 31 de marzo de 2016 20:52

Todas las respuestas

  • Hola Lorena.Giammaria20, creo que por lo que dice el error estás intentando instalar un curso Oficial. Concretamente el error te esta diciendo que el archivo no está, que no lo encuentra. Podés verificar que en la ruta que muestra el script se encuentren los archivos?

    Si es como nos indicas, el error es repetitivo y debe ser que se estén registrando los errores junto a cada archivo que no encuntra.

    Podés enviarnos más información o el script que estás ejecutando?

    • Propuesto como respuesta vmsilvamolina jueves, 1 de diciembre de 2016 14:49
    miércoles, 6 de abril de 2016 18:38