none
Error inesperado durante la conexión al servidor de informes RRS feed

  • Pregunta

  • Cada vez que entro en un informe o intento entrar en alguna opcion del informe , me da el siguiente error: "Error inesperado durante la conexión al servidor de informes. Compruebe que el servidor de informes está disponible y configurado para el modo integrado de SharePoint." .

    No tengo mucha idea de administrar el servidor de informe de sharepoint, pero estoy desarrolando con reporting services , que esta integrado con moss 2007.

    Donde puedo empezar a mirar para resolver este problema?

    miércoles, 17 de agosto de 2011 10:02

Respuestas

Todas las respuestas

  • Hola,

    Te recomendaría que fueses a la Administración Central de SharePoint 2007 y que en la sección de configuración de Reporting Services revisases que puedes acceder a las opciones de integración con Reporting Services sin problemas ya que será signo de que la integración está configurada de forma correcta.

    Un saludo


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.gavd.net/servers/compartimoss/compartimoss_main.aspx
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------
    miércoles, 17 de agosto de 2011 11:34
  • Hola,

    Te recomendaría que fueses a la Administración Central de SharePoint 2007 y que en la sección de configuración de Reporting Services revisases que puedes acceder a las opciones de integración con Reporting Services sin problemas ya que será signo de que la integración está configurada de forma correcta.

    Un saludo


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.gavd.net/servers/compartimoss/compartimoss_main.aspx
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------


    Hola,

    Puedo acceder a "administrar configuraciones de administracion" y "conceder acceso a base de datos" , pero no puedo entrar en  "establecer valores predeterminados del servidor"  , que me da el mismo error que puse antes.  En "administrar configuraciones de administracion" , tengo puesto http://192.168.10.xx/reportserver y autentificacion de windows ; y en "conceder acceso a bbdd" tengo puesto el nombre del servidor donde esta la bbdd de sharepoint (instancia predeterminada).

     

    Por que no podré acceder a "establecer valores predeterminados del servidor" ?

     

     

    miércoles, 17 de agosto de 2011 12:52
  • Buenas,

    ¿Estás seguro de que tienes configurado Reporting Services en modo integrado con SharePoint? ¿Qué tipo de instalación tienes: granja de servidores o mono-servidor?

    Saludos


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.gavd.net/servers/compartimoss/compartimoss_main.aspx
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------
    miércoles, 17 de agosto de 2011 18:31
  • Buenas,

    ¿Estás seguro de que tienes configurado Reporting Services en modo integrado con SharePoint? ¿Qué tipo de instalación tienes: granja de servidores o mono-servidor?

    Saludos


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.gavd.net/servers/compartimoss/compartimoss_main.aspx
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------


    Esta con granja servidores , pero si parece que está fallando la integracion entre sharepoint y reporting services.

    talvez haya algun servicio parado o algo mal configurado en el reporting service configuration manager, en este sentido he visto que la opcion sharepoint integration esta fallando, dice que el repot server no puede acceder a setting database configuration, y que vindows ashrepoint services object model no esta instalado o que el report server web services y windows service account no tiene acceso a la base de datos, 

    supongo que algo hay que tocar en sharepoint central administration, no?


    jueves, 18 de agosto de 2011 7:48
  • Hola,

    como comenta Juan Carlos, debes configurar primero tu Reporting Services en modo integrado de SharePoint y luego configurar en la Administración Central la integración con el servidor de Reporting.

    Te dejo un how-to para que te ayuda http://mosshowto.blogspot.com/2009/01/integrating-sql-server-2008-reporting.html

     


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server
    jueves, 18 de agosto de 2011 8:19
  • Hola,

    Pues ahí tienes el problema....para solucionarlo tienes que ir haciendo lo siguiente:

    • En primer lugar, instalar el modelo de objetos de SharePoint en tu servidor de BD...para ello ejecutas el instalador de SharePoint y añades tu servidor a la granja.
    • En segundo lugar, configura Reporting Services integrado con SharePoint utilizando el Reporting Services Configuration Manager...si estás con SQL Server 2008 es bastante sencillo.
    • En tercer lugar, instala el AddIn de integración de Reporting Services y SharePoint en tus frontales web.

    Estos son los pasos resumidos de lo que tienes que hacer. Revisa los posts que escribí hace tiempo respecto a la integración y que espero te ayuden:

    • http://geeks.ms/blogs/ciin/archive/2008/08/25/sharepoint-y-ssrs-2008-i.aspx
    • http://geeks.ms/blogs/ciin/archive/2008/09/01/sharepoint-y-ssrs-2008-ii.aspx
    • http://geeks.ms/blogs/ciin/archive/2008/10/13/sharepoint-y-ssrs-2008-iii.aspx
    • http://geeks.ms/blogs/ciin/archive/2008/12/10/sharepoint-y-ssrs-2008-iv.aspx
    • http://geeks.ms/blogs/ciin/archive/2009/02/12/sharepoint-y-ssrs-2008-v.aspx

    Saludos


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.gavd.net/servers/compartimoss/compartimoss_main.aspx
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------
    jueves, 18 de agosto de 2011 9:16
  • Ya he conseguido configurarlo bien, o eso creo, es lo que tiene que te hagan tocar temas de administracion sin ser administrador. La cosa es q estaba bien y salto un muelle.

    Ya accedo a los informes, los informes que tienen como origen de datos sqlserver van bien, los unicos informes que no van son los que tienen como origen de datos un cubo de analisis services, he probado poner origen de datos compartido o especifico , pero nada. Estos origenes de datos siempre tienen seguridad integrada de windows. Pero entrando en el servidor de reporting en http://localhost/reportserver si se me abren los informes cuyo origen de datos sea un cubo. Da la impresion que es un tema de acceso desde servidor externo y de permisos.

    jueves, 18 de agosto de 2011 9:23
  • Hola

    el problema que tienes es porque no tienes configurado Kerberos (http://blogs.msdn.com/b/martinkearn/archive/2007/04/23/configuring-kerberos-for-sharepoint-2007-part-1-base-configuration-for-sharepoint.aspx). Cuando un usuario intenta acceder a un informe, es SharePoint quien intenta autenticar al usuario frente al Analysis y al no estar habilitado Kerberos no se puede realizar esa autenticación.

    Tienes dos opciones, o configuras Kerberos o pones las credenciales de un usuario con permisos en el fichero de conexión.

     


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server
    jueves, 18 de agosto de 2011 9:51
  • Hola

    el problema que tienes es porque no tienes configurado Kerberos (http://blogs.msdn.com/b/martinkearn/archive/2007/04/23/configuring-kerberos-for-sharepoint-2007-part-1-base-configuration-for-sharepoint.aspx). Cuando un usuario intenta acceder a un informe, es SharePoint quien intenta autenticar al usuario frente al Analysis y al no estar habilitado Kerberos no se puede realizar esa autenticación.

    Tienes dos opciones, o configuras Kerberos o pones las credenciales de un usuario con permisos en el fichero de conexión.

     


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server

    gracias Alberto, de momento he configurado manualmente las credenciales , ya mirare lo de kerberos.

    Parece que me funcionan ya, he probado con diferentes usuarios y bien.

    La cosa es que al rato he vuelto a entrar en los informes y hay algunos informes que me fallan (ya sean de origen de datos sqlserver y tambien de analisis services), y otros no me fallan (origen de datos sqlserver), el error que da es el que pongo abajo. Parece que hay otros temas externos que afectan a esto.  Lo mas gracioso es que dos informes con el mismo origen de datos sqlserver uno falla y el otro da el error .

    • Error durante la representación del informe.
      • Valor de tiempo de espera caducado. El período de tiempo de espera caducó antes de completar la operación o el servidor no responde.
    Pero al rato vuelto a entrar y todo funciona bien... que esta pasandooo

    jueves, 18 de agosto de 2011 10:47
  • Hola,

    Ese último error ya es de timeout bien porque la consulta del informe es pesada o bien porque tienes el servidor a tope y no le da tiempo a renderizarlo...esto ya es cuestión de rendimiento y ver por dónde se está yendo.

    Saludos


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.gavd.net/servers/compartimoss/compartimoss_main.aspx
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------
    jueves, 18 de agosto de 2011 17:33
  • Lo que si he observado es que no tengo selecionado el protocolo kerneros sino que tengo NTLM.

    Si un usuario entra un informe que tiene autenticacion integrada de windows y el informe no consigue abrir una conexion de analisis services , esta claro que algo mal configurado hay .

    viernes, 19 de agosto de 2011 7:52
  • Ese es el problema, si no tienes Kerberos no puedes usar autenticación integrada de Windows. Piensa que eso significar que SharePoint tiene que pasarle las credenciales del usuario actual (que no conoce) al servidor OLAP para autenticarse.

     


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server
    viernes, 19 de agosto de 2011 8:35
  • si pero yo siempre he tenido configurado los informes que tiran de olap con seguridad de windows integrada y han funcionado bien , por lo que no creo que antes hubiera habido kerberos, nadie en principio lo ha cambiado.

    Supongo que configurar el modo kerberos no es tan facil como entrar en proveedores de confianza y cambiar la configuracion de autenticacion en ISS por kerberos simplemente ,no?


    viernes, 19 de agosto de 2011 9:15
  • No, Kerberos no es tan fácil de configurar. Tienes que hacer cambios a nivel de Directorio Activo. Mira este enlace http://blogs.msdn.com/b/martinkearn/archive/2007/04/23/configuring-kerberos-for-sharepoint-2007-part-1-base-configuration-for-sharepoint.aspx

    ¿antes te funcionaba con los informes en SharePoint o en el Reporting Services?

    Si te funcionaba desde Reporting sería porque la base de datos OLAP residía en local junto con el servidor de informes.

     


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server
    • Marcado como respuesta Ismael Borche viernes, 26 de agosto de 2011 18:15
    viernes, 19 de agosto de 2011 9:20
  • si funcionaban en sharepoint, por eso talvez sea otra cuestion relacionado con la seguridad y las autenticaciones, pero de momento va bien porque le he puesto credenciales especificas manualmente a cada informe que tira de olap.
    viernes, 19 de agosto de 2011 9:49