none
Publicar site wss 3.0 con ISA 2006 RRS feed

  • Pregunta

  • Buenas tardes,

    Tengo la necesidad de publicar varios site a traves de ISA y no consigo llevarlo a cabo, es necesario extender el site como he leido en alguna documentación o se puede publicar cualquier sitio. Y he copiado los pasos literales de como hacerlo de algunas web, pero no consigo realizar el test de la regla y que conecte, si consigo externamente llegar a la autenticación del isa pero introduzco credenciales y no me redirige al sitio, no sé si es problema de ISa o sharepoint o ambos.

    Muchas gracias.

    miércoles, 20 de julio de 2011 15:25

Respuestas

  • Hola cenrugi

    para publicar un sitio (tanto de SharePoint como cualquier aplicación web) no es necesaria extenderlo. Lo que tienes que hacer es lo siguiente:

    - Registrar la url de acceso por el isa en la aplicación web de SharePoint como ruta de acceso alternativa.

    - Crear una regla de publicación (el ISA tiene un asistente para SharePoint) para que atienda a esas peticiones en la URL y el puerto adecuado y las rediriga a tu SharePoint.

    - Que la autenticación no se haga en el ISA y delegar la autenticación al SharePoint.

    Igual se me queda algo, pero más o menos esas son las cosas que hay que tener en cuenta.

     


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server
    miércoles, 20 de julio de 2011 17:10

Todas las respuestas

  • Hola cenrugi

    para publicar un sitio (tanto de SharePoint como cualquier aplicación web) no es necesaria extenderlo. Lo que tienes que hacer es lo siguiente:

    - Registrar la url de acceso por el isa en la aplicación web de SharePoint como ruta de acceso alternativa.

    - Crear una regla de publicación (el ISA tiene un asistente para SharePoint) para que atienda a esas peticiones en la URL y el puerto adecuado y las rediriga a tu SharePoint.

    - Que la autenticación no se haga en el ISA y delegar la autenticación al SharePoint.

    Igual se me queda algo, pero más o menos esas son las cosas que hay que tener en cuenta.

     


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server
    miércoles, 20 de julio de 2011 17:10
  • Dicho así suena muy facil,

    Pero incluso tengo creado una regla con un sitio publicado, y la he copiado y simplemente he cambiado las rutas del servidor interno y publico, el listener es el mismo por lo que entiendo que debería funcionar, pero no consigo enlazar que redirección al hacer el test de la regla me desprende error.

    Lo de la autenticación esta configurado como la otra regla que ya se encuentra funcionando, esto pasa porque la gente se guarda la información para ellos y no documentan.

     

    Saludos y seguire probando a ver si doy con ello.

    jueves, 21 de julio de 2011 6:51
  • Podrías hacer una traza (activar el log en el ISA) para comprobar si el problema es del ISA o del IIS del SharePoint, nos comentas por donde puede estar el problema y te orientamos un poco.

     


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server
    jueves, 21 de julio de 2011 6:57
  • El problema creo que esta en la comunicación entre el ISA y el sharepoint, la prueba de regla no consigo que comunique con isa, en el aam de sharepoint, la ruta que pongo alternativa que pongo para que comunique con ISA, tiene que ser internet, extranet o interna?? yo la tengo como internet.

    TEngo que añadir, que el sitio no esta publicado en la raiz, es decir esta publicado como http://nombreserver:puerto/sites/nombresitio

    Porque a lo mejor estoy obviendo que hay que agregar /sites/nombresitio en algún campo de la configuración?

    jueves, 21 de julio de 2011 8:07
  • Hola la ruta que poner como interna en el ISA puede valer alguna de las que están registradas en SharePoint.

    ¿has probado a navegar desde el ISA a esa url? ¿Podrías tener un problema de DNS interno?

     


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server
    jueves, 21 de julio de 2011 8:20
  • Eso estoy pensando ahora, porque..no consigo que isa me convierta la ruta externa a la interna y yo internamente  no consigo acceder con la ruta alternativa que le he dado en sharepoint, sin embargo tengo credada en el dns el registro para que apunte a la IP del sharepoint. cuando intento me da un error isa, "The IP address for the website you requested could not be found. " Voy a buscar porque no me resuelve internamente.

    Al final podré con ello. Muchas gracias por todo, te sigo informando.

    jueves, 21 de julio de 2011 8:25
  • Busca una opción en el ISA para que reenvie la cabecera de la petición. Posiblemente esté intentando acceder a SharePoint usando la IP y no el HostHeader

     


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server
    jueves, 21 de julio de 2011 8:27
  • Esa opcion, la acabo de desmarcar y vamos mejorando, pero sigo teniendo problemas.

    Otro sitio que tengo publicado accede a traves de autentificarte en ISA. Y cuando intento acceder a este sitio, en lugar de aparecer la pantalla aparece el tipico errror de que existe un problema con el certificado de seguridad. Por si te da alguna pista.

    Pero me sigue dando error el test de  la regla. con nslookup, si que me responde el sitio interno, por lo que en el dns entiendo que esta bien, o hay que agregar algun registro en el reverse?? Si intento acceder desde la web, en lugar de darme el mensaje de isa anterior de que no encontraba ahora me sale el http 400, solicitud incorrecta.


    Cuando pongo la idrección interna de otro sitio que esta funcionando, automaticamente la conviernte a la externa y sin embargo la de este sitio da el error que te acabo de menciar. De quien es trabajo el transformar eso, del ISS de sitio??
    jueves, 21 de julio de 2011 8:43
  • No consigo entender entender como crear los AAM para que funcione, el sitio no tiene host header, por lo que por defecto se encuentra con el nombre del equipo mas ell puerto. Y en el iis viene vacio el host header, ahora he confirgurado dos registro mas como internet que son he añadido las rutas externas desde internet y la ruta interna que debería redirigir el isa, pero algo me estoy saltando porque así es como lo tiene configurado el sitio que tengo publicado.

    Desde el isa internamente tengo sitio,dominio.com y desde el exterior sitio.sharepoint.dominio.com estas son las configuraciones del isa y los dos rutas alternativas. internamente el sitio funciona como http://nombreequipo:91/sites/sitio

    A ver si con estos datos me podeis ayudar. Saludos

    jueves, 21 de julio de 2011 10:29
  • ¿cuál es tu url externa? ¿intranet.midominio.com? Mi recomendación es que configures SharePoint para que acepte esa url y que compruebas que se crear el correspondiente bind (host header) en el IIS.

     


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server
    jueves, 21 de julio de 2011 15:36