none
error web part Buscador de listas en Sharepoint 2007 RRS feed

  • Pregunta

  • Hola

    Este codigo de javascript es que tengamos un buscador de listas, en sharepoint  en un contenedor de web part inserto el siguiente codigo.



    <script language=javascript>

    function LeerWikiSharePointSearchWebpart()
    {
     var searchKey = document.getElementById("Held").value;
     var searchType = document.getElementById("wssHeader__ctl0_HeaderSearch1_headerSearchType").value;
     var searchUrl = document.getElementById("wssHeader__ctl0_HeaderSearch1_headerSearchUrl").value;
     window.location.href= 'http://vcms:44857/sites/Test/default.aspx?k=' + searchKey + "& type=" +  searchType + " & url=http://vcms:44857/sites/Test/Lists/Clasificados";
    }

    function handleEnterKeyForSearchLeerWiki()
    {
    if (window.event.keyCode==13)
    {
    LeerWikiSharePointSearchWebpart();
    return false;
    }
    return true;
    }
    </script>
    <table>
    <tr>
    <td class="ms-sbtable ms-searchform" style="PADDING-LEFT: 4px">
    <a accesskey="S" title="Advanced Search" href="javascript:LeerWikiSharePointSearchWebpart();">
      <img title="Advanced Search" alt="Advanced Search" src="/_layouts/images/SPSSearch2.gif" border="0" style="CURSOR:hand;" align="absmiddle"></a>
    </td>
    <td style="PADDING-LEFT:4px">
    <input name="wssHeader:_ctl0:HeaderSearch1:headerSearchBox" id="Held" type="text" style="width:100px" maxlength="200" Class="ms-sbkeyword ms-descriptiontext" onkeypress="return handleEnterKeyForSearchLeerWiki();" value="" />
    </td>
    <td nowrap>
    <img title="Execute search" alt="Execute search" border="0" alt="Execute Search"
    onmouseover="changeImages(this, '\/_layouts\/images\/icongo02.gif'); return true;"
    onmouseout="changeImages(this,'\/_layouts\/images\/icongo01.gif'); return true;"
    onclick="LeerWikiSharePointSearchWebpart();"
    src="/_layouts/images/icongo01.gif" style="CURSOR:hand" />
    <input name="wssHeader:_ctl0:HeaderSearch1:headerSearchUrl" id="wssHeader__ctl0_HeaderSearch1_headerSearchUrl" type="hidden" />
    </td>
    </tr>

    </table>


    Me regresa el siguiente Error

    Char: 1
    error Object Expected
    Code: 0
    URL http://vcms:44857/sites/Test/default.aspx


    Help me
    viernes, 19 de junio de 2009 0:01