none
Abrir documentos pdf en el explorador RRS feed

  • Pregunta

  • Hola,

    Tengo una colección de sitios con varios subsitios. El caso es que en algunos se me abren los documentos pdf en el explorador y en otros tengo que descargarlos directamente.

    ¿Tengo que tener alguna feature activada a nivel de coleccion de sitios o a nivel de stio para que se me abran por defecto todos en el explorador? ¿O a que se puede deber? 

    A nivel de aplicacion tengo el estado "permisivo" para el manejo de archivos en el explorador.

    Un saludo y gracias.

    miércoles, 2 de noviembre de 2011 12:08

Respuestas

Todas las respuestas

  • Encontré como solventarlo.

    http://howtosharepoint.blogspot.com/2011/04/open-pdf-files-in-browser.html

    Site Collection level

    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    foreach ( $subsite in $site.allwebs )
    {
     foreach ($list in $subsite.Lists)
     {
      if($list.browserfilehandling -eq "Strict")
      {
       $list.browserfilehandling = "Permissive";
       $list.update();
      }
     }
    }
    miércoles, 2 de noviembre de 2011 12:55
  • Hola Ximo,

    esa opción la tienes a nivel de Aplicación Web en la Administración Central de tu granja de SharePoint.

     


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server
    miércoles, 2 de noviembre de 2011 13:45
  • Hola Alberto,

    El caso es que a nivel de aplicación ya la tenía activada. Pero en algunos sitios de una de las colecciones de esta no. Creo que puede ser porque estoy utilizando una plantilla gardada a partir de un sitio importado, pero tampoco lo se seguro...

     

    miércoles, 2 de noviembre de 2011 16:03
  • Hola Ximo,

    A mi pe pasa exactamente lo mismo que te pasó a ti en un subsitio, podrías explicarme como lo hiciste?, donde agregaste este código que nos indicas?.

    Gracias y saludos,

    Whilda

    lunes, 14 de noviembre de 2011 16:33
  • Hola Whilda,

    Prueba primero a ver si te funciona como dice Alberto haciendolo a nivel de aplicación web desde la administracion central. Seleccionando la aplicación web haciendo clic sobre "general settings" y en el apartado de "Browser file handing" selecciona "Permissive".

    Si no, tienes que abrir el SharePoint Management Shell desde el servidor e introducir y ejecutar el codigo para tu coleccion de sitios cambiando la url por la de tu colección.

    lunes, 14 de noviembre de 2011 19:04
  • Hola Ximo,

    Lo tengo en la aplicación marcado como permisivo y en todos los sitios y subsitios me funciona bien, exepto en uno el cuál también importé de una plantilla.

    Gracias por responder tan pronto, lo voy a probar ya comento los resultados.

    Saludos,

    Whilda

    lunes, 14 de noviembre de 2011 19:34
  • Lo acabo de intentar, pero estoy haciendo algo mal, me sale un error cuando intento ejecutar el código:

    Object not found <get-spsite:string>, pero estoy escribiendo correctamente la url.

    Agradezco tus comentarios,

    Saludos,

    Whilda

    lunes, 14 de noviembre de 2011 20:04
  • Hola Whilda,

    Ejecuta primero en tu poweshell "get-spsite", deberian de aparecerte todas las colecciones de sitios.  Para comprobar que la url que estas introduciendo es una de ellas.

    Y otra cosa no pegues directamente todo el script modificado en la linea de comandos.

    Un saludo.

    martes, 15 de noviembre de 2011 16:16
  • Ximo,

    Ya me funciona muchas gracias, lo estaba haciendo bien (el script lo llamo de un notepad), pero me hacían falta importar módulos de Powershell.

    Saludos,

    Whilda

    martes, 15 de noviembre de 2011 19:28