locked
Configuracion de Procesadores en Vista! RRS feed

  • Pregunta

  •  

    Ha salido un truco que se dice, optimiza el arranque de Windows Vista en maquinas con dos procesadores en Vista Business y Ultimate que son diseñado para dos procesadores
    Funcionara?
    la ruta es:
    INICIO - EJECUTAR despues MSCONFIG ingresar a la pestaña de ARRANQUE alli buscar "Opciones Avanzadas" y en la ventana que aparece activar "Numero de Procesadores" y elegir obviamente 2.
    he probado esta opcion en maquinas "Single-Core" (de un solo nucleo) y aparece desactivada, esto pasa tambien con Home Basic y Premium aunque tengan Core Duo, en mi caso utilizo un Centrino Core Duo y Vista Business y si se puede habilitar, pero la pregunta es........
    servira esta opcion para maquinas Core Duo? (doble nucleo que en si son dos CPU´s) o es solo para PC´s con dos procesadores fisicos por separado.
     
    jueves, 29 de noviembre de 2007 3:25

Respuestas

  •  DAMIAN32 Escribió:
     deja de reconoserme los 4 nucleos entonses susede que puede luego ararncar en 2 o en 3 o tal vez 1 o tal ves con mucha suerte los 4 .aclaro que en xp sp3 funciona perfecto y es una lastima no poder usarlo en vista por que con ese fin lo compre al igual que todo el equipo esta totalmente diseñado pra funcionar correctamente en vista

     

    Es un problema de hardware: de Bios probablemente. Y XP, lo mismo que Vista, reconoce lo que la Bios le dica al arrancar el equipo. Recuerda que los equipos con AMD dejan mucho que desear, no por AMD en si, sino porque los fabricante lo usan para ahorrar costes y lo que montan tanto como chipset como Bios en placa madre, nunca es de calidad.

     

    Un saludo,

    • Marcado como respuesta Ismael Borche jueves, 23 de diciembre de 2010 19:46
    viernes, 19 de septiembre de 2008 9:44

Todas las respuestas

  • Las ch*rradas que hay que oir... con perdon... ( y no es culpa tuya.. sino de quien las escribe...)

     

     

    jueves, 29 de noviembre de 2007 6:20
  • Por cierto, y por si acaso alguien se mosquea con mi respuesta anterior (que me ha salido del alma)...

     

    Esa opcion es precisamente AL CONTRARIO... es decir para disminuir el numero de procesadores de una maquina que el sistema operativo puede usar (y no solo en la arrancada, sino en toda la sesion).

     

    Esa opcion existe precisamente para pruebas de programas que si se ejecutan en un determinado numero de procesadores (2 por ejmplo) fallan. De esta manera, Windows de da la opcion de usar solo UN procesador para probar o ejeutar dichos programas. Mas informacion en http://technet.microsoft.com realizando busqyueda por "nunproc" que es el parámetro que modifica dicha opcion del MSCONFIG. Este parametro existente ya en sistemas operativos anteriores (NT, W2000, XP) antes se reflejaba en el boot.ini y en la actualidad, al ser el boot basado en store en vez del boot.ini, para introducri dichi parametro o se usa con bcdedit -muy engorroso para usuarios finales- o se hace mediante esta opcion del MSCONFIG.

     

    Y ahora ¿de tonde c*ño, esos "escritores" de trucos se inventan las cosas?... y lo que es mas grave: ¿la gente sigue siendo tan credula como para creerse estas ch*rradas?...

     

    jueves, 29 de noviembre de 2007 8:31
  •  Jose Manuel Tella Llop Escribió:

     realizando busqueda por "nunproc" que es el parámetro que ...

     

    perdon, quise decir "numproc", no "nunproc".

     

    Un saludo,

     

    jueves, 29 de noviembre de 2007 8:33
  • Hola, con respecto a este post y a la explicacion... ya revise mi equipo.. y esa supuesta opcion la tengo deshabilitada... es decir no esta seleccionado ni 1 ni 2... entonces mi duda es mi win vista con cuantos esta trabajando... por defecto con los 2....?? en administrador de tareas -> rendimiento me muestra 2... asumo que esta trabajando con los 2 nucleos...!!

     

    gracias...

    jueves, 29 de noviembre de 2007 18:06
  •  Fenixxx Escribió:

    en administrador de tareas -> rendimiento me muestra 2... asumo que esta trabajando con los 2 nucleos...!!

     

    Está funcioando con los nucleos que allí ves.

     

    Un saludo,

    jueves, 29 de noviembre de 2007 18:09
  • Bueno en mi post lo aclare, esta opcion aparece desactivada en versiones Home Premium, Basic y por supuesto Starter, debido a que fueron diseñados para un solo procesador (como XP Home) pero NO QUIERE DECIR que Windows Vista Home no pueda trabajar con ellos, Vista "Casero" reconoce y pone a trabajar a ambos nucleos.

     

    MAS BIEN MI PREGUNTA ES..  

     

    POR "DEFECTO" WINDOWS VISTA BUSINESS, ENTERPRISE Y ULTIMATE, AL CORRER CON DOS PROCESADORES FISICOS O CON UN PROCESADOR DE DOS NUCLEOS, "HABILITA" ESTA OPCION, POR DEFAULT VIENE COLOCADA A "1" (LASTIMA QUE NO PUEDO HACER UNA CAPTURA DE PANTALLA) MI DUDA ES..... SI YO COLOCO ESTA OPCION EN "2" PARA DECIRLE A VISTA QUE ESTA MAQUINA TIENE DOS CPUS, VISTA TOMARA VENTAJA Y FUNCIONARA MEJOR, O ESTA VENTAJA ES SOLO PARA DOS PROCESADORES SEPARADOS.

    SALUDOS

     

    jueves, 29 de noviembre de 2007 20:32
  •  Josue Nava Escribió:

    POR "DEFECTO" WINDOWS VISTA BUSINESS, ENTERPRISE Y ULTIMATE, AL CORRER CON DOS PROCESADORES FISICOS O CON UN PROCESADOR DE DOS NUCLEOS, "HABILITA" ESTA OPCION, POR DEFAULT VIENE COLOCADA A "1"

     

    No señor. Lo coloca en el numero de procesadores logicos que tengas. El Hypertrheading *no* es procesador logico. Si a ti te sale uno, es que no tienes mas que un nucleo (aunque veas dos si tiene activado el hyperthreading en la Bios).

     

    En mi caso tengo dos procesaores fisicos Xeon cada uno de ellos QuadCore. Por tanto veo que por defecto me pone 8 procesadores que son los que usa.

     

    En otra maquina tengo un Dual Core en Hypoerthreading... es decir 4 procesadores pero solo dos de ellos son logicos. Por tanto me pone por defecto 2 procesadores.

     

    En una tercera maquina tengo un procesador Quad Core Extreme. No admite hypertrheading pero tiene 4 CPU's logicas. Me pone por defecto 4.

     

    Un saludo,

    jueves, 29 de noviembre de 2007 20:43
  • Como complemente de nuevo: las CPU's que usa Vista son las que ves al abrir el administrador de tareas. Si ves dos, usa dos (aunuqe sea un core en hypertreading). Y las usa desde el inicio de la carga.

     

    El forzar con MSCONFIG es precisamente para *disminuir*. La prueba es tan sencilla como que alguien que tenga dos, que ponga 1 y reinicie. Luego que vaya al administrador de tareas y mire...

     

    Y por cierto, Home (Vista o XP) solo da dosporte a un "socket" de procesador fisico. Si ese socketc es un Quad, usa las 4 CPU's. Si el dia de mañana ese socket tiene 16 CPU's... servirá para 16.

     

    El Business, Ulñtimate y Enterprise (y XP Profesional) son para dos sockets fisicos. Es decir la licencia NO es por CPU sino por socket.

     

    W2003 / W2008 dependiendo de la version da soporte a mas de dos sockets fisicos.

     

    Un saludo,

    jueves, 29 de noviembre de 2007 20:55
  • Al principio de tener un procesador con doble nucleo, si recuerdo que me asuste... porque no tenía ni idea de como podía tener mi equipo dos procesadores, si solo había uno dentro. Lógicamente, te haces a la idea de que dos procesadores, son dos tabletones dentro y no es así. Dos procesadores, dos nucleos, pueden estar empaquetados en un mismo conjunto, vamos en una sola cosa.

    Recuerdo que vi los dos procesadores y lo pregunté en la tienda pensando que era un defecto de la placa base, me dijeron que no, que era por eso.

    Es decir, Windows detecta sin problemas un doble procesador y te pone dos ventanitas...

    ¿Ahora... lo que yo no he visto nunca es uno de quádruple nucleo? Que hace Windows? te lo muestra como si tuvieras 4 procesadores? ni idea Big Smile
    viernes, 30 de noviembre de 2007 19:50
  •  JoseMan09 Escribió:

    ¿Ahora... lo que yo no he visto nunca es uno de quádruple nucleo? Que hace Windows? te lo muestra como si tuvieras 4 procesadores?

     

    Efectivamente, cuatro. O dos de 4 nucleos y lo ves como 8 (es una pena que no pueda poner adjuntos aquí para que lo vieses en mi maquina).

     

    Un saludo,

    viernes, 30 de noviembre de 2007 20:11
  • hola my buenas. tengo una duda sobre vista.... con 4 nucleos de phenom amd 9550 lb3.bueno mi problema es que al instalar vista sp1 claro, lo dejo aqui es que al poquito tiempo este deja de reconoserme los 4 nucleos entonses susede que puede luego ararncar en 2 o en 3 o tal vez 1 o tal ves con mucha suerte los 4 .aclaro que en xp sp3 funciona perfecto y es una lastima no poder usarlo en vista por que con ese fin lo compre al igual que todo el equipo esta totalmente diseñado pra funcionar correctamente en vista desde ram a placa de video pasando por el procesador. no encuentro respuesta por ningun lado ni solucion no espero insultos ni cosas como prova linux por que se que no es totalmente compatible nada en esos sistemas libres.bueno un saludo y gracias de antemano.

     

    viernes, 19 de septiembre de 2008 8:14
  •  DAMIAN32 Escribió:
     deja de reconoserme los 4 nucleos entonses susede que puede luego ararncar en 2 o en 3 o tal vez 1 o tal ves con mucha suerte los 4 .aclaro que en xp sp3 funciona perfecto y es una lastima no poder usarlo en vista por que con ese fin lo compre al igual que todo el equipo esta totalmente diseñado pra funcionar correctamente en vista

     

    Es un problema de hardware: de Bios probablemente. Y XP, lo mismo que Vista, reconoce lo que la Bios le dica al arrancar el equipo. Recuerda que los equipos con AMD dejan mucho que desear, no por AMD en si, sino porque los fabricante lo usan para ahorrar costes y lo que montan tanto como chipset como Bios en placa madre, nunca es de calidad.

     

    Un saludo,

    • Marcado como respuesta Ismael Borche jueves, 23 de diciembre de 2010 19:46
    viernes, 19 de septiembre de 2008 9:44
  •  

    Post interesante sin duda..lastima que ultimamente con el instituto me pierda todos estos temas...

     

    Aver, ami ya me habeis liado...en principio lo mio es un dualcore (Intle pentium d915)...me voy al "msconfig" y veo la casilla que decis deshabilitada...me voy a "ayuda y soporte tecnico", desde alli solicito la "informacion del sistema" y veo que en las espcecificaciones, me dice que tengo 2 procesadores logicos y 2 principales...como hago para ver los procesadores que tengo con el administrador de tareas??

     

    Estoy por solicitar un "systeminfo" en una consola y ver que me suelta...XD

     

    Saludos!!

     

     

    Pijoooo..ahora me doy cuenta en el administrador de tareas me salen las 2 ventanitas XD..esto me pasa por no fijarme bien en las cosas!

     

    creo que por mi esta solucionado...ahora me toca crear un post con dudillas.

     

    Saludos!

    viernes, 19 de septiembre de 2008 20:31
  •  molpiiii Escribió:

    Pijoooo..ahora me doy cuenta en el administrador de tareas me salen las 2 ventanitas XD..esto me pasa por no fijarme bien en las cosas!


    como pa' caparte.. :-PPP

    Un saludo,
    viernes, 19 de septiembre de 2008 20:41
  •  Jose Manuel Tella Llop Escribió:
     molpiiii Escribió:

    Pijoooo..ahora me doy cuenta en el administrador de tareas me salen las 2 ventanitas XD..esto me pasa por no fijarme bien en las cosas!


    como pa' caparte.. :-PPP

    Un saludo,

     

    sisi, ultimamente voy "apollardao"..fijate que viniendo del instituto, no me e acordado de los badenes que hay en la carretera (paso por ella todos los dias, porque es la unica carretera para llegar) y asi a pasado, que parecia que estaba haciendo motocross! XD

     

    Saludos!

    viernes, 19 de septiembre de 2008 20:51
  • hola amigo, gracias por tu respuesta, muy atento . bueno bueno sin anismos de ofensa quiero volver al tema .esto no ofrece ninguna solucion a mi pregunta , no es cosa de amd ni de abaratar costos ya que estamos hablando de la gama alta de amd por dios ! , no s ede donde eres tu pero aqui en argentina  comprar un amd x 4  no es cosa barata . bueno a eso me referia no quiero entrar en detalles para no salir del tema mi equipo es totalmente nuevo y vista es original xp va de lujo vista de ves en cuando aun busco una solucion al desvario de los quad en vista . ya que no es esto por ninguna marca si no que es a quien preste atencion con un quad core en administrador de tareas . ejemplo luego de salir de un juego pesado y exijente como lo es crysis o assassins creed entre otros sucede que no vuelve a funcionar uno o 2 de los procesadores. solo en win vista ultimate original con todas las de la ley . mi mother es un abit ax78 , y esto pasa tambien con los micro quad intel ya que reparo varias pc de paso les echo una buena prueva a cada una con quad intel . que ni siquiera es ficico. bueno un saludote espero respuestas.perdon si entre muy en detalles que no bienen al caso las marcas de micro ni mother este es un problema generalisado por vista.

     

    sábado, 20 de septiembre de 2008 4:24
  •  DAMIAN32 Escribió:
    , no es cosa de amd ni de abaratar costos ya que estamos hablando de la gama alta de amd por dios ! , no s ede donde eres tu pero aqui en argentina  comprar un amd x 4  no es cosa barata . bueno a eso me referia no quiero entrar en detalles para no salir del tema mi equipo es totalmente nuevo 

    Devuelve el equipo y ejerce la garantia. Ese equipo está dañado.

    Un saludo,
    sábado, 20 de septiembre de 2008 7:45
  •  

    Pues sip, porque si en principio lo que tu compraste era un "cuadcore" (4 nucleos, o un dualcore ect) has pagado mas dinero por ese procesador y te han metido uno muy inferior....la garantia esta para usarla (piensa que solo dura 2 años) ve y reclamales!!

     

    Saludos!

    sábado, 20 de septiembre de 2008 11:58
  •  molpiiii Escribió:

    Pues sip, porque si en principio lo que tu compraste era un "cuadcore" (4 nucleos, o un dualcore ect) has pagado mas dinero por ese procesador y te han metido uno muy inferior....la garantia esta para usarla (piensa que solo dura 2 años) ve y reclamales!!


    No. Le han vendido uno de 4 nucleos... pero dañado o bien la placa madre dañada... ya que a veces ve un solo nucleo, a veces dos, y a veces 4.

    Un saludo,
    sábado, 20 de septiembre de 2008 13:40
  • hola de nuevo, el problema no es del mother ya lo e cambiado y tambien el amd lb2 x uno de lb3. el problema esta en vista y algun tipo de incompatibilidad de la que no se como manipular, solo a esto es por lo que pido ayuda tengo algunos años en pc y electronica se reparar algunas cosas e aprendido en 14 años de trabajo," sin animo de ofensas" si alguien conose la solucion que desconosco en vista favor me avise saludos,....

    domingo, 21 de septiembre de 2008 4:24
  •  DAMIAN32 Escribió:

    hola de nuevo, el problema no es del mother ya lo e cambiado y tambien el amd lb2 x uno de lb3. el problema esta en vista y algun tipo de incompatibilidad de la que no se como manipular, solo a esto es por lo que pido ayuda tengo algunos años en pc y electronica se reparar algunas cosas e aprendido en 14 años de trabajo," sin animo de ofensas" 


    El problema está en el hardware o en la Bios. Y tambien sin "animo de ofensa" mas de 30 años en el mundo de la informatica (antes de que existiese el primer PC) y mi primera carrera universitaria fué con doctorado en Fisicas expecialidad de Electronica.




    domingo, 21 de septiembre de 2008 8:00
  •  

    hola hay un parche en la pagina de amd que te puede servir ,ahora si te corre bien en xp tu equipo esta bueno , si estuiera malo tendrias problemas siempre, pero en amd hay un parche para los dual core chao
    martes, 23 de septiembre de 2008 5:21
  •  jose dominguez2 Escribió:

     ,ahora si te corre bien en xp tu equipo esta bueno , si estuiera malo tendrias problemas siempre, pero en amd hay un parche para los dual core chao



    No. No está bien. Hay una gama entera de procesador AMD Phenom que salieron incorrectos... y la unica solucion es que la bios modifique su microcodigo o bien hacerlo por driver de boot cuando las placas madre son de baja calidad y no actualizan sus Bios, o bien, lo que yo veo mas logico: devolver el procesador.


    Un saludo,

    martes, 23 de septiembre de 2008 13:44
  • Hola. Veo que este foro no tiene rstas. desde hace un año, pero realmente está muy interesante y no hay muchos lugares donde se hable esto.

    Yo tengo un procesador nuevo Core i7 920 de 4 proesadores físicos y 8 núcleos. Tengo win vista Home Premium SP2. Hice el supuesto "truco" de cambiar el MSCONFIG la parte de arranque y colocar 8 nucleos, ya que en el win vista me venía desactivado y solo mostraba 1 nucleo. En Administrador de tareas siempre vi 8 nucleos separados, antes y despues del supuesto truco de MSCONFIG.

    Consultas: 
    - Actualmente mi PC está usando los 8 nucleos?
    - Para arrancar empezo a usar los 8 nucleos cuando le cambie el arranque desde el MSCONFIG o antes tambien lo hacia por defecto pese a que estaba grisada la opcion y decia 1?
    - Con Vista Home Premium, estoy desaprovechando parte de la capacidad de la maquina? Debería cambiar a un Ultimate por ej? Lo consulto por el tema de los sockts.
    - Tengo un relojito en el escritorio que me marca el uso del procesador y veo que esta siempre bajo. O no lo uso muy fuerte o se està desaprovechando su uso: HAY ALGUNA MANERA DE CONFIGURAR EL USO TOTAL DE 8 NUCLEOS EN VISTA HOME PREMIUM?

    Gracias. Espero me respondan.

    Victor
    miércoles, 16 de septiembre de 2009 1:18
  • El truco...esta ahi, yo no le hice mucho caso en su dia...
    El tema del aprovechamiento del procesador...metele caña, ya veras como sube el contador..un quad core necesita un poco de "animos" para que trabaje...por ejemplo haz funcionar una maquina virtual o algun juego que necesite de procesador...

    Saludos!
    jueves, 17 de septiembre de 2009 20:38