none
Problemas en el despliegue de una aplicación con dos "Deployment Types" RRS feed

  • Pregunta

  • Buenas tardes,
    Estoy intentando realizar un despliegue desde SCCM 2012 que me lleva loco durante dos semanas.

    Lo que intento hacer es:
     * Instalar una aplicación de la que no encuentro msi pero que si permite instalación silenciosa desde el propio setup (*.exe)
     * Realizar un cambio en la configuración de registro dentro de la rama HKCU

    Para esto creo una aplicación y defino:
     * Un deployment type para distribuir la aplicación
     * Un deployment type para distribuir el cambio en el registro del usuario validado

    He hecho mil combinaciones y nada.

    El deployment de la aplicación se instala correctamente, pero el deployment para la modificación de registro no hay manera.

    Este mismo deployment type (el del registro)  lo he definido dentro de una aplicación independiente y si funciona, pero cuando los incluyo a los dos en la misma aplicación no.

    He utilizado para el segundo un archivo bat que se encuentra en el mismo directorio que el setup del primer deploy, con entradas del tipo:

    "%COMSPEC% /C REG ADD "HKCU\Software....." que como he comentado antes funciona desde una aplicacion independiente.

    He probado a cambiar la prioridad de los dos deploys, a poner una dependencia del deploy del registro, de forma que éste dependa de que se instale OK el primero.

    El despliegue debe ser "Required" así que se ejecuta con usuario privilegiado

    No se ya por donde tirar.

    Se os ocurre alguna idea de que puedo estar haciendo mál?

    Muchas gracias.
    Un saludo
    Paco.

    lunes, 27 de abril de 2015 12:39

Respuestas

  • Buenas tardes.

    Has probado (en tus combinaciones):

    -Generar 2 aplicaciones

    -Agregar método de detección en la instalación de la aplicación

    -Agregar como dependencia el cambio de registry --> creando un "dependency Group" y colocando la  aplicación como "Auto Install"??

    Además revisar los logs:

    AppIntenteval.log (compliant) / AppDiscovery.log (detección) / Appenforce.log (install/uninstall) / _SCNotify_dom@user_1.log / _SCNotify_dom@user_2.log  / statusAgent.log

    En los logs, verás cual es el problema.  Además en la consola de Monitoring, para el deploy, también se ve la info.

    Espero te ayude. Saludos.


    Ayuda a la comunidad. Si consideras que la respuesta te fue util, marcala por favor como respuesta final. Marcela Berri Instructor/Consultor Senior IT MCT–MVP Enterprise Client Management MCTS Server Admin/AD2008/Network Inf/Srv Virt2012R2/W7yOff2010 MCTS SCCM2012/2007/SCOM2007 MCITP Exchange 2010/2007-MCTS Exch2010/2007-MCTS Lync2010 ITTechnologySite.blogspot.com

    • Marcado como respuesta fgg18l miércoles, 29 de abril de 2015 12:35
    lunes, 27 de abril de 2015 19:27

Todas las respuestas

  • Buenas tardes.

    Has probado (en tus combinaciones):

    -Generar 2 aplicaciones

    -Agregar método de detección en la instalación de la aplicación

    -Agregar como dependencia el cambio de registry --> creando un "dependency Group" y colocando la  aplicación como "Auto Install"??

    Además revisar los logs:

    AppIntenteval.log (compliant) / AppDiscovery.log (detección) / Appenforce.log (install/uninstall) / _SCNotify_dom@user_1.log / _SCNotify_dom@user_2.log  / statusAgent.log

    En los logs, verás cual es el problema.  Además en la consola de Monitoring, para el deploy, también se ve la info.

    Espero te ayude. Saludos.


    Ayuda a la comunidad. Si consideras que la respuesta te fue util, marcala por favor como respuesta final. Marcela Berri Instructor/Consultor Senior IT MCT–MVP Enterprise Client Management MCTS Server Admin/AD2008/Network Inf/Srv Virt2012R2/W7yOff2010 MCTS SCCM2012/2007/SCOM2007 MCITP Exchange 2010/2007-MCTS Exch2010/2007-MCTS Lync2010 ITTechnologySite.blogspot.com

    • Marcado como respuesta fgg18l miércoles, 29 de abril de 2015 12:35
    lunes, 27 de abril de 2015 19:27
  • Buenos días,

    Probaré con tus indicaciones Marcela.

    Muchas gracias por tu atención :-)

    Saludos.

    Paco.

    martes, 28 de abril de 2015 6:17
  • Buenos días de nuevo Marcela,

    Como me has indicado, así ha funcionado perfectamente.

    Muchas gracias de nuevo :-)
    Saludos

    Paco.

    miércoles, 29 de abril de 2015 8:43
  • Me alegro que te sirva!

    Saludos.


    Ayuda a la comunidad. Si consideras que la respuesta te fue util, marcala por favor como respuesta final. Marcela Berri Instructor/Consultor Senior IT MCT–MVP Enterprise Client Management MCTS Server Admin/AD2008/Network Inf/Srv Virt2012R2/W7yOff2010 MCTS SCCM2012/2007/SCOM2007 MCITP Exchange 2010/2007-MCTS Exch2010/2007-MCTS Lync2010 ITTechnologySite.blogspot.com

    miércoles, 29 de abril de 2015 14:05