none
Error Durante el proceso de instalacion de Exchange 2010 RRS feed

  • Pregunta

  • Buenas,

    Tengo un servidor HP ML 350 con un Windows 2008 Server R2 Standard, y sobre éste un máquina virtual con Hyper-V que tiene otro windows 2008 Server R2 Standard. La instalación sobre el SO de la máquina física es el controlador de dominio, y sobre la virtual tenía montado un exchange 2010. Todo funcionó bien durante mas de 1 año; hasta que sin más un día dejó de sincronizar el directorio activo. Intenté repararlo pero no hubo forma (o yo no supe encontrarla).

    Cuestión que decidí deshacerme de la máquina virtual(ya que dispongo de copia de seguridad de todos los correos y no pierdo mas que el tiempo de reinstalarla) pero oh sorpresa la mia, después de instalar toda la máquina virtual nuevamente (con todas las actualizaciones y demas) me dispongo a instalar exchange y me sale un mensaje diciendo que hay un exchange instalado y que no puede eliminar unos atributos del AD.

    Yo he limpiado todo el AD manualmente (como pude y según algunas web indicaban) pero aún me sigo encontrando con algunos problemas.

    Les detallo los problemas que tengo:

    Al ejecutar el comando x:\setup /PrepareSchema ó setup /ps me aparece el siguiente mensaje:

    Ampliando Esquema de directorio activo

    Progreso                     ......................ERROR

    Se ha generado el siguiente errorcuando se ejecutó "$error.Clean(); install-ExchangeSchema -LdapFileName ($rolInstallPath + "Setup\Data\"$RoleSchemaPrefix + "schema0.ldf")":"Error al ejecutar "ldifde.exe" para importar el archivo de esquema "C:\Windows\Temp\ExchangeSetup\Setup\Data\postExchange2003_schema0.ldf". El código de error es: 8224. Se pueden encontrar mas detalles en el archivo de error: "C:\Users\Administrador.(nombredeldominio)\AppData\Local\Temp\ldif.err"."

    Este fichero solo contiene la siguiente leyenda: "El código de error es: 8224."

    Si paso por alto este mensaje de error (que esta mal porque ya está indicando que hay algo que no va muy fino) y ejecuto el comando:

    x:\Setup /PrepareAD

    Me aparece el siguiente error:

    Se ha generado el siguiente error cuando se ejecutó "$error.Clear(); initialize-

    ExchangeUniversalGroups -DomainController $RoleDomainController": "La entrada de objeto conocida

    B:32:C262A929D691B74A9E068728F8F842EA:CN=Organization Management\0ADEL:1ed4bce3-9e6c-4435-9549-

    53040f5f103e,CN=Deleted Objects,DC=(midominio),DC=local del atributo otherWellKnownObjects del objeto

    contenedor CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=(midominio),,DC=local señala a un DN que no

    es válido o a un objeto eliminado. Quite la entrada y vuelva a ejecutar la tarea.
    ".

    He intentado quitar la entrada pero no puedo, no me deja. Lo he editado con el Editor ADSI pero no me deja modificar la entrada ni eliminarla.

    A ver si alguien puede echarme un cable.

    Gracias

    martes, 8 de noviembre de 2011 16:47

Respuestas

Todas las respuestas

  • Es que Exchange no se puede desinstalar "formateando", se debe hacer desde el programa de instalación.

    Por otro lado, si ya preparaste el Schema en la primera instalación, no debes volver a prepararlo esta vez aunque tal como está el AD, tendrás bastantes problemas para instalar Exchange correctamente :(


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card
    martes, 8 de noviembre de 2011 17:50
    Moderador
  • Hola Marc.

    Yo tengo el mismo problema, y me da ese error que me recomiendas hacer?

    agradezco mucho tu ayuda.

    martes, 29 de noviembre de 2011 21:53
  • No sabría decirte dado que estos casos son realmente complicados de explicar y de resolver.

    Podrías probar de intentar recuperar el servidor con un setup.com /m:recoverserver tal como tengo explicado en este par de artículos pero no te puedo garantizar nada :(


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCTS: Microsoft Lync Server 2010, Configuring
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card
    miércoles, 30 de noviembre de 2011 7:52
    Moderador
  • En este caso, esto se solucionaria si formateo mi DC y el exchange y comenzar desde cero, como una instalacion en limpio?

    si hago eso, podria solucionarse?

    Gracias.

    miércoles, 30 de noviembre de 2011 16:37
  • Buenas,

    Samuel, un consejo,

    olvida la opcion de formateo porque creo que con la experiencia que has tenido con exchange todavía no tienes suficiente, te lo comento con todo el respeto.

    Si formateas tu dc, los usuarios perderan su identificador original y no podran validarse con el nuevo DC que crees.

    Por favor sigue el consejo de Marc Salvador de reinstalar el Exchange con esa opcion de reparacion para poder añadirle la base de datos del exchange antiguo y poder recuperar los emails.

    Si no pudieras recuperar el servicio, deberia pensar en una solucion de terceros, que permite recuperar buzones de una base de datos de exchange sin estar montada sobre un exchange.

    Saludos.


    MCSE Formador y Consultor Microsoft.
    miércoles, 30 de noviembre de 2011 17:06
  • Hola Raul agradesco tu sinceridad.

    pero considerando que solo existia un usuario y era de prueba, que el servidor no estaba siendo usado por ningun usuario.

    Gracias

    miércoles, 30 de noviembre de 2011 17:38
  • En ese caso, si era un laboratorio con un DC, un Exchange y un usuario, lo mejor es que empieces de cero :)
    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCTS: Microsoft Lync Server 2010, Configuring
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card
    jueves, 1 de diciembre de 2011 8:41
    Moderador
  • Hola Marc muchas gracias por tu respuesta,

    entonces comenzare desde cero.


    Marc comenze desde cero pero tengo otro problema con el exchane, aver si me ayudas por favor, esta en el siguiente post.

    http://social.technet.microsoft.com/Forums/es-ES/exchangees/thread/31c8a9fd-3b7a-4ac8-bda5-de7c993701e1/#6f681d78-7f47-4286-8dd3-e32dd4b0845a

     

    Muchas gracias.

    jueves, 1 de diciembre de 2011 16:01
  • Responido :)
    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCTS: Microsoft Lync Server 2010, Configuring
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card
    viernes, 2 de diciembre de 2011 14:37
    Moderador