none
SharePoint 2010 - Flujos de trabajo RRS feed

  • Pregunta

  • Buenos días,

    Mi duda surge porque en una lista de SharePoint que tenía unos flujos de trabajo funcionando correctamente; cuando accedo a un elemento de la lista y reviso el historial de un flujo para ver todos los procesos; me indica que el elemento no tiene asignado ningún flujo de trabajo.

    Si accedo a través de la lista Historial del flujo de trabajo y busco por el ID de la lista sí que me lo encuentra y puedo visualizar todo el proceso que se ha llevado a cabo.

    Parece como que se haya perdido la referencia entre el elemento y el historial.

    Espero que me puedan ayudar.

    Gracias de antemano.

    Un saludo.

    David

    martes, 25 de octubre de 2011 10:19

Todas las respuestas

  • Hola David,

    si vas al elemento no puedes ver el Workflow salvo que se haya ejecutado para ese elemento de la lista.

     


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server
    martes, 25 de octubre de 2011 12:03
  • Hola Alberto,

    Antes de nada, agradecerte tu contestación; pero indicarte que ése es el problema; que el elemento sí que tiene asignado el flujo de trabajo; pero no sé si la relación se ha perdido por alguna razón; ya que en la columna denominada como el nombre del flujo de trabajo en la vista de la lista; el hipervínculo indicaba el estado como finalizado y al hacer click se podía ver todo el historial.

    El problema es que ahora en esa columna aparece en blanco, es decir, no indica ningún estado. Lo más sorprendente es que no lo muestra en ningún elemento de la lista.

    Las dudas que me surgen, no sé si perdería por el timerjob que se encarga de limpiar el historial del flujo de trabajo (ahora ya lo he deshabilitado pero puede que estuviera funcionando) o por actualizar al ServicePack 1 y algún proceso no funcione correctamente.

    También, mediante C# he hecho visible la lista "Historial del flujo de trabajo" y mediante los GUID y la BBDD he podido ver que ese elemento sí que tiene el historial del flujo de trabajo guardado ya que tiene unos 5 elementos en esa lista. Lo único que al acceder a la propia lista me indica que no se ha iniciado ningún flujo de trabajo.

    Un saludo.

    David


    • Editado David Uru martes, 25 de octubre de 2011 15:26
    martes, 25 de octubre de 2011 15:17