none
Ejecutar como administrador ejecutables en carpetas redireccionadas RRS feed

  • Pregunta

  • Buenas tardes.

    Estoy poniendo en funcionamiento en la red el sistema de redirección de carpetas de usuarios.

    El recurso compartido donde están configuradas las redirecciones es un una namespace DFS, y los permisos del recurso compartido están definidos como describe este artículo:

    https://support.microsoft.com/en-us/kb/288991

    De esta forma, puedo hacer Backup de las carpetas y cada usuario solo ve lo suyo.

    También he configurado que las carpetas redirigidas estén siempre disponibles sin conexión, ya que hay mucho portátil:

    https://technet.microsoft.com/en-us/library/hh968298.aspx


    Todo funciona según lo esperado, pero me gustaría saber si hay manera de de resolver lo que expongo a continuación:

    Muchas veces los usuarios piden instalar aplicaciones que se han descargado en sus carpetas redireccionadas, y al ejecutar estos ejecutables con el usuario administrador designado para hacer las instalaciones, pide las credenciales un par de veces, y no funcionan. Al segundo intento aparece un mensaje de que el usuario (El Administrador que se usa para instalar) no tiene acceso al recurso de red.

    La molesta solución es copiar el ejecutable en alguna otra parte del disco duro, y lanzar la instalación desde esta nueva ubicación.

    Si miro los permisos del ejecutable en el recurso donde están las redirecciones directamente desde el servidor de archivos, veo que el grupo de administradores tiene permisos completos para el ejecutable, pero si miro los mismos permisos del archivo ejecutable desde la sesión de usuario, ni tan solo me aparece la pestaña de seguridad.

    Me imagino que esto es debido al hecho de haber activado que los archivos siempre estén disponibles sin conexión.

    ¿Hay alguna manera de poder solucionar esto? 

    Gracias



    • Editado jokland_cat miércoles, 6 de abril de 2016 14:51
    miércoles, 6 de abril de 2016 14:40

Respuestas

  • Yo he tenido un problema mas o menos similar, no igual pero parecido...

    Creo que la raíz del problema está en que los ejecutables están en carpetas compartidas, por lo que windows los detecta como no seguros, por lo general suele preguntar si quieres ejecutarlo o no, pero en algunos casos no pregunta o hace cosas como las que dijiste tu arriba.

    Posible solución: opciones de internet > pestaña seguridad > nivel personalizado > marca Ejecutar aplicaciones y archivos no seguros(no seguro) en habilitar

    Puedes probarlo en modo local a ver si así te funciona y luego aplicarlo por directivas de grupo a todo el dominio. Cabe destacar que una vez que marques ésta opción, internet explorer se volverá pesado diciendote que la configuración no es segura, para solucionar este segundo problema, en el editor de directivas de grupo habilitas la siguiente directiva:

    User configuration/Computer configuration > Policies > Administrative Templates > Windows components > Internet explorer > Turn off the security settings check feature

    Por último, avisarte de que tengas cuidado con los ejecutables que hay en la red porque ahora se pueden ejecutar todos.

    Espero haberte sido de ayuda, saludos

    • Marcado como respuesta Moderador M lunes, 30 de mayo de 2016 21:33
    viernes, 20 de mayo de 2016 8:45