none
Problema con servicio FimService a la hora de iniciar la sincronizacion de perfiles de usuario en sharepoint 2010 RRS feed

  • Pregunta

  • Buenas, estoy trabajando con sharepoint 2010 virtualizado en un servidor windoes server 2008, la computadora esta pegada al dominio y el AD esta en un servidor 2000

    el proceso para la sincronizacion lo hice con base en el link de microsoft Configure profile synchronization (SharePoint Server 2010) http://technet.microsoft.com/en-us/library/ee721049.aspx  ,confiero los permisos necesarios en el AD....

     

    Ademas desde administracion central verifico que el usuario que se utilizo en la configuracion inicial o instalacion pertenezca

    , despues este agregado a las cuentas administradas

    y por ultimo que sea la cuanta asignada para el conjunto de servidores

    todo esto en la seccion de seguridad de administracion central.

     

    Luego voy a administracion de aplicaciones -> administrar aplicaciones de servicio -> hay le he dado permisos a la cuenta del conjunto de servidores (mencionada anteriormente) sobre la aplicacion de perfiles de usuario  (en el ribon en la parte seguridad y permisos). Otro intento fue no correr el asistente de configuracion y crear yo mismo la aplicacion de perfiles de usuario y darle los permisos respectivos, tampoco funciono.

     

    Ahora viene la parte confusa o que no puedo resolver (Pregunta)

    Se supone que ya configurado todo esto deberia ir a administracion central ->administracion de aplicacionesd>administrar servicios en el servidor e iniciar:

    1. El servicio de perfil de usuario (El cual inicia satisfactoriamente)
    2. el servicio de sincronizaion de perfiles de usuario (pasa a estado iniciando, despues de aproximadamente 10 minutos se detiene), aqui viene el problema mientra el servicio esta en estado iniciando voy al visor de enventos de widows, al log de Aplicacion y vigilo el servicio FIMSynchronizationService el cual se comunica con la base de datos de sincronizacion de forma satisfactoria e inicia, pero se deteine alrededor de 10 minutos despues, lo estrano es que el servicio FIMService siempre aparece como Disabled en todo momento, segun lo que he investifgado y leido este servicio deberia estar corriendo al momento de iniciar la sincronizacion ,pero parece que sharepoint nunca lo inicia, no se si sera falta de alguna configuracion, permiso o actualizacion del servicio o del forefront manager identity??
    Agradezco ideas que me ayuden a solucionar este problema. Algo importante esque no aparece ningun error en el log, despues de 10 miniutos el servicio FIMSynchronizationService se detien satisfactoriamente .

     

    miércoles, 19 de enero de 2011 14:39

Respuestas

  • Hice pruebas con un AD en un windows server 2008 y funciono a la primera, pareciera que sharepoint 2010 no es compatible con el controlador de dominio de windows server 2000, solo con versiones 2003 en adelante según lo que he leido.

     gracias por toda la ayuda ...

    • Marcado como respuesta Esteban. _ martes, 26 de julio de 2011 21:59
    lunes, 7 de febrero de 2011 15:44

Todas las respuestas

  • Hola Esteban,

    Para configurar la dichosa sincronizacíón de los pérfiles de usuario, te recomiendo que sigas los posts al respecto de Spence Harbar: http://www.harbar.net/articles/sp2010ups.aspx. El es el mayor experto en este tema. Si lo que dice Spencer no te soluciona el problema que estás teniendo, haz lo siguiente:

    • Lo primero, bájate la utilidad ULSViewer para ver de forma detallada cuál es el error que estás teniendo.
    • En segundo lugar, ¿qué versión en cuanto a cumulative updates de SharePoint Server 2010 tienes instalada? Te lo pregunto, porque la CU de agosto de 2010 soluciona alguno de los problemas de sincronización de pérfiles...también te lo pregunto porque si instalaste la CU de Octubre qde 2010 ue tenía fallos, posiblemente te esté afectando a la sincronización.

    Un saludo

    miércoles, 19 de enero de 2011 16:12
  • Hola Esteban

    como dice Juan Carlos leete bien el artículo de Harbar. Posiblemente, aunque no parece una buena solución, se soluciona poniendo como administrador local al usuario del servicio y poniendo esa identidad en los dos servicios de FIM.

    Una vez esto, configuras el SharePoint y si ves que se queda colgado los servicios de FIM, reinicia el server y probablemente se arranquen perfectamente una vez todo esto.


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server
    miércoles, 19 de enero de 2011 16:40
  • Gracias por la pronta respuesta , investigue e hice lo que me aconsejaron, primero instale las actualizaciones acumulativas hasta la de agosto del 2010 de sharepoint server, luego baje la herramienta  ULSViewer para revisar los log de sharepoint y definitivamente el servicio de Fimservice no se iniciaba porque existian problemas, pero llege a este:

    UserProfileApplication.SynchronizeMIIS: Failed to configure ILM, will attempt during next rerun. Exception: System.Security.SecurityException: The Kerberos subsystem encountered an error. A service for user protocol request was made against a domain controller which does not support service for user.       at System.Security.Principal.WindowsIdentity.KerbS4ULogon(String upn)     at System.Security.Principal.WindowsIdentity..ctor(String sUserPrincipalName, String type)     at System.Security.Principal.WindowsIdentity..ctor(String sUserPrincipalName)     at Microsoft.IdentityManagement.SetupUtils.IlmWSSetup.GetDomainAccountSIDHexString(String domainName, String accountName)     at Microsoft.IdentityManagement.SetupUtils.IlmWSSetup.GrantSQLRightsToServiceAccount()     at Microsoft.IdentityManagement.SetupUtils.IlmWSSetup.IlmBuildDatabase()     at Microsoft.Office.Server.UserProfiles.Synchronization.ILMPostSetupConfiguration.ConfigureIlmWebService(Boolean existingDatabase)     at Microsoft.Office.Server.Administration.UserProfileApplication.SetupSynchronizationService(ProfileSynchronizationServiceInstance profileSyncInstance)  The Zone of the assembly that failed was:  MyComputer.

    La duda es la siguiente : estoy tratando de conectar sharepoint a un AD en windows 2000, pero segun este link de microsoft  http://technet.microsoft.com/en-us/library/ff182925.aspx y este foro http://social.msdn.microsoft.com/Forums/en-US/sharepoint2010setup/thread/d636ba25-2bce-413b-a7a9-9989f8029412 solo es compatible con windows server 2003 como minimo, esto es del todo cierto??
    viernes, 21 de enero de 2011 22:27
  • Hola Esteban,

    ¿tienes la negociación de kerberos habilitada en tu proveedor de autenticación? Si es así, deberías de configurar kerberos para su servidor sharepoint en el dominio.


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server
    sábado, 22 de enero de 2011 10:34
  • Hice pruebas con un AD en un windows server 2008 y funciono a la primera, pareciera que sharepoint 2010 no es compatible con el controlador de dominio de windows server 2000, solo con versiones 2003 en adelante según lo que he leido.

     gracias por toda la ayuda ...

    • Marcado como respuesta Esteban. _ martes, 26 de julio de 2011 21:59
    lunes, 7 de febrero de 2011 15:44