none
Ayuda! Como desinstalar Service Pack 2 Windows 2003 RRS feed

  • Pregunta

  • Hola a todos, mi problema es el siguiente:

     

    Resulta que las instalaciones automáticas de mi windows 2003 server SMB instalaron fallidamente el service pack 2, ahora que quiero instalar el parche de seguridad MS08-067 me dice que no lo puede instalar porque no tengo el SP2 siendo que aparece en "agregar y quitar programas", cuando trato de desinstalarlo de agregar y quitar programas me marca que no encuentra el archivo de desinstalación y se cierra el desinstalador, mi preguntas es, ¿alguien sabe como desinstalar el SP2 manualmente?

     

    Mil gracias por su ayuda.

    jueves, 15 de enero de 2009 17:11

Respuestas

  • Descartando la opción de agregar y quitar programas... prueba con alguna de las siguientes 2 opciones:

    Utilizar la carpeta oculta $NtServicePackUninstall$

    1. Haz clic en Inicio y en Ejecutar, escribe c:\windows\$NtServicePackUninstall$\spuninst\spuninst.exe en el cuadro Abrir y haz clic en Aceptar.
    2. Cuando se inicie el Asistente para desinstalación del Service Pack 2 de Windows Server 2003 (Windows Server 2003 Service Pack 2 Removal Wizard), haz clic en Siguiente.
    3. Sigue las instrucciones en pantalla para quitar el SP2 de Windows Server 2003.

    Utilizar el proceso Restaurar sistema

    1. Haz clic en Inicio y en Ejecutar, escribe %raízSistema%\System32\restore\rstrui.exe en el cuadro Abrir y haz clic en Aceptar.
    2. Haz clic en Restaurar mi equipo a un estado anterior y, a continuación, en Siguiente.
    3. Haz clic en la fecha en la que se instaló el SP2 de Windows Server 2003 y haz clic en Se instaló Windows Server 2003 Service Pack 2 en el cuadro Punto de restauración.
    4. Haz clic en Siguiente y sigue las instrucciones en pantalla para quitar el SP2 de Windows Server 2003.

    Un saludo

    jueves, 15 de enero de 2009 17:31
    Moderador
  •  unixzoo Escribió:

    Muchas gracias Alonso, lo voy a probar y te comento como me fue.

     

    Aunque pensando en la primera opción que me das, no crees que me dé el mismo error que cuando lo ejecuto desde "agregar y quitar programas"?, de cualquier forma lo prueba y te comento que pasa.

     

    Saludos.

     



    Es muy probable de que te responda igual que si lo haces desde "Agregar o quitar programas", pero también es posible que sólo sea una desasociación entre appwiz.cpl y el desinstalador del SP2, por ello te he dado también esa primera opción.

    Espero tus resultados, un saludo!
    jueves, 15 de enero de 2009 17:50
    Moderador

Todas las respuestas

  • Descartando la opción de agregar y quitar programas... prueba con alguna de las siguientes 2 opciones:

    Utilizar la carpeta oculta $NtServicePackUninstall$

    1. Haz clic en Inicio y en Ejecutar, escribe c:\windows\$NtServicePackUninstall$\spuninst\spuninst.exe en el cuadro Abrir y haz clic en Aceptar.
    2. Cuando se inicie el Asistente para desinstalación del Service Pack 2 de Windows Server 2003 (Windows Server 2003 Service Pack 2 Removal Wizard), haz clic en Siguiente.
    3. Sigue las instrucciones en pantalla para quitar el SP2 de Windows Server 2003.

    Utilizar el proceso Restaurar sistema

    1. Haz clic en Inicio y en Ejecutar, escribe %raízSistema%\System32\restore\rstrui.exe en el cuadro Abrir y haz clic en Aceptar.
    2. Haz clic en Restaurar mi equipo a un estado anterior y, a continuación, en Siguiente.
    3. Haz clic en la fecha en la que se instaló el SP2 de Windows Server 2003 y haz clic en Se instaló Windows Server 2003 Service Pack 2 en el cuadro Punto de restauración.
    4. Haz clic en Siguiente y sigue las instrucciones en pantalla para quitar el SP2 de Windows Server 2003.

    Un saludo

    jueves, 15 de enero de 2009 17:31
    Moderador
  • Muchas gracias Alonso, lo voy a probar y te comento como me fue.

     

    Aunque pensando en la primera opción que me das, no crees que me dé el mismo error que cuando lo ejecuto desde "agregar y quitar programas"?, de cualquier forma lo prueba y te comento que pasa.

     

    Saludos.

     

    jueves, 15 de enero de 2009 17:38
  •  unixzoo Escribió:

    Muchas gracias Alonso, lo voy a probar y te comento como me fue.

     

    Aunque pensando en la primera opción que me das, no crees que me dé el mismo error que cuando lo ejecuto desde "agregar y quitar programas"?, de cualquier forma lo prueba y te comento que pasa.

     

    Saludos.

     



    Es muy probable de que te responda igual que si lo haces desde "Agregar o quitar programas", pero también es posible que sólo sea una desasociación entre appwiz.cpl y el desinstalador del SP2, por ello te he dado también esa primera opción.

    Espero tus resultados, un saludo!
    jueves, 15 de enero de 2009 17:50
    Moderador