none
Salto de linea entre instrucciones en Procedimientos Almacenados SQL Server 2012 RRS feed

  • Pregunta

  • Hola Amigos;

    MI consulta es la siguiente:

    Tengo SLQ server 2012 y al trabajar con procedimientos almacenados se presenta  demasiados saltos de linea (20 o 30 espacios en blanco) entre instrucciones


    Al tratar de hacer un mantenimiento a mi procedimiento almacenados tengo que estar borrando los espacios en blanco, modificar y al grabar nuevamente el SP, otra vez se generan los saltos de linea entre instrucciones, a veces 25 a 30 saltos de linea por instrucción;

    Podría alguien ayudarme;

    Muchas gracias a Ustedes por su aporte

    Gustavo Paucar

    Quito - cuador

    martes, 28 de julio de 2015 16:08

Respuestas

  • Hola,

    Como te han comentado, sucede esto al tratar de modificar el SP y obtienes el resultado en Grid.

    Puedes hacer esto:

    1. Presiona previamente Ctrl+T (Resultado a Texto).

    2. Ejecuta sp_helptext TuStoredProcedure

    3. Copia el resultado.

    4. Presiona Ctrl+D (Resultado a Grilla).

    Ahora si no deseas estar haciendo siempre eso, puede configurar Management Studio para que siempre te retorne el resultado en forma de Texto:

    1. Tools-> Options-> Query Result-> Selecciona Results To Text.

    Saludos!


    Ayacucho - Perú
    Recuerda si mi solución atiende tu consulta por favor márcala como útil y como respuesta.

    http://litigiouslobo.blogspot.com/
    El Blog de Herbert Mendoza

    martes, 28 de julio de 2015 17:06
  • como buena practica también puedes poner en management studio sobre tu sp, botón derecho modify. y evitas eso

    Comparte lo que sepas, aprende lo que no sepas (FGG)
    portalSQL
    El rincón del DBA

    martes, 28 de julio de 2015 18:51
    Moderador

Todas las respuestas

  • Hola Gustavo Paucar,

    ¿Podrías explicarnos en que consiste tu proceso de "grabar la consulta"? 

    martes, 28 de julio de 2015 16:23
  • Yo llegue a tener un problema parecido, y era que cada vez que actualizaba un store procedure se agregaba un salto de linea entre cada instrucción.

    Desconosco la causa del problema, pero lo que hice fue obtener los store procedures desde el Management Studio, con sp_helptext [storeprocedure] pero indicándole que quiero los resultados en texto (puedes obtener 3 tipos de salidas de resultados, grid, texto y archivo), al hacer esto, los espacios que antes quitaba a mano desaparecieron.

    No fue una solucion de raiz pero me ayudo con el problema


    Ing. Carlos Monroy MCP, MCAD, MCSD, MCTS

    martes, 28 de julio de 2015 16:37
  • Saludos parece un error más de SSMS que de sql server, podrias restrablecerlo a valdores por default, no tendras algun add on que pueda estar haciendo este cambio?.  
    martes, 28 de julio de 2015 16:40
  • Hola,

    Como te han comentado, sucede esto al tratar de modificar el SP y obtienes el resultado en Grid.

    Puedes hacer esto:

    1. Presiona previamente Ctrl+T (Resultado a Texto).

    2. Ejecuta sp_helptext TuStoredProcedure

    3. Copia el resultado.

    4. Presiona Ctrl+D (Resultado a Grilla).

    Ahora si no deseas estar haciendo siempre eso, puede configurar Management Studio para que siempre te retorne el resultado en forma de Texto:

    1. Tools-> Options-> Query Result-> Selecciona Results To Text.

    Saludos!


    Ayacucho - Perú
    Recuerda si mi solución atiende tu consulta por favor márcala como útil y como respuesta.

    http://litigiouslobo.blogspot.com/
    El Blog de Herbert Mendoza

    martes, 28 de julio de 2015 17:06
  • como buena practica también puedes poner en management studio sobre tu sp, botón derecho modify. y evitas eso

    Comparte lo que sepas, aprende lo que no sepas (FGG)
    portalSQL
    El rincón del DBA

    martes, 28 de julio de 2015 18:51
    Moderador
  • No he podido solucionar este inconveniente, pero use la siguiente alternativa

    remplazar "^p^p" por "^p"  una vez copiado a Word.

    Saludos....

    martes, 27 de octubre de 2015 21:43