locked
Administrador de Ventanas RRS feed

  • Pregunta

  • Hola a todos,

     

    "El administrador de ventanas de escritorio esta experimentando una contencion intensa de recursos". "Los recursos del susistema de graficos se estan usando en exceso". "Se detecto una degradacion aguda en la capacidad de respuesta del administrador de ventanas de escritorio".

     

    Este mensaje me sale dos tres veces al dia en el visor de sucesos.

     

    Sin embargo yo no veo que ni la cpu ni la gpu trabajen en exceso, ni tampoco soy capaz de percibir ninguna ralentizacion.

     

    Alguien sabe que esta pasando?, esta  apunto de reventar alguna cosa?

     

    Gracias y un saludo para todos.

    miércoles, 24 de septiembre de 2008 10:47

Respuestas

  • Yo tengo 4 monitores, con dos nVidia ... y no he tenido ningun problema... y no apago la maquina nunca... :-P

    Un saludo,
    miércoles, 24 de septiembre de 2008 18:43

Todas las respuestas

  •  

    mmm que antivirus tienes??? podria estar dando problemas....

     

    La verdad que es raro que falle el administrador de ventanas....devezencuando mira en el administrador de tareas el proceso dwm.exe y mira si sus niveles son "normales", recuerda que este proceso aumenta proporcionalmente a las ventanas que tengas abiertas..osea que muchas ventanas abiertas, mas chupa el administrador de ventanas...

     

    Si quieres mas info detallada, bajate la suite de sysinternals y abre el process explorer que te da info muy detallada

    el link: http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx   (este es el process) y la suite entera: http://technet.microsoft.com/en-us/sysinternals/0e18b180-9b7a-4c49-8120-c47c5a693683.aspx  (abajo del todo esta para descargar!).....hablando de la suite, yo todavia tengo la version antigua...aver si bajo esta tambien XD

     

    Aver que dice Jose Manuel....

     

    Por cierto..paquetes de codecs no tienes ninguno raro no??

     

    Saludos!!

    miércoles, 24 de septiembre de 2008 11:26
  • Hola molpiiii,

     

    No me falla en absoluto el administrador de ventanas (al menos hasta hoy), simplemente veo este suceso en Visor de sucesos/Registro de aplicaciones y servicios/Microsoft/Windows/Diagnostics-Performance, que ademas de esta informacion -en la rama de windows- hay un monton de informaciones interesantes, como por ejemplo a que hora y duracion se ha hecho backup, tiempo de cierre y de arranque de windows en milisegundos, etc, etc, etc.

     

    Ya lo he mirado con el process explorer y tampoco veo nada especial, ni siquiera en el tiempo de proceso de la aplicacion.

     

    Quizas lo que detecta el visor de sucesos son situaciones muy muy puntuales de actividad, pues tengo una pantalla con resolucion 1920x1200 y la otra 1680x1050, por supuesto con el Aero en marcha y un monton de programas funcionado.

    Para eso y otras cosas, estoy usando Vista 64 bits con Intel Quad 9450, 8GB de Ram y  2TB en Raid10 de disco, que hay cosas mas potentes por ahi, pero creo que esto es mas que suficiente.

     

    Como te he comentado antes tanto la CPU como la GPU (grafica Asus 3870 TOP) estan bailando siempre entre 0,1,2% de actividad, excepto -obviamente- en casos concretos de actividad como por ejemplo una busqueda, arranque etc, donde normalmente la CPU esta sobre el 30% de actividad y la GPU nunca la he visto mas alla de un 15% (no juego).

     

    Respecto a codecs, contextuales, etc, estoy todo lo virgen que se puede estar, los tengo controlados, primero por que no uso y segundo por que sigo el tema a traves de Gspot (tengo 79 codecs instalados)

     

    Y tampoco uso anti-virus, nunca he usado ninguno...Je..Je, y tampoco hasta ahora (cruzo los dedos) nunca he pillado ninguno, en cualquiera de los 4 PC's de mi pequeña red.

     

    Un saludo para todos.

     

     

     

    miércoles, 24 de septiembre de 2008 12:26
  •  Xavier_23 Escribió:

    Alguien sabe que esta pasando?, esta  apunto de reventar alguna cosa?


    Pues si: por desgracia el tamaño reservado para el "heap" de la parte grafica lo tienes alcanzando el limite... ¿multipels monitores? ¿software que simula multiples monitores?...

    Hay un articulo muy bueno de Mark Russinovich sobre esto... mira a ver si lo localizas...

    Un saludo,
    miércoles, 24 de septiembre de 2008 13:09
  • Hola Jose manuel,

     

    Gracias por contestar.

     

    Si, como me temia el tema probablemente viene de ahi, dos monitores 1920x1200, 1680x1050, en escritorio extendido.

     

    Pero vamos, hoy en dia es perfectamente normal, no puedo creer que Vista no sea capaz de manejar esto con soltura.

     

    ¿Me puedes dar alguna referencia adcional de ese articulo?, pues por mas que lo busco no lo encuentro, y eso que como ya te he comentado en ateriores ocasiones, me gusta mucho seguir los articulos del blog de Mark Russinovich.

     

    Un saludo para todos.

     

     

    miércoles, 24 de septiembre de 2008 17:08
  •  Xavier_23 Escribió:

    Pero vamos, hoy en dia es perfectamente normal, no puedo creer que Vista no sea capaz de manejar esto con soltura.


    Te maneja perfectamente dos y cuatro,,, y los que quieras. La pega es la posible utilidad del driver para manejo de estos (que no hace falta)... y que normalmente están mal hechas... ¿que driver y que "utilidades" tiene?

    Un saludo,
    miércoles, 24 de septiembre de 2008 17:18
  • Hola Jose Manuel,

     

    Para el escritorio extendido no manejo ningun driver especial (que yo sepa), lo hace el propio Windows....a menos que el Catalyst lo anule.

     

    Saludos.

     

     

    miércoles, 24 de septiembre de 2008 17:59
  • Probablemente el Catalyst.

    Estoy desde hace tiempo alejado de ATI... ¿como es su driver?... solo un dirver o un programa que instala vete a saber qué? Supongo que te deja un icono en el systray... por tanto es un programa residente y puede que algo m+as, un sericio, etc, y no solo el driver.... y una cosa, deja en alguna carpeta los .inf?... porque lo normal sería desistalar todo de ATI... y luego instalar solo el driver desde el Administrador de dispositivos apuntando a la carpeta que tiene los .inf

    Un saludo,
    miércoles, 24 de septiembre de 2008 18:03
  • Hola Jose Manuel,

     

    Puede ser, puede ser.....lo tengo en observacion, peroooo......he buscado por la knowledge base y tambien con google y me he encontrado que el problema del "desktop heap size" no es inusual en Vista, especialmente con muchas aplicaciones, ventanas, escritorios, resolucion, aero, etc, etc

     

    Me he leido la kb  http://support.microsoft.com/kb/947246/en-us, donde se explica la mod para aumentar el heap y aunque dice no sobrepasar 20480 kb (default en Vista 64), pues puede disminuirse el rendimiento, dado que la kernel memory no puede sobrepasarse ya que esta limitada a 1GB. Tambien he leido en otra parte que la kernel memory de Vista x64 es dinamica y no fija como en 32.

     

    Total que he exportado la clave del registro en cuestion y me la he guardado, restore point al canto y he aumentado a 30720 kb la desktop heap size (un 50%).

     

    Inicio....y de momento ya no ha vuelto a salir el problema durante 20 minutos y especialmente en el arranque salia siempre......veremos....veremos....

     

    Un saludo para todos.

     

    miércoles, 24 de septiembre de 2008 18:18
  • Yo tengo 4 monitores, con dos nVidia ... y no he tenido ningun problema... y no apago la maquina nunca... :-P

    Un saludo,
    miércoles, 24 de septiembre de 2008 18:43
  • Has mirado en: Visor de sucesos/Registro de aplicaciones y servicios/Microsoft/Windows/Diagnostics-Performance, si tienes algun mensaje de bajo rendimiento del subsistema grafico?

     

    He leido en alguna parte, que al usar dos tarjetras graficas, Vista asigna a la segunda grafica lo mismo que a la primera, es decir se duplican los recursos y eso podria ser la explicaion de que a mi pase y a ti no....lo digo con reservas pues ahora no me acuerdo donde lo lei.

     

    Yo solo uso una tarjeta para los dos monitores.

     

    Si el problema sigue es otra opcion que estoy considerando.

     

    Un cordial saludo para todos.

    miércoles, 24 de septiembre de 2008 19:20
  •  Xavier_23 Escribió:

    Has mirado en: Visor de sucesos/Registro de aplicaciones y servicios/Microsoft/Windows/Diagnostics-Performance, si tienes algun mensaje de bajo rendimiento del subsistema grafico?

     

    He leido en alguna parte, que al usar dos tarjetras graficas, Vista asigna a la segunda grafica lo mismo que a la primera, es decir se duplican los recursos y eso podria ser la explicaion de que a mi pase y a ti no....lo digo con reservas pues ahora no me acuerdo donde lo lei.


    No. No hay mensajes raros. Y eso que duplica recursos ¿te refieres a que usa los mismos recursos de direcciones de memoria, IRQ, etc?... pues no. De todas formas en este sentido windows Vista "no fuerza nada" sino que usa las tablas que le dice la Bios para intentar guardar la maxima compatibilidad con drivers "dudosos". Unicamanete los sistemas server reasignan recursos a su gusto.

    Un saludo,
    miércoles, 24 de septiembre de 2008 19:49
  • Hola Jose Manuel, no te he podido responder antes por que he estado de viaje.

     

    Lo de duplicar recursos evidentemente me he explicado muy mal. Me refiero a que cuando en Vista se introduce una segunda grafica, el sistema le asigna unos nuevos recursos iguales que los asignados a la primera grafica, pero no los mismos.

     

    Respecto a mi problema ya lo he solucionado y como siempre con tu solucion o en este caso inspiracion.

     

    No era el Heap, pues aunque en Vista x64 no he sido capaz de encontrar una utilidad para medirlo (si la he encontrado en Microsoft para Vista 32), me he dedicado a ir aumentando el Heap y he comprobado que por mas que lo aumente el fallo sigue presente, incluso he llegado al punto de ralentizar el sistema.

     

    Entonces siguiendo tu mensaje de que el Catalyst podria ser, pues tampoco era, lo he probado. Entonces que puede ser?, pues no me voy a quedar sin drivers.

     

    Se me ocurrio que en lugar de usar el driver+Catalyst de ATI, podria usar directamente los del fabricante de la grafica(ASUS), que tambien son ATI, pero probablemente con alguna midificacion.

     

    Total que he instalado el ultimo Catalyst de ASUS-ATI y su correspondiente driver y final del problema.

     

    Gracias por la inspiracion.

     

    Saludos.

     

    lunes, 29 de septiembre de 2008 17:59
  •  Xavier_23 Escribió:

    Total que he instalado el ultimo Catalyst de ASUS-ATI y su correspondiente driver y final del problema.


    De todas formas... estos fabricantes a veces tocan lo que no deben... que si lo dejasen estandar no tendriamos estos problemas... :-P

    Me alegro.

    Un saludo,
    lunes, 29 de septiembre de 2008 20:37
  • Totalmente de acuerdo.

     

    Los consumidores de soft deberiamos ser mucho mas exigentes con la baja calidad de una buena parte del soft.

     

    Pero no parece que entos momentos haya ningun medio para canalizar esa exigencia.

     

    Cuando hay un problema se le carga el muerto al sistema operativo de turno (que tambien tiene sus errores, pero muchos menos) y listo!........aparentemente, porque el problema lo seguimos padeciendo.

     

    Saludos.

     

    martes, 30 de septiembre de 2008 8:46
  •  Xavier_23 Escribió:

    Cuando hay un problema se le carga el muerto al sistema operativo de turno (que tambien tiene sus errores, pero muchos menos) y listo!........aparentemente, porque el problema lo seguimos padeciendo.

     

    No te creas que tiene errores.. o esto son minimos y se corrigen con los parches (que al fin y al cabo, nos quejamos de  él, y resulta que MS es el unico serio que tiene todo un equipo de desarrollo dedicado a eso).

     

    Es curioso, pero esto me ha recordado hace un par de años, que en una tienda de montaje de ordenadores (clonicos) un dia les llamé la atención por montar una memoria no compatible en sus equipos con la placa madre y cpu. La respuesta del "tecnico" fué: ya lo se... pero da pocos pantallazos azules y es barata... y cuando alguien se queje le echamos la culpa a windows y ya está.   :-P   ¿y que les haces?... porque no hay mecanismos de queja en ese sentido...

     

    Un saludo,

     

     

    martes, 30 de septiembre de 2008 9:08
  • 100% de acuerdo.

     

    Lo dicho, no hay mecanismos de queja.

     

    Las revistas del sector podrian ser un medio, pero estan demasiado "biased" (condicionadas) con las marcas.

     

    Sin embargo, no deja de extrañarme que no existan algunas web's que canalicen esto, al menos yo no las conozco.

     

    O quizas la gran mayoria del personal se encuentra en otra galaxia y no tenga practicamente quejas. Lo cual tambien es probable.

     

    Saludos.

     

    martes, 30 de septiembre de 2008 14:04
  •  Xavier_23 Escribió:

    Sin embargo, no deja de extrañarme que no existan algunas web's que canalicen esto, al menos yo no las conozco.

     

    O quizas la gran mayoria del personal se encuentra en otra galaxia y no tenga practicamente quejas. Lo cual tambien es probable.


    Un poco de todo: las web serias ya no existen: alguien publica algo y sea verdad o mentira se multiplica la noticia por la red.. nadie comprueba la veracidad... es triste.

    Un saludo,
    sábado, 4 de octubre de 2008 21:11