none
Excel. SUMAR.SI.CONJUNTO. ¿Puedo incluir la formula O? RRS feed

  • Pregunta

  • Hola a tod@s. Gracias de antemano por vuestra atención.

    Tengo Office 365 y quiero incluir la fórmula O dentro de SUMAR.SI.CONJUNTO. ¿Se puede? No lo logro.

    Explico lo que quiero conseguir:

    Tengo Vendedores, Productos y Ventas.

    Quiero conseguir el total por vendedor, producto y venta según día de la semana (Lunes - Viernes; Sábado - Domingo); por la fecha de venta obtengo el día de la semana (1-Domingo, ..., 7-Sábado)

    Utilizando la fórmula

    SUMAR.SI.CONJUNTO($G$3:$G$16;$A$3:$A$16;"Vendedor";$C$3:$C$16:"Producto";$F$3:$F$16;"Día de la semana")

    Colocando en "Día de la semana" el número del dia (1 a 7), la fórmula funciona, pero yo quiero poner una fórmula que me controle los días, por ejemplo: $F$3:$F$16;<5

    ¿Es esto posible?

    De nuevo, gracias y salu2.

    jueves, 20 de diciembre de 2018 15:27

Todas las respuestas

  • Javier,

    Buen día, la condición que necesitas si la puedes colocar en la función que indicas. Solo ten en cuenta que el signo < no es numero, entonces la sintaxis es:

    SUMAR.SI.CONJUNTO(.......;$F$3:$F$16;"<" & 5)

    Saludos.

    Francisco Diez.


    Saludos. Francisco Diez.

    jueves, 20 de diciembre de 2018 19:52
  • Hola, Francisco. Muchas gracias por tu información.

    Efectivamente, al utilizar la información que me has indicado:

    ;"<" & 6) la suma buscada da un total de 11.

    Sin embargo, al sustituirla por:

    ;O("=" & 1; "=" & 2; "=" & 3; "=" & 4; "=" &5)) la suma da CERO.

    He probado, por curiosidad, a cambiar O por Y, pero la suma sigue siendo 0.

    Por eso mi pregunta es si se puede utilizar la instrucción O.

    Necesitaría poner días alternos. Por ejemplo: 1 y 4

    ¿Se te ocurre alguna solución?

    De nuevo, muchas gracias por tu ayuda.

    Saludos.

    lunes, 24 de diciembre de 2018 8:23
  • Javier,

    Hola, lo que sucede es que excel está evaluando primero la función anidada:

    o("=" & 1; "=" & 2; "=" & 3; "=" & 4; "=" &5)

    Si lo que buscas es sumar valores con días alternos, puedes utilizar formulas matriciales:

    =SUMA((($F$3:$F$16=1)+($F$3:$F$16=6))*($A$3:$A$16="Vendedor")*($C$3:$C$16="Producto")*($G$3:$G$16))

    Para que la formula sea matricial en modo edición presiona la combinación de teclas ctrl+shift+enter


    Saludos. Francisco Diez.

    miércoles, 26 de diciembre de 2018 16:22