none
Problema DNS, el servidor no se encuentra a si mismo. RRS feed

  • Pregunta

  • Hola, buenas tardes:

    Tengo un problema con el servidor DNS, y si alguien sabe la solución, le agradecería mucho que me alludara.

    El problema es que tengo en un servidor Windows 2008 server standard edition de 32 bits. El nivel funcional del dominio es el de windows 2008. Tengo instalado el servicio servidor DNS, y tengo creadas las zonas de busqueda directa, y de busqueda inversa, con registros de host creados, tanto en una como su puntero asociado en la otra. Mi problema es que los clientes, si yo hago un nslookup, encuentran perfectamente el servidor, pero lo curioso es que si hago ese mismo nslookup en el servidor, me dice desconocido y dirección ::1. Si hago un nslookup dirección IP, me resuelve dos direcciones:

    nslookup 192.........(por ejemplo)

    servidor: LocalHost

    Address:     ::1

    servidor: nombre equipo.mi dominio (Todo correcto)

    Address: 192.........(Tambien correcto)

    nslookup midominio

    servidor: LocalHost

    Address:     ::1

    Nombre: Mi dominio (Correcto)

    Address: servidor mio DNS (Correcto)

     

    nslookup nombre completo equipo, es decir nombre equipo.mi dominio

    servidor: LocalHost

    Address:     ::1

    Nombre:     Nombre completo de equipo (correcto)

    Address: Dirección IP de mi servidor DNS (correcto)ç

    Con un simple nslookup, sin nada mas, el resultado es:

    servidor: LocalHost

    Address:     ::1

    Es curioso, porque si voy a la consola de DNS, y le doy a ejecutar un nslookup, lo resuelve bien, es cuando abro un cmd, que no lo hace. He probado a borrar la cache y los registros obsoletos, tanto desde la consola de DNS, como desde cmd con ipconfig /flushdns. He vuelto a crear la zona de busqueda inversa, y volver a meter los host, ya que es una red pequeña, tanto en la zona directa, como en la iversa con el ptr.

    Realmente este problema en la red local, no me esta afectando mucho por ahora, ya que como digo los clientes, se pueden conectar al servidor. Pero el problema, es mas, si intento entrar a la oficina por vpn. Tengo puesto en enrutamiento y acceso remoto, que las ip sean dinamicas, y que sea el servidor dhcp, que es el mismo, el que asigne las direcciones, ya que lo he agregado en el agente de retransmisión. Pero claro, como el servidor digamos que no se encuentra, cuando el cliente VPN, se conecta, solo se puede autoasignar una dirección apipa. Vamos, yo creo que es por eso, pero no lo se. Lo primero, es que pregunto si puede ser de eso, y si lo es, si hay alguna solución, que no pase por cambiar el nombre del servidor, o el dominio o algo así, porque ya tengo instalada una entidad certificadora, así que no me permitiría hacer eso.

    Bueno en fín agradecería mucho una ayuda.

    Un saludo.

    Álvaro

    miércoles, 20 de abril de 2011 18:22

Respuestas

Todas las respuestas