none
Error Databse Engine 2008 RRS feed

  • Pregunta

  • Hola, la verdad es que me gustaría que me ayuden con este tema tnego un problema con la conexion al sql express 2008 y es que he tratado con todo lo que conozco y he buscado ayuda pero aún no encuentro con la solución.
    He instalado el SQL 2008 sin clusters y soy el administrador del equipo.

    Al tratar de probar un servidor me sale:

    Testing the registered server failed. Verify the name, credentials and database and then click test again.
    Additional Information:
    A network-related or instance specific error ocurred while establishing a connection to SQL server. The server was not found or was not accesible. Verify that the instance name is correct and that the SQL server is configured to allow remote connections(Provider: named pipes provider, error: 40 -Could not open a connection to SQL server)(Microsoft SQL server, Error: 53)

    Supongamos que ingreso un servidor sin probarlo y trato de ingresar por cualquier auntenticacion t las conexiones en default y me sale:

    Cannot connect to logos69.(Nombre de mi supuesto servidor creado)
    Additional information:
    A network-related or instance specific error ocurred while establishing a connection to SQL server. The server was not found or was not accesible. Verify that the instance name is correct and that the SQL server is configured to allow remote connections(Provider: named pipes provider, error: 40 -Could not open a connection to SQL server)(Microsoft SQL server, Error: 53)(Esto pero en español)

    Ademas al tratar de configurar el sql server configuration manager:
    En la opcion sql server services: ""No hay elementos disponibles a la vista"
    En la opcion sql server network configuration me sale : "No hay elementos disponibles a la vista"
    En la opcion Sql Native client configuration: las propiedades de todos los protocolo de accesos estan activos

    Además ningun firewall niega el acceso a internet. Osea, no esta activo.

    Agradezco su ayuda.
    viernes, 22 de mayo de 2009 15:19

Respuestas

Todas las respuestas

  • Hola Joel. Todo parece indicar que el servicio de SQL Server Engine no quedó instalado. Verifica que efectivamente esté instalado y que el servicio esté corriendo.

    Para ello ve a la opción de Services de Windows y verifica que el servicio de SQL Server se encuentra allí y está corriendo. Si no es así, quedó mal instalado SQL Server

    Revisa eso y miramos cómo más te puedo ayudar!!!
    Alberto Rivera alberto@intermezzo-bi.com Intermezzo BI Lead http://www.intermezzo-bi.com
    viernes, 22 de mayo de 2009 15:27
  • Hola agradezco tu interes por mi problema pero la verdad es que me gustaría que me indiques con una mayor precision el como llegar a la opcion services de windows y como ver si esta o no instalado el servicio SQL server Engine.
    P.D.1:Uso el windows Vista.
    P.D.2:Perdon por tener la cabeza tan dura!
    saludos.
    sábado, 23 de mayo de 2009 4:16
  • Hola que tal.

    En la barra de búsqueda de Windows escribe services.msc. Y ahi busca el servicio de SQL Server.
    Alberto Rivera alberto@intermezzo-bi.com Intermezzo BI Lead http://www.intermezzo-bi.com
    sábado, 23 de mayo de 2009 12:07
  • Hola ya lo vi y nop....nada de nada nada que diga SQL o SQL server.
    y Ahora??
    sábado, 23 de mayo de 2009 14:30
  • Hola. Nada que hacer. No está instalado. Intenta instalarlo nuevamente. Si tienes problemas con el instalador, descargalo de aca

    SQL Server Express 2008: http://www.microsoft.com/downloads/details.aspx?FamilyId=B5D1B8C3-FDA5-4508-B0D0-1311D670E336&displaylang=en
    SQL Server 2008 Express SP1: http://www.microsoft.com/downloads/details.aspx?FamilyID=01af61e6-2f63-4291-bcad-fd500f6027ff&displaylang=en

    Importantisimo instalar el SP1, te puede ahorrar problemas de compatibilidad!!!!

    Si tienes dudas en cómo instalarlo: http://msdn.microsoft.com/en-us/library/ms143219.aspx

    Me cuentas cualquier cosa
    Alberto Rivera alberto@intermezzo-bi.com Intermezzo BI Lead http://www.intermezzo-bi.com
    • Marcado como respuesta joelRam90 domingo, 24 de mayo de 2009 2:59
    sábado, 23 de mayo de 2009 15:12
  • La verdad me parece extraño lo he instalado y re instalado y asi y weno ...supongo q seguire tus instrucciones....aver como me va gracias a dios no tengo mucho apuro ya que tengo un par de semanas libres ...
    sábado, 23 de mayo de 2009 15:18
  • Hola, ya lo trate de instalar y me he dado cuenta de que es otro pack aun mas pesado el que me asiganaste. Bueno y al tratar de instalarlo(ya un par de veces)me sale este error:

    The MOF compiler could not connect to the WMI server. This is either because of a semantic error such as an incompatibility with the existing WMI repository or an actual error such as the failure of the WMI server to start.

    Traducido sería:

    El compilador MOF no se pudo conectar al servidor WMI. Esto puede ser por un error semantico como un incompatibilidad con el el repositorio WMI existente o un error real como la falla del servidor de la WMI para iniciar.

    Otra pregunta, seria mejor primero instalar el service pack??

    Gracias.
    sábado, 23 de mayo de 2009 22:12
  • Por fin!!
    Ya lo isntale, primero instale el service pack y me funciona de mail maravillas agradezco mucho tu ayuda!!!

    Como un pequeño detalle, exsiten tantas versiones del sql express disponibles en microsoft que uno se marea deberían poner un mayor enfasis en esto!
    domingo, 24 de mayo de 2009 2:58
  • Saludos

     

    Tengo exactamente el mismo problema, por favor me podrias ayudar indicandome el detalle de como lograstes resolverlo. estaria muy agradecido.

     

    walterfalla@gmail.com

     

    _Gracias..!!!

    martes, 31 de agosto de 2010 20:28
  • Hola.

    Sigue las instrucciones expuestas en el hilo (en este caso, instalar el SP1). Si no lo logras, quizá sea mejor que inicies un nuevo hilo exponiendo tu caso, los errores que recibes, etc.


    Alberto López Grande
    SQL Server MVP
    Visita mi blog en http://qwalgrande.blogspot.es/

    martes, 31 de agosto de 2010 20:37
    Moderador
  • Hombre,sucedio hace un año y no recuerdo muy bien como lo hice. Eso si revisa cada opción y cada programa instalado con el SQLExpress.Especialmente los administrativos ya que te permiten agregar usuarios y manejar las conexiones. Mmmm, en la raiz de los servidores tu también puedes agregar usuarios dentro del mismo Express. Revisa las recomendaciones de este hilo y apuesto que tu problema se solucionará!

    Saludos

    jueves, 2 de septiembre de 2010 20:29