none
No se ejecuta parte del código Visual Basic para Aplicaciones en Access 2010 RRS feed

  • Pregunta

  • Sres. se me ha presentado el siguiente problema:

    He creado una base de datos en Access 2007, utilizo código de Visual Basic para Aplicaciones. La base de datos está compartida y es accedida por varios puestos de trabajo. En realidad, la primera versión estaba diseñada en la version 2003 de Access, el tema de los usuarios es usando los perfiles de usuario que el mismo access deja utilizar. Posteriormente comenzaron a instalar el Office 2007 y mas tarde el Access 2010.

    El primer problema fue que al abrir la base de datos desde una pc con Access 2010, se perdia el código de VBA o se perdían las referencias a las librerias y bibliotecas que necesita el VBA; investigando un poco el tema lo corregí habilitando las opciones del centro de confianza. Por las dudas, hice instalar la misma version de Windows y Office en todas las maquinas que debian utilizar la base de datos en cuestión. 

    El problema que se presenta es que a pesar de instalar la misma versión de Windows 7 y Office 2010 en las pc que lo utilizan, y de tomar los recaudos de configurar de la misma manera el Access y sus opciones del centro de confianza; en algunas máquinas funciona a la perfección, pero en otras hay cosas que no funcionan y ni siquiera me tiran un error, directamente no responden; es más, lo único que no funciona en algunas maquinas es un treeview desde el que se muestra un árbol de componentes de las máquinas de producción.

    El problema ya se ha vuelto tedioso, pues los usuarios tienen que estar desplazandose a pcs en donde el sistema no tiene problemas para tener acceso a la base de datos.

    Por favor, desarrolladores de Access de Microsoft, ayúdenme!!

    Desde ya muchas gracias.

    David Ludueña

    Analista de Sistemas

    david_luduena@hotmail.com

    miércoles, 24 de octubre de 2012 20:00

Respuestas

  • Hola!

    Microsoft decidió hace tiempo eliminar la mayoría de controles ActiveX, lo hace mediante una serie de actualizaciones llamadas killbits, por ello es posible que según el estado de actualizaciones de unos equipos u otros te funcionen o no los treeviews.


    Saludos a todos desde Huelva
    http://www.mvp-access.es/emilio/

    • Marcado como respuesta Uriel Almendra martes, 23 de abril de 2013 14:51
    miércoles, 24 de octubre de 2012 20:18

Todas las respuestas

  • Hola!

    Microsoft decidió hace tiempo eliminar la mayoría de controles ActiveX, lo hace mediante una serie de actualizaciones llamadas killbits, por ello es posible que según el estado de actualizaciones de unos equipos u otros te funcionen o no los treeviews.


    Saludos a todos desde Huelva
    http://www.mvp-access.es/emilio/

    • Marcado como respuesta Uriel Almendra martes, 23 de abril de 2013 14:51
    miércoles, 24 de octubre de 2012 20:18
  • Gracias por tu aporte Emilio, no se pudo solucionar el problema. Se decidió por fin invertir y desarrollar un sistema.

    Suerte,

    David

    martes, 18 de junio de 2013 1:25