locked
No se reconoce como un comando interno o externo RRS feed

  • Pregunta

  • Hola a todos,

    tengo un wondows 7 x64 y me he dado cuenta que al ejecutar un script que tengo en remoto me sale lo siguiente:"xcopy" no se reconoce como un comando interno o externo,
    programa o archivo por lotes ejecutable.

    En principio me pasa con otros comandos del dos como el NET.

    He visto una posible solución para xp pero no sé si funcionará para w7 x64.

    ¿Alguien me puede ayudar?

    Gracias de antemano.

    miércoles, 12 de septiembre de 2012 13:31

Respuestas

  • Sería algo así: NET USE G: "\\192.168.0.214\TST"

    Quería comentar que he añadido lo siquiente la la variable entorno del path y funciona:

    C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;

    Lo que no tengo claro que sea muy correcto ya que otro compañero se acaba de cambiar ahora también el portátil y en el path el no tiene esas entradas y sí que le funciona el script

    ¿Es esa la solución?

    Gracias.

    miércoles, 12 de septiembre de 2012 15:50
  • Hola 

    Para ejecutar el NET, el windows utilizar el cmd.exe, entonces, solamente con el C:\WINDOWS\system32\ te funciona.

    Gracias.

    Saludos.


    Eduardo Portescheller - LATAM Forum Support Engineer
    Microsoft Corporation

    lunes, 17 de septiembre de 2012 15:38

Todas las respuestas

  • ¿Cómo es el comando, y de qué forma lo estás ejecutando?
    miércoles, 12 de septiembre de 2012 15:16
  • Sería algo así: NET USE G: "\\192.168.0.214\TST"

    Quería comentar que he añadido lo siquiente la la variable entorno del path y funciona:

    C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;

    Lo que no tengo claro que sea muy correcto ya que otro compañero se acaba de cambiar ahora también el portátil y en el path el no tiene esas entradas y sí que le funciona el script

    ¿Es esa la solución?

    Gracias.

    miércoles, 12 de septiembre de 2012 15:50
  • Hola 

    Para ejecutar el NET, el windows utilizar el cmd.exe, entonces, solamente con el C:\WINDOWS\system32\ te funciona.

    Gracias.

    Saludos.


    Eduardo Portescheller - LATAM Forum Support Engineer
    Microsoft Corporation

    lunes, 17 de septiembre de 2012 15:38