none
Me falla el workflow RRS feed

  • Pregunta

  • Buenas, necesito ejecutar un workflow que me indique 5 dias despues de creado un pedido, que ahorita hay que entregar el pedido o que me indique 5 dias antes de la fecha de entrega que faltan 5 dias para la entrega del pedido. El problema es que le he aplicado todos los filtros pero no se me ejecuta el workflow queda como en espera y nunca pasa nada. Abajo voy a adjuntar los parametros del workflow y como estan estructurados los filtros para que me puedan ayudar. La version que uso es CRM 2011 Online!

    Agradesco todo tipo de ayuda!

    jueves, 8 de diciembre de 2011 17:26

Todas las respuestas

  • Todo parece correcto, de hecho en el filtro final sólo haría falta la condición de comprobación de que el estado del pedido es Activo. ¿Podrías poner una captura de pantalla de alguna ejecución del workflow?
    viernes, 9 de diciembre de 2011 12:02
  • Muchas gracias Ignacio, lo que pasa es que como desactive el workflow se pierden las ejecuciones, pero el siempre se queda en espera en el segundo filtro y nunca llega al final! Y en donde me decis que falta la condicion de comprobacion de que el estado del pedido es activo?
    viernes, 9 de diciembre de 2011 14:21
  • por favor coloca un historial del flujo para ver con mas detalle loq ue te genera.

     

    saludos

    viernes, 9 de diciembre de 2011 17:44
  • No es que falte una condición, es que cuando acaba el tiempo de espera sólo hace falta comprobar si el estado del pedido sigue siendo activo (ha podido cambiar en los 5 días posteriores a la creación del pedido). No hace falta verificar que el tiempo de ejecución en ese momento del workflow ha pasado de los 5 días.
    lunes, 12 de diciembre de 2011 16:46
  • Hola Cristian Guapi, desde ya gracias por la ayuda, me imagino que el historial seria algo como asi:

    X cualquier cosa le cambie un poco el filtro con respecto a las primeras imagenes, pero el resultado es el mismo, no funciona y no entiendo porque????

     

     

     

     

     

     

     

     

    lunes, 12 de diciembre de 2011 17:20
  • Gracias Ignacio_camacho, pero es que casi no comprendo lo que me indicas podes ayudarme haciendo un ejemplo de como quedaria entonces???

     

    lunes, 12 de diciembre de 2011 17:22
  • hop, me referia a, en la entidad que esta corriendo el flujo o en el flujo mismo hay una opcion que dice Historial, el cual nos muestra donde fallo el flujo o donde esta correiendo y el estado de los mismos, ese me lo puedes pasar para revisarlo, gracias
    viernes, 16 de diciembre de 2011 14:38
  • Hola Crisitian Guapi, me fui al registro donde se debe ejecutar el wf y me sale sin registros en la seccion "Historial de auditoria"

     

    viernes, 16 de diciembre de 2011 17:39
  • Lo que quería decir es que una vez se pasa al filtro final, no hace falta comporbar que el tiempo de ejecución del workflow es un día después de la fecha de creación. Lo que no tiene lógica es que una vez pasado el tiempo de la condición de espera, se quede en esa situación. Puedes probar a pausar y reanudar el flujo, a ver que hace. De todas formas, también miraría los log de los servicios asíncronos. Hay algo raro en tu sistema.
    miércoles, 21 de diciembre de 2011 11:35