none
Fallo inicio VM sin HD externo conectado (Server 2019) RRS feed

  • Pregunta

  • Hola.
    Tengo un servidor en producción (Windows Server 2019) con dos Maquinas Virtuales. En una de las VM tengo añadido un disco usb para realizar backups. El proceso de montar un disco usb en un Windows invitado, salvo que se me indique lo contrario, es el soportado por el sistema. Es decir, una vez conectado el disco y reconocido por el windows anfitrión, se marca como offline, se añade a la VM y se pone en línea en la VM.
    Este HD ext. solo se conecta los viernes para realizar un backup y posteriormente se retira para guardar fuera de la oficina.

    El problema que tengo reside cuando se inicia el VM los lunes. La VM no inicia dando error si el HD ext. no está conectado.

    Todos los viernes en la VM el sistema realiza un backup (copia de seguridad de windows) en el HD ext. y posteriormente se apaga el windows anfitrión, apagando por configuración las VM's. 
    El usuario los lunes por la mañana enciende físicamente el servidor. La configuración de las VM's indica que se deben encender automáticamente.
    Si en el encendido de la VM el HD ext. no está conectado, la VM no inicia dando un error. 
    Probé a cambiar la configuración y que la VM guardase el estado en vez de apagar, pero el resultado es el mismo. Sin el HD ext. conectado, la VM arroja un error y no inicia.

    Por favor, pueden indicarme como solventar este fallo. El usuario quiere que el servidor se encuentre apagado el fin de semana y a la vez quiere que la copia de seguridad se realice el vienes antes del apagado para poder retirar el HD ext. ese mismo día o el sábado. 
    lunes, 28 de diciembre de 2020 11:26