none
W7 NO detecta los Discos duros usb pero SÍ los Pendrive RRS feed

  • Pregunta

  • Buenas. Me pasa algo muy raro desde hace unos días mi PC ha dejado de reconocer los discos duros y nunca había tenido problemas con esos mismos discos duros, he probado mil cosas y no sé que más puedo hacer. El problema es que mi PC no detecta los discos duros externos por USB, en cambio los Pendrive si. Sé que los discos duros están bien pues los he podido probar en otro PC y los reconoce inmediatamente. (el otro equipo tiene Windows XP). Asi que podemos descartar que los discos duros esten dañados o rotos.

    Los he probado en todos los puertos USB del PC y en ninguno lo detecta. Ni siquiera empieza la instalacion de un nuevo controlador típica de windows cuando se conecta algo nuevo al equipo.

    Los discos duros son de 400GB y 500GB y el Pendrive es de 1GB solo....Esto me da que pensar que tenga algo que ver con el tamaño de los discos.

    Tambien he actualizado la BIOS del sistema, desactivado y activado el soporte de los USB 2.0, formatee el ordenador y reinstale W7, pero nada.

     

    Sólo a veces me detecta el disco duro en el administrador de discos que tiene W7, pero me dice que es desconocido y que no esta inicializado. Buscando por la web leí que podía ser algo de que no asignaba letra al disco, pero es que en el estado que me detecta el disco no me deja ni siquiera hacer esa opción.

     

    A alguien se le ocurre alguna solución???

     

    jueves, 4 de noviembre de 2010 12:55

Respuestas

  • Me acabo de dar cuenta que respondí con mi otra cuenta la ultima vez (yerex_tf). Bueno el caso es que ya sé por que me pasó eso.

    Al ser discos de 2'5, toman la energía necesaria de los concentradores USB. Estos discos necesitan 5v como mínimo para funcioanar correctamente, y las concentradoras USB estan testeadas para dar esa energía y verifican un buen funcionamiento a estas tensiones. Pero, en la práctica, según la calidad del disco duro, éstos pueden solicitar picos de corriente, que superen esos 5 voltios. Las concetradoras USB se los suministran a pesar de que sus componenetes no soportan mas de 5 voltios para un funcionamiento optimo. Entonces Estos componentes que forman parte del concentrador se van deteriorando y con el tiempo acaban por dejar de funcionar. Pero recalco que lo que deja de funcionar es el concentrador, el puerto USB sigue funcionando correctamente. Pero no es capaz de suministrar los 5 voltios requeridos por los discos duros USB.

    Esto explica que los puertos sigan funcionando para dispositivos neutrales como pendrives, teclados, ratones y demás, pero no para los discos duros. Lo curiosos es la ni la placa madre ni el sistema Operativo logicamente se dan cuenta del fallo hardware.

    Desconozco si las placas actuales detectan este problema, la mia tiene ya unos añitos (+5) y ya les digo uqe no.. y creo que ninguna lo hace.

     

    Mi recomendación es comprar discos USB de 2'5 con fuente de alimentación adicional para evitar este problema o discos de 3'5 directamente (que sólo funcionan con fuente de alimentación).

    • Marcado como respuesta yerayvg domingo, 14 de noviembre de 2010 10:37
    domingo, 14 de noviembre de 2010 10:37

Todas las respuestas

  • Hola,

    Cuando los conectas dentro del Administrador de discos te los reconoce? Es decir, los visualiza? Además en el Administrador de dispositivos también los visualiza o no aparecen? Hay sonido de reconocimiento?

    Saludos,


    Sergio Calderón | Microsoft Student Partner Senior
    jueves, 4 de noviembre de 2010 13:10
    Moderador
  • Mejor te lo pongo con imagenes.

    Cuando conecto el disco duro, hace el sonido típico de que se ha conectado un nuevo dispositivo, pero no se lanza nada y por supuesto en Mi PC no aparece la unidad de disco correspondiente. Si voy al administrador de discos lo que muestra es lo siguiente:

    http://img192.imageshack.us/i/66035061.png/

    Si le doy a aceptar, muestra el siguiente mensaje:

    http://img696.imageshack.us/i/28701669.png/

     

    EDITO: Es curioso también que esto solo me sale con uno de los discos. El otro ni siquiera es detectado por el administrador de discos aunque Windows si detecta que hay algo conectado pues hace el sonido de conexión y desconexión tipicos.

    Concretamente este segundo disco (el de 500GB) es un Wester Digital y la primera vez que lo conecte Windows se bajo un "driver" Initio Default Controller, pero no sirvió de nada.

    • Editado yerayvg jueves, 4 de noviembre de 2010 13:27 mas info
    jueves, 4 de noviembre de 2010 13:20
  • Mejor te lo pongo con imagenes.

    Cuando conecto el disco duro, hace el sonido típico de que se ha conectado un nuevo dispositivo, pero no se lanza nada y por supuesto en Mi PC no aparece la unidad de disco correspondiente. Si voy al administrador de discos lo que muestra es lo siguiente:

    http://img192.imageshack.us/i/66035061.png/

    Si le doy a aceptar, muestra el siguiente mensaje:

    http://img696.imageshack.us/i/28701669.png/

     

    EDITO: Es curioso también que esto solo me sale con uno de los discos. El otro ni siquiera es detectado por el administrador de discos aunque Windows si detecta que hay algo conectado pues hace el sonido de conexión y desconexión tipicos.

    Concretamente este segundo disco (el de 500GB) es un Wester Digital y la primera vez que lo conecte Windows se bajo un "driver" Initio Default Controller, pero no sirvió de nada.


    ¿esos discos llevan su propia alimentacion externa o la estan tomando de tu maquina?... me suena que es lo segundo y en ese caso tu maquina es incapaz de dar la corriente necesaria para su alimentacion. En los purtos USB hay dos posibilidades segun la norma, que suministren 100 mA o 500 mA. Con 100 es insuficiente para discos duros sin alimentacion y con 500 suele ser bastante justo.

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    viernes, 5 de noviembre de 2010 6:07
  • Si, son discos de 2'5 y por lo tanto la energia la suministran los propios USB.

    Estan suministrando 500mA. Lo he comprobado en los concentradores de los USB y entendería que fuera un fallo Hardware si nunca hubiesen funcionado, pero como ya he comentado no había tenido ningun problema con ellos. El problema viene de unos días para aca, de repente y sin previo aviso han dejado de reconocerlos.

    Los controladores que me están cargando en el equipo con XP son los mismo que en W7. La unica diferencia es la version ya que en XP son la version 5 y en W7 la 6 para disk.sys y partmgr.sys.

     

    En el equipo con Windows XP me detecta que el sispositivo es un SAMSUNG HM400LI (Para el disco de 400GB) mientras que en W7 es un generico USB TO IDE/SATA Device USB Device.

    La verdad es que yo tambien empiezo a pensar que sea problema de alimentación...Pero la fuente esta bien, y el resto del equipo funciona correctamente y no he añadido hardware nuevo...sino todo lo contrario...Asiq ue no entiendo por que de repente ha dejado de funcionar.

    viernes, 5 de noviembre de 2010 12:04
  • Me acabo de dar cuenta que respondí con mi otra cuenta la ultima vez (yerex_tf). Bueno el caso es que ya sé por que me pasó eso.

    Al ser discos de 2'5, toman la energía necesaria de los concentradores USB. Estos discos necesitan 5v como mínimo para funcioanar correctamente, y las concentradoras USB estan testeadas para dar esa energía y verifican un buen funcionamiento a estas tensiones. Pero, en la práctica, según la calidad del disco duro, éstos pueden solicitar picos de corriente, que superen esos 5 voltios. Las concetradoras USB se los suministran a pesar de que sus componenetes no soportan mas de 5 voltios para un funcionamiento optimo. Entonces Estos componentes que forman parte del concentrador se van deteriorando y con el tiempo acaban por dejar de funcionar. Pero recalco que lo que deja de funcionar es el concentrador, el puerto USB sigue funcionando correctamente. Pero no es capaz de suministrar los 5 voltios requeridos por los discos duros USB.

    Esto explica que los puertos sigan funcionando para dispositivos neutrales como pendrives, teclados, ratones y demás, pero no para los discos duros. Lo curiosos es la ni la placa madre ni el sistema Operativo logicamente se dan cuenta del fallo hardware.

    Desconozco si las placas actuales detectan este problema, la mia tiene ya unos añitos (+5) y ya les digo uqe no.. y creo que ninguna lo hace.

     

    Mi recomendación es comprar discos USB de 2'5 con fuente de alimentación adicional para evitar este problema o discos de 3'5 directamente (que sólo funcionan con fuente de alimentación).

    • Marcado como respuesta yerayvg domingo, 14 de noviembre de 2010 10:37
    domingo, 14 de noviembre de 2010 10:37
  • Me acabo de dar cuenta que respondí con mi otra cuenta la ultima vez (yerex_tf). Bueno el caso es que ya sé por que me pasó eso.

    Al ser discos de 2'5, toman la energía necesaria de los concentradores USB. Estos discos necesitan 5v como mínimo para funcioanar correctamente, y las concentradoras USB estan testeadas para dar esa energía y verifican un buen funcionamiento a estas tensiones. Pero, en la práctica, según la calidad del disco duro, éstos pueden solicitar picos de corriente, que superen esos 5 voltios. Las concetradoras USB se los suministran a pesar de que sus componenetes no soportan mas de 5 voltios para un funcionamiento optimo. Entonces Estos componentes que forman parte del concentrador se van deteriorando y con el tiempo acaban por dejar de funcionar. Pero recalco que lo que deja de funcionar es el concentrador, el puerto USB sigue funcionando correctamente. Pero no es capaz de suministrar los 5 voltios requeridos por los discos duros USB.

    Esto explica que los puertos sigan funcionando para dispositivos neutrales como pendrives, teclados, ratones y demás, pero no para los discos duros. Lo curiosos es la ni la placa madre ni el sistema Operativo logicamente se dan cuenta del fallo hardware.

    Desconozco si las placas actuales detectan este problema, la mia tiene ya unos añitos (+5) y ya les digo uqe no.. y creo que ninguna lo hace.

     

    Mi recomendación es comprar discos USB de 2'5 con fuente de alimentación adicional para evitar este problema o discos de 3'5 directamente (que sólo funcionan con fuente de alimentación).

    No es problema de voltage sino de la intensidad que pueden suministrar: 100 mA o 500 mA.

    Pon un concentrador USB "nuevo" con alimentador de corriente externo... y adios los problemas.

     


    Jose Manuel Tella Llop news://jmtella.com

    domingo, 14 de noviembre de 2010 13:08