none
Duda urgente sobre función en excel!! RRS feed

  • Pregunta

  • Hola buenos días,

    tengo una duda con mi excel.

    Tengo unas 500 personas y cada persona tiene un coeficiente: Javier;0,1/ Maria;0,2... ( así hasta 500).

    En otro cuadro, tengo puestas las personas y los Kg que produce cada persona. ( por ejemplo, Javier-500Kg, Maria- 900Kg...)

    Lo que yo quiero, es hacer que si pongo Javier en la columna esa, me coja su porcentaje y lo multiplique por los kilos que pone al lado.

    Ejemplo: Javier-500Kg   Seria 500Kg*0,1(su porcentaje)=50

                  Maria-100Kg  Seria 100Kg*0,2 ( su porcentaje)= 20

                  Javier- 1000Kg Seria 1000Kg*0,1 ( su porcentaje)= 100

                  .... Así muchísimos más, solo que en vez de tener dos nombres, tendríamos 500.

    La cosa es que en la primera celda de segundo cuadro ( al lado de los Kg), podría ser Javier, Maria... y por eso, quiero poner una formula para que coja el porcentaje de la persona 1 o de las 400 por ejemplo. Si el porcentaje de la persona 400 fuese 0,7, tendría que coger ese porcentaje y multiplicarlo por los Kg que le pone al lado...

    miércoles, 31 de mayo de 2017 10:48

Todas las respuestas

  • Hola beñat93:

    Como fórmula se me ocurre Buscarv:

    Teniendo en cuenta que la primera tabla están en las columnas 1 y 2 y la segunda tabla en las columnas 3 y 4 y que contamos con encabezados de fila:

    =BUSCARV(C2;$A$2:$B$4;2;0)*D2

    Pon la fórmula en E2 y arrastra:

    NOMBRE % NOMBRE PESO FORMULA
    MARCOS 0,2 CARLOS 4000 3600
    MANUEL 0,5 MANUEL 5000 2500
    CARLOS 0,9 MARCOS 6000 1200


    Te recomiendo que uses ID en lugar de nombres, o cualquier identificador que sea único.

    Saludos.

    viernes, 9 de junio de 2017 13:00